Tuner not available


#1

I currently have an AT4 that constantly goes to Tuner Not available. Once you get that message, the only thing you can do is restore the Apple TV and set it back up to use the Channels App. This is the only way to get rid of the message. It loads the guide icons as if you can actually watch the channel. Everything seems normal. The signal is good and the router is in the next room. I get all 5 dots on the network test. Netflix, Hulu, Plex all play normally. Even removing the Channels app and putting it back does not fix the issue. It seems to remember settings from iCloud or one of the other Apple TV’s.

You can do a scan for tuners on network and it will find my two HDHR Primes without and issue. Scans for channels without an issue. I’ve even tried switching back and forth between the two Primes and nothing. When I look at the HDHR’s there are no channels in use as the tuner LEDS are blank. I can start one of the other AppleTV’s and one of the LEDS light up. I’m not understanding what’s going on with this thing. I returned the previous Apple TV because I thought it was the problem. Turns out it’s not.

I have 2 other ATV4’s that do not have this problem. I can use the HDHR view app and Windows Media Center an never get this message. I only used WMC because Silicondust asked me to test it.

Equipment:
2 HDHR Primes (6 Tuners)
3 ATV4’s

Each Apple TV is named something different to indicate which room they are in. If anyone has a solution, please let me know. Restarting the HDHR’s and removing the cable cards do nothing.


#2

Thanks a lot for writing up this issue. We’ve heard isolated reports from a handful of other users and are anxious to track down the issue.

It’s really interesting that only one of your ATVs is affected. Can you check if they all have the same version of tvOS?

Are they all on wifi?

Do you happen to have a usb-c cable and a Mac with Xcode to look at the ATV logs?


#3

I have a issue just like this. What’s weird is it only sometimes happens and is only prevalent when the Apple TV is connected via Wi-Fi, with ethernet it does not happen. What is even weirder is with the beta version of channels I have not seemed to encounter this issue. It is only with the public release on the app store for the Apple TV. Something also note this does not happen on the public version of the iOS app. So not necessarily sure what exactly was changed in the AppleTV Beta (I know that there was a lot of back end code that changed and that could’ve been why this issue has not been occurring in that build) however it is something to note.


#4

I have seen the tuner not available message on ATV and iOS but always when trying to tune an OTA station of low signal strength. When I switch to a strong station the message goes away and app works. Could something be timing out waiting for data?


#5

Well, I’m not using OTA channels. Only cable card.


#6

Two of them are on Wifi and one ethernet. I did find a little trick that is working so far. Not sure how long it will. Since I have my router set to broadcast the 5ghz channel and 2.4ghz channel separately with appropriately named SSID’s. I switched to the slower SSID and it found the tuner. I then went back to the 5ghz channel and it seems to be working so far. I’ll see if it stays.

The other Apple TV i have on wireless has never had this problem and they are set up identical.


#7

What firmware is your Prime using?


#8

@tmm1 Right now it is using 20160630atest2 which loads with the 7/30 version you see on the website. I’m using the latest DVR software.

I’m also having an issue with DRM channels not being unlocked, but that’s another subject.


#9

Just bought and installed Channels today to watch some Olympics on an OTA HD Homerun + ATV4. Getting the same Tuner Not Available error. However, in my case, restarting the ATV seems to get it out of the locked state and it works again, at least for a while. It does seem to correlate on some level with degradation of the TV signal; I saw it at least twice after a few moments of garbled video.

I’m running an older 2-tuner HDHR and Channels upgraded the firmware for me we it first detected it, I want to say to a 201506xx version. I don’t recall the exact number.

When the TNA error occurred, I went over to a PC with HD Homerun VIEW on it and was able to use the tuners without issue, watching the same channel (NBC) that was locked up on the ATV.

I have a mac, xcode, and a cable if there’s some log info that would be helpful to pull.


#10

That would be incredibly helpful. Under Xcode, Window > Devices click your Apple TV (after plugging in over usb-c) and you can see logs on the bottom right.

I’d recommend attaching the Mac and then copying the new log messages that show up when you try to play a channel.


#14

I attached the logs as requested. Sorry, I had to break it down into 3 pieces because it would not allow me to post all at the same time.


#15

Thanks so much @mythicalcaesar. I downloaded the logs and deleted the messages above to prevent clutter.

I assume you got that Tuner Not Available error every time you tried to watch a channel?


#16

Yes, I got them earlier. This time it actually works, but then I still can’t tune certain channels. That was until I either erased the apple tv completely or now I change SSID’s to go from 5ghz to 2.4ghz. I’m trying to see how long it will last. I usually get a day or so out of it and then go back to Tuner not available.

My other 2 Apple Tv’s have never had this problem.


#17

Just released a new beta which might help with the Tuner Not Available errors. Please download and try it out.


#18

Not to sound crazy, but I can’t seem to download the beta software. Is there a secret that I’m missing?


#19

got it. downloaded and trying now.


#20

I hooked up my macbook and fired up Xcode, but the ATV didn’t appear in My Devices. Do I need a dev kit or special component to access the device? (Yes, it was connected via USB-C too :wink: )

In any case, I brought up the logs directly on the ATV diagnostics pages, and there’s only a single Channels*.ips entry there. It says “SIMULATED event [not a crash]” and reports exception code 0x8badf00d. The backtrace goes through MPVKit below Channels. The log says “failed to update scene after 10.0s”.

That’s all I have for you right now.


#21

I’ve has tunner not found issues that I detirnned was related to the router. I’ve had zero problems since switching to a Ubiquti ER-X https://www.amazon.com/Ubiquiti-EdgeRouter-Advanced-Gigabit-Ethernet/dp/B00YFJT29C

With a UniFi AC lite access point.

Ubiquiti has some new consumer router wifi system which should work great out of the box:

Amplifi.com


#22

Well, I haven’t had any issues yet with the beta version. Good advice though, I have 3 apple TV’s and only one of them gave me problems until recently.


#23

We’ve released v1.5.5 to the App Store with a fix for this issue!