TVE losing Discovery owned channels

I started getting 403 errors with Discovery channels and Mediacom cable. I went to the Discovery website and entered cable credentials there, which was accepted. After doing this, I rescanned the channels in Channels DVR and the errors went away.

That's similar to my experience

Wonder if @tmm1 DISCOVERed anything (pun intended)

I had the issue with the Discovery channels on 2/22, and then again today. Today I had to remove Spectrum as a source, and then re-add it.

I've been fortunate since I moved my TVE source from a Docker Container to a Synology Package install.
When channels need re-authed, Channels DVR has handled it seamlessly.
If it's a recording, Channels DVR re-auths the channel and starts the recording.
If it's while watching Live, Channels DVR re-auths the channel and starts the playback.
It may take anywhere from 30 seconds to a couple minutes, but it's now seamless.

Xfinity if it matters.

Knock On Wood

I do know what some of the terms you are using mean, however, I am using Channels on Windows, so I don't think I have those options.

Spectrum here if it matters...

Not sure if my situation applies to Windows and Spectrum.

When running Channels DVR in a TVE Docker Container, it includes it's own version of headless-chrome.
It was constantly getting corrupted, see Losing locals when updating version only in docker container
But installing using the Synology Package (uses an almost identical version of headless-chrome) I never get a corrupted chrome error in Diagnostics and Channels DVR now automatically re-auths any TVE channels whose auth has expired.

Pretty sure with a Windows install it uses the version of Chrome you installed in Windows.

The only things I've done that most probably don't is to login to my secondary account I use for TVE every week to check if my Provider is asking me to add recovery info for the account (which will make a Channels DVR re-auth fail) Xfinity, Ask me later and I use the source Update Password to clear the chromedata folder TVE Troubleshooting tips anytime Channels DVR re-auths a channel.

So I decided to try to experiment with this some more. My server it running on Windows, and I had it set up as running as a service so that if I lost power, Channels would start up again once power was restored among other reasons. I switch it back to running normally, requiring a user to be logged in. The next day after the change, I lost discovery owned channels again, and the only way I could get them back was to delete and recreate the TVE tuner.

I decided to let it keep going this way rather than switch it back to a service right away. 5 days later, I lost discovery owned channels again, but they came back after I watched a non discovery owned channel for a few seconds and came back. It's now been about 4 days since then, and I still haven't lost them yet, which I did almost every other day when it was running as a service.

I would assume that it is running headless when it is running as a service, so that might be one thing to look at. My setup is an older (4 years maybe) I-5 PC running Windows 10 Home. Only browser is Edge, and I am using Bitdefender for antivirus and firewall. Windows has all patches installed up to today.

1 Like

I also run Channels as a service, for the same reason.
Windows 10 Pro, no antivirus (don’t tell anyone) no firewall.
Also on an old Dell 8300 i5

Today I tried to watch Travel (a discovery channel) on TVE and got a tuner not available message. I tried a channel I knew wasn't a discovery channel (Hallmark since it was the closest on the guide), and it worked. I then went back to Travel, and it worked. So, I'm guessing something is still going on with the login, but it's an easy fix to go to a non-discovery channel and back, and it is definitely working better when it is not running as a service.

Check the DVR log.
It may have had to re-auth that channel when you tuned it.
Channels DVR has been re-authing channels automatically for me when it needs to.
Takes anywhere from 20 seconds to 2 minutes, but it's been working.

1 Like

I can confirm the same as @chDVRuser i have been watching my logs and it is doing the re-authentication. I run on the rpi setup that is provided and for couple weeks now been stable haven’t needed to take the trouble shooting steps. I’m still on beta 2022.02.28.1826 for that matter. My observation 2cents is between the sci-fi fix and runtime improvements they made back in February sure seem to have helped.

Is there an option to increase the time out so that when I have a channel that takes to longer to reauthenticate and get the tuner notavailable message. It would save having to go back and come back in.

No there is not.

That would be nice, yes. But currently not possible.

Unfortunately, losing the Discovery owned channels is getting worse. They lose the login on a daily basis now, and I've had them lose the login more than once in a day a couple times. It is easier to get them back, Once you get the error message, tune to a different Discovery owned channel for a couple seconds where nothing will happen and then tune back to the one you want and eventually it will start to play, usually takes about a minute, though I have had it take longer to start.

With the channels going out like this you can't schedule anything to record since it will have lost the login by the time the recording is supposed to start. I've gotten to the point where I only record so that I get a reminder that something new is available that I want to watch and then use the specific channel app to stream it.

Using Xfinity I find the auth expires on Discovery channels every 7-8 days.
I've been keeping track.
Recordings get delayed 40-50 seconds if it has to re-auth to start the recording.
Worst case time was 3 1/2 minutes once a couple months ago.
If I start to watch a channel live in the web UI viewer when it needs to re-auth you can see it says reconnecting, then the video window goes away and when it finishes re-auth the audio starts to play with no video. Much different log entries compared to when a recording causes re-auth.

I'm glad your experience with Xfinity is better than what I'm having on Mediacom. When I lose access I have to do what I said above to get it back. If I just let it sit on the channel I get nothing except the error message.

Each channel has it's own auth token.
Renewing auth for one channel doesn't renew them all.
You can tell by looking at the dvr log.
I would submit diagnsotics from the client app (which I heard also submits it from the server).

Continuing the discussion from TVE losing Discovery owned channels:

I'm now having the same "403: (access.denied.missingpackage)" issue. Tried moving to the DVR pre-release, which did not work. i also tried rescanning the individual channels, too.

Discovery suite seems to be working fine here.

I have the issue with HGTV; and now another with Comedy Central (notAuthorized: A network error occured when communicating with the provider's authorization service).

I'll also report in the Beta forum.