TVE - Recordings files crashes Win Explorer

I have a secondary Channels DVR on my pi4 fine, slower than my main server, thats using a i7 3.2ghz of course.

But when i enable the Samba share option, when ever i open the folders to look at or mess with the .mpg files Channels makes, it fully locks up Explorer in Win 10 and causes it to crash then restart.

It does it trying to load the file thumbnail, or if i try to open the file, or right click it, instant lock up.
I can quickly drag and drop the file to the desktop of the same computer(copying the file from the Pi to the computer) and the file is fine, no issues.

Its not specific to the computer, any Win 10 computer i have, even a just reset clean win 10 unit, it can't deal with your Samba share.

Does not affect MacOS or Linux.

Using the Channels image flashed to a usb 3.0 stick.
OS updated and so is the server to the latest pre-lease as of yesterday afternoon.

Edit: Win does not, overall, like .mpg files.....but has no issues with .ts files....i have noticed. Would be really nice to ditch .mpg, isn't it antiquated/vintage a file extension anyway? i recall them a thing in the days of .wmv and .avi? early 2000's.

EDIT: Further troubleshooting revels this is a TVE issue, and not exclusive to the Pi.

This sounds more like TVE Beta: Recordings causing problems with Windows Explorer

OTA recordings are not affected, and I thought in the past someone tried to rename TVE recordings to .ts and the same problems occurred.

Regardless it's not related to Samba

Any file the Pi server makes, is having this issue for me, right out of the box.
Even OTA.

Has to be something on the Samba side or how Channels is hosting the file...idk....cause if it was the files it self, then the issue would persist no mater where the file is stored or moved to, local, or external usb stick. The issue happens only when I try to access and use the Samba powered file share you image offers.

I don't have this issue with my main server, that is running on normal Linux install, I did have a file access permission, that was infact Samba user related that I had to do something to tweak the samba config file to fix, but that did not cause Explorer to crash and be un-useable, it just prevented me from deleting the dvr files over the network.

Okay thanks for clarifying.

Ok. I have only used it for a few test records, but it does seem that at least one OTA record file seems to work fine, if i open that program folder directly only that is.

When i try to load the root TV folder, and it has any TVE program folders with files in it, it tries to load thumbnail for the folder and will start to lag, and its a generic white file icon and it causes Explorer to globally not show any file thumbnails anywhere on the computer, until it locks up and auto restarts it self, or I use task man and manually restart Explorer.

Edit: Also, If i try to play the TVE file, it never loads in my MPV player(or any other media player), but it is like it is always still trying to in the background, as the usb stick is blinking full on, until i disconnect the wifi/ethernet of the computer to break the connection.

This may not work either, but have you tried the VLC media player?

I stated, doesn't matter the media player.
Also, since explorer locks up, you can not right click and do the open with thing to choose a differnt player.

If you copy one of those files to another folder, rename to .ts, then open SMB directly to that folder does it still hang up or is it fine like the OTA folders?

Not possible with Win 10. Like I said, the moment i open the TV folder, or even the main root folder of the share, and there is a TVE folder there, or a sub folder of the TV folder, it starts to hang, trying to load read the folders.

if i very quickly go into the recorded program folder, i can only just drag and drop the raw file to my desktop(computer I am accessing the share from).

If i try to have open another Explorer window, of a folder i created on the server share, and drag it to that, the copy dialog comes up, but freezes at 0% then Explorer crashes.
This also happens if i try to copy the TVE program folder with the file in it as well. so can not do anything on the folder level.

The thought occured to me....I for got you can shutdown the Pi, and pull the usb stick out and connect it up to computer to access the library that way.

So....its does the same thing direct loading the USB stick.

However, it i only right click on the file once, and just let it sit for about 2 min, it does load the context menu, and does not crash like it does over Samba.

So, not a Samba specific thing, but something in how your image is saving the files/folders...etc.

Replaced the crap slow usb stick i was using....with a fast ssd, to remove that bottle neck.

I recall reading somewhere that only some TVE stations recordings would cause this issue, I recorded a 30 min show on C.N. and it is not causing the Explorer crash when i acces the TV folder over Samba.

Going to do a few more test TVE records and see if the issue comes up again.

Still haveing this issue.
Recorded Dr. Pol on Nat Geo Wild channel, and trying to open that folder locks up Explorer.

Also I notice, that even restarting Explorer, the OS will no longer populate thumbnails, only show white file icon, I have to log out of the OS, or restart computer, inorder for it to show the file thumbnails and icons again....when ever I access the DVR folder on the Pi that triggers this.

Pretty serious this makes it not useable to do what i wanted to do with the Pi, setup a secondary server, so that my mother can record, access its dvr share, and pull off the files on her own.

As it stands now, using my main server, I go into the OS(Linux Mint) and run a batch file copy script from FreeFileSync, to copy the DVR folder to a separate partition on the internal drive, then an other script to set the linux file permissions so she can also delete the files. Doing this, there is no issues or File Explorer issues. But i am trying to eliminate me having to do all that.

Something else to note...

When I use my mothers laptop to access the file share, that computer has VLC as default video player, it actualy loads the video thumbnail fine, but, right click on the file or folder, or try to play it, and it locks up/crashes Explorer.

Must be some thing malformed metadata in the video file that Windows hates...

Cause, now i copy the file or folder with the file in it, to my computer, and it will locks up and crash's after a bit, cant rename or right click. But, it will open and play just fine.

If i remux the file to .mkv using mkvtoolnix...the file causes no issues at all.
I also tried a remux/stream copy using ShannaEncoder to .TS and same thing, works fine. (though .ts does not show a thumbnail, it just sits trying to load one)

So it seems to me it something in Channels and how it is writing the file and its extension or whatever.

I have seen other threads about other requesting the files to be something other than there any way to make a build so that TVE files get put into a different container format?

There has to be a way fix this. Has to be a root cause.

Maybe adding in a post processing option, to remux the files to .mkv/.ts/.mp4 (using ffmpeg perhaps) so that users can also get what they want, and would be a good test to see and prove that remuxing the file to a different container, resolves this issue.
(Emby had a option to do this, where it would trigger a action to remux to mp4 for a "player device friendly format"

More like the problem is with poor-formed streams from the source; especially since Channels just saves the streams as they are received, without modification.

Sure: the networks can actually adhere to standards and send sane streams.

This would be welcomed, but shouldn't be necessary. This is the reason why some channels had to be removed from TVE: the networks are sending malformed feeds.

I don't see it being the streams fault....Channels is the one making the file and encapsulating it as .mpg same as if you use ffmpeg to raw capture a stream, and it is set to out put that data into the user selected file extension file container format.

Since remuxnig the file, it is STREAM copying the raw data, thus that proves, that the video and audio data being sent to channels, is not the issue, it is the file container in how it is being written and closed out and its headers/metadata.

If i record and use Channels as a tuner for Emby, and record that same TVE stream, guess what, that resulting .mpg file is fine. and all it is doing is raw capturing the same data stream.
If i use VLC and record the stream from channels, using the url links u can export, its file is fine.

Also, if the stream it self was bad, then it would also cause issues in other OS's i would think.

And by your own reasoning, it thus has to be necessary then, to add a post process remux, since, it is not possible to get the networks to "fix" their stream, if that is the root cause.

And removed TVE feeds due to malformed streams is a very differnt thing and issue.
Those had issues playing at all, live.
These video stream play fine live and have no issues playing back in Channels

I am just saying, its a possible workaround or option to restore needed core functionality of having a DVR software that stores its files so that the user can save them.

But, the cop out approach of blaming it on the network stream provider, and perhaps, the devs deciding to ignore trying to figure out a solution or useable quite frustrating.

Because Channels is using Ffmpeg to repackage the stream upon reception. They are fixing what they were given. It's not fixed upon reception, but it is upon delivering to your external third-party application.

Frankly, that's bullshit. The developers are active contributors to both Ffmpeg—which handles reception of streams, transcoding, and remuxing—as well as mpv—which is the project that handles the display/presentation of the received video.

Essentially, GIGO. Garbage in, garbage out. If they get crap from the networks, they can only give you crap back. If you want to fix this, go for the head: complain to the source of your issues, informing them that they are impeding your ability to ingest their content because their internet streams are malformed. If you are aware that their stream is a problem, but make no effort to address the problem, you are becoming part of the problem, and have no room to complain.

So then it should be a easy and trival thing to then use ffmepg again, and run the remux of the file.....since , that is exactly what users are doing to "fix" the file and prevent this issue.

And its a problem when one refuses to listen or consider a working fix/workaround when it is presented to you.