Ubuntu 20.04 TVE issue with chromium package

Hey,

I started getting some strange errors, such as 'context cancelled' when trying to watch some of my TVE channels. I tried rescanning channels, but that ended up with me losing all of the channels. I've done a number of things trying to get them back including, removing and readding my TVE sources, and moving all of my channels-dvr data out of the way and setting up from scratch on the latest version (2020.12.12.2011).

When I try to add TVE sources now I see errors like this:

could not dial "ws://127.0.0.1:37059/devtools/browser/2aeb0347-cf5e-45cf-b650-30cbd7107edf": EOF

The relevant log entries are:
2020/12/13 21:55:30.130495 [TVE] Auth starting for ATT as [email protected]

2020/12/13 21:55:30.130781 [TVE] action=auth mvpd=ATT requestor=nbcentertainment

2020/12/13 21:55:31.757073 [TVE] Auth failed for ATT: could not dial "ws://127.0.0.1:37059/devtools/browser/2aeb0347-cf5e-45cf-b650-30cbd7107edf": EOF

Anyone have any idea how to fix this?

Thanks!

Chrome is not installed or too old

I think I have the latest version available for Ubuntu 20.04:
ii chromium-browser 1:85.0.4183.83-0ubuntu0.20.04.2 amd64 Transitional package - chromium-browser -> chromium snap

I looked in to this further and it seems Chromium was recently upgraded.

I was able to fix this by reverting back to the previous version:

sudo snap revert chromium --revision=1421

It's working again for now.

1 Like

As of last night, I started getting these errors on some channels as well. I am also running Ubuntu 20.04 - though my provider is Philo.

I, unfortunately, had tried uninstalling Chromium and re-installing, which removed the previous version from my machine so I couldn't revert. Trying to remove the lineup and re-signing in didn't work. I was getting errors when it tried to authenticate (context changed sometimes. Others this similar could not dial error)

Now, since this was completely broken, I seeked out other means. I tried refreshing to the edge and beta snaps, but that didn't help. So it seems something has changed in these 20.04 snap builds that is causing authentication to fail (maybe?)

For now, I got it working by using the official build from 18.04 (the solution on the bottom):
https://askubuntu.com/questions/1255692/is-it-still-possible-to-install-chromium-as-a-deb-package-on-20-04-lts-using-som

1 Like

THIS!!! I'm having the same issue and this thread has resolved it. Thank you very much!

Can you share the output of this command:

chromium-browser --version

Chromium 87.0.4280.88 snap

I don't think the issue is with the Channels DVR software. It seems to be an issue with headless Chromium in the new snap in general. Also, the version number you get when you run chromium-browser --version is the same on both the working snap and the broken snap, but the sizes are significantly different based on the output you get from snap info chromium:

[email protected]:~$ snap info chromium
name:      chromium
summary:   Chromium web browser, open-source version of Chrome
publisher: Canonical✓
store-url: https://snapcraft.io/chromium
contact:   https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bugs?field.tag=snap
license:   unset
description: |
  An open-source browser project that aims to build a safer, faster, and more stable way for all
  Internet users to experience the web.
commands:
  - chromium.chromedriver
  - chromium
snap-id:      XKEcBqPM06H1Z7zGOdG5fbICuf8NWK5R
tracking:     latest/stable
refresh-date: 2 days ago, at 20:18 CST
channels:
  latest/stable:    87.0.4280.88 2020-12-10 (1424) 124MB -
  latest/candidate: 87.0.4280.88 2020-12-10 (1424) 124MB -
  latest/beta:      88.0.4324.41 2020-12-15 (1441) 144MB -
  latest/edge:      89.0.4350.4  2020-12-11 (1434) 257MB -
installed:          87.0.4280.88            (1421) 254MB -

I just created a new Ubuntu 20.04 VPS to test it out, and sure enough it's broken:

[email protected]:~$ chromium --headless --remote-debugging-port=9222 https://chromium.org
mkdir: cannot create directory '/run/user/1000': Permission denied

DevTools listening on ws://127.0.0.1:9222/devtools/browser/d466c669-1a60-4db0-ac8b-103e5e6e1b01
[0100/000000.275108:ERROR:zygote_linux.cc(607)] Zygote could not fork: process_type renderer numfds 4 child_pid -1
[0100/000000.276508:ERROR:zygote_linux.cc(639)] write: Broken pipe (32)
Trace/breakpoint trap (core dumped)

I'm running the command from this Headless Chromium README just to test, figuring it should definitely work. As expected, on the system where I had version 1421 of the snap and was able to revert back, that same command works fine:

[email protected]:~$ chromium --headless --remote-debugging-port=9222 https://chromium.org

DevTools listening on ws://127.0.0.1:9222/devtools/browser/1244bb3e-f709-491d-af5e-d2dfecd62b73

Anyone following the installation instructions that are installing Chromium on Ubuntu for the first time will run in to the issue and need to find a different workaround since they won't have the old snap to revert back to.

1 Like

This part is strange and I wonder if it's related?

Can you try chown that dir to see if it helps?

Similar report here: https://unix.stackexchange.com/questions/579448/why-are-the-permissions-of-run-user-1000-wrong

That error went away on subsequent runs:

[email protected]:~$ ls -ld /run/user/1000
drwx------ 5 tjcravey tjcravey 160 Dec 15 17:43 /run/user/1000
[email protected]:~$ chromium --headless --remote-debugging-port=9222 https://chromium.org

DevTools listening on ws://127.0.0.1:9222/devtools/browser/b6131f17-e10a-43fb-ab2f-ff280b32dc6a
[0100/000000.996377:ERROR:zygote_linux.cc(607)] Zygote could not fork: process_type gpu-process numfds 3 child_pid -1
[0100/000000.996624:ERROR:zygote_linux.cc(639)] write: Broken pipe (32)
Trace/breakpoint trap (core dumped)
1 Like

Thanks for all the info. I'll spin up a VPS and see what I can figure out..

Looks like you already filed this upstream :slight_smile:

I’m experiencing the same issue and rolling back Chromium to 1421 fixed it. Any leads on a permanent fix?

Thanks!

The fix is up to Ubuntu. We reported it to them above so hopefully they can figure it out.

If everyone experiencing the problem could mark that the bug affects them too, it might help it get some priority. So far it's been ignored since the initial triage.

https://bugs.launchpad.net/ubuntu/+source/chromium-browser/+bug/1908284/+affectsmetoo

I have a work around for someone that doesn't really care if they dont run the latest chrome. Got me up and running on 20.04 fresh install.

sudo snap remove chromium
wget http://dl.google.com/linux/chrome/deb/pool/main/g/google-chrome-stable/google-chrome-stable_85.0.4183.102-1_amd64.deb
sudo dpkg -i google-chrome-stable_85.0.4183.102-1_amd64.deb 
sudo apt --fix-broken install
cd /usr/bin
sudo rm -rf chromium-browser
sudo ln -s google-chrome-stable chromium-browser
1 Like

An easier workaround is to install the fonts-dejavu-core packge and then remove and reinstall the chromium snap. I just tested and it worked for me. I found this in the Ubuntu bug report.

sudo apt install fonts-dejavu-core
sudo snap remove chromium
sudo snap install chromium
1 Like

I can confirm that gdrapp's instructions corrected my issues I was attempting to add Sling TV as a source and was getting "context cancelled" or something like that. I am using latest version of Channels with fully updated 20.04 on a RPi4.