Unable to discover DVR server

One of my fireTV's is connected to my network VIA Wifi.

It seems that is the only client that I am unable to discover my DVR server on. Even when I manually type in the correct IP address

I have manually reserved the DVR server's IP address on my router, so that it does not get re-assigned. I have tried unselecting and reselecting the Bonjour check box as recommended in some other threads i have read, and that allowed me to connect for a short time (around 5 minutes) before getting disconnected around 1 minute in to a recorded show, and then being unable to connect again.

I downloaded a Bonjour Browser on my iphone, and am able to find the DVR server listed as _Channels_app._TCP. and _channels_dvr._tcp.

I submitted diagnostics previously from the client that is unable to connect.

DVR Server Info:

Gigabyte Technology Z97-HD3
Windows Microsoft Windows 10 Home
10.0.19041 Build 19041 (kernel: 10.0.19041 Build 19041)

8 cores / Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz
load averages: 0.00 0.00 0.00

15.86 GB
58.0% free

Bonjour info:

Advertising dvr-desktop-rddea13.local. via 2 networks: []

Any help would be greatly appreciated.

This is a long shot, but I would recommend that you force an IP address that is well outside of the normal assignment range, like:

What is the IP of the FireTV that's not working?

Is it maybe connected to guest Wi-Fi? is the IP address of the Firetv. But that one is not a reserved address. Only my dvr server and HDHomeRun have reserved ip’s on my network.

Okay I just wanted to make sure it was the same subnet.

You could try installing a web browser on that FireTV and see if it can load the dvr web UI

Yep. For some reason that worked. I’m able to view the dvr dashboard an connect to the dvr server in the channels app now.

Edit: so I was able to see the dvr dash briefly. Fired up a recording and a minute in it stopped. Tried to restart it and playback failed. Forced the app to stop and restart, and I’m now unable to connect to the server again in the app but I’m able to connect via web browser. In app I manually type in dvr address, and get the error that the dvr server was not found at

Okay I think it's an issue with the older FireTV model. I'm working on a fix in beta.

I pulled logs off of the fireTV and sent them over to the support email. this is a 2nd gen firetv box, and my 4k stick and iphone don't seem to have any issues connecting.

Try this apk: https://cdn.channelsdvr.net/apk-beta/channels-dvr-203112204.apk

Installed it, and it still does not automatically detect the dvr, and won’t connect if I manually type in the IP of the server

Edit: it connected after manually entering it the third time.

Edit 2: tried loading up a recording and it disconnected after about 5 min.

Can you submit diagnostics

You got it. Just submitted.

Seems like a bad network connection. Maybe try the speed test option under settings > support.

This FireTV box uses a legacy Android 5.1.1 which causes lots of issues. If it doesn't work the best thing I can suggest is to upgrade to a newer device.

Seems like your right. I was able to get connected, ping was around 150ms jitter around 168, and speed to the dvr server was around 16Mb. Not ideal. Might have to figure out a way to fish a network cable up to the bedroom.