WD MyCloud: Chrome Crashing

Does anyone have a fix for chrome crashing in ChannelsDVR TVE. This seems to cause "Connection Lost" display errors for Spectrum TV extended channels line up. Equipment: PR4100 NAS and HRHD3-CC Prime w/spectrum cable card. Local network channels display normally. Rescanned Spectrum source and got check boxes for extended cable channels. All component firmware is up to date and reboots performed on NAS and HRHD Prime.

Did you update Chrome to the latest version? Or try chromium?

According to a recent email response from Channels tech support, the newest WD PR4100 firmware update (5.27.157) included a new version of Chrome that is incompatible with the Chrome version in the ChannelsDVR app. They are working on an update to fix it.


Update on Chrome failure error log of Spectrum settings Channels DVR server via HDHR PRIME (1323CD5F) cable card:

chrome failed to start: [1027/170740.303178:WARNING:resource_bundle.cc(456)] locale_file_path.empty() for locale /bin/sh: /mnt/HD/HD_a2/Nas_Prog/ChannelsDVR/channels-dvr/data/chromedp-chroot/lib/x86_64-linux-gnu/libcrypt.so.1: version XCRYPT_2.0' not found (required by /bin/sh) /bin/sh: /mnt/HD/HD_a2/Nas_Prog/ChannelsDVR/channels-dvr/data/chromedp-chroot/lib/x86_64-linux-gnu/libm.so.6: version GLIBC_2.29' not found (required by /bin/sh) [1027/170740.570291:FATAL:zygote_communication_linux.cc(255)] Cannot communicate with zygote #0 0x7f4955bac2f9 (/mnt/HD/HD_a2/Nas_Prog/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x684f2f8) #1 0x7f4955ae7a83 (/mnt/HD/HD_a2/Nas_Prog/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x678aa82) #2 0x7f4955afd4c0 (/mnt/HD/HD_a2/Nas_Prog/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x67a04bf) #3 0x7f495389ebf8 (/mnt/HD/HD_a2/Nas_Prog/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x4541bf7) #4 0x7f495389f2e7 (/mnt/HD/HD_a2/Nas_Prog/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x45422e6) #5 0x7f4954482c20 (/mnt/HD/HD_a2/Nas_Prog/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x5125c1f) #6 0x7f49544809b9 (/mnt/HD/HD_a2/Nas_Prog/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x51239b8) #7 0x7f49544814ce (/mnt/HD/HD_a2/Nas_Prog/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x51244cd) #8 0x7f4955adf076 (/mnt/HD/HD_a2/Nas_Prog/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x6782075) #9 0x7f4955adeeee (/mnt/HD/HD_a2/Nas_Prog/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x6781eed) #10 0x7f4955adec42 (/mnt/HD/HD_a2/Nas_Prog/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x6781c41) #11 0x7f494edfb09b __libc_start_main #12 0x7f49526b632a _start Received signal 6 #0 0x7f4955bac2f9 (/mnt/HD/HD_a2/Nas_Prog/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x684f2f8) #1 0x7f4955ae7a83 (/mnt/HD/HD_a2/Nas_Prog/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x678aa82) #2 0x7f4955babd81 (/mnt/HD/HD_a2/Nas_Prog/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x684ed80) #3 0x7f494f347730 (/mnt/HD/HD_a2/Nas_Prog/ChannelsDVR/channels-dvr/data/chromedp-chroot/lib/x86_64-linux-gnu/libpthread-2.28.so+0x1272f) #4 0x7f494ee0e7bb gsignal #5 0x7f494edf9535 abort #6 0x7f4955baaf05 (/mnt/HD/HD_a2/Nas_Prog/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x684df04) #7 0x7f4955afd917 (/mnt/HD/HD_a2/Nas_Prog/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x67a0916) #8 0x7f495389ebf8 (/mnt/HD/HD_a2/Nas_Prog/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x4541bf7) #9 0x7f495389f2e7 (/mnt/HD/HD_a2/Nas_Prog/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x45422e6) #10 0x7f4954482c20 (/mnt/HD/HD_a2/Nas_Prog/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x5125c1f) #11 0x7f49544809b9 (/mnt/HD/HD_a2/Nas_Prog/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x51239b8) #12 0x7f49544814ce (/mnt/HD/HD_a2/Nas_Prog/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x51244cd) #13 0x7f4955adf076 (/mnt/HD/HD_a2/Nas_Prog/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x6782075) #14 0x7f4955adeeee (/mnt/HD/HD_a2/Nas_Prog/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x6781eed) #15 0x7f4955adec42 (/mnt/HD/HD_a2/Nas_Prog/ChannelsDVR/channels-dvr/data/chromedp-chroot/headless-shell/headless-shell+0x6781c41) #16 0x7f494edfb09b __libc_start_main #17 0x7f49526b632a _start r8: 0000000000000000 r9: 00007ffc2f45b5d0 r10: 0000000000000008 r11: 0000000000000246 r12: 00007ffc2f45c910 r13: 000000000000005c r14: aaaaaaaaaaaaaaaa r15: 00007ffc2f45c050 di: 0000000000000002 si: 00007ffc2f45b5d0 bp: 00007ffc2f45b820 bx: 0000000000000006 dx: 0000000000000000 ax: 0000000000000000 cx: 00007f494ee0e7bb sp: 00007ffc2f45b5d0 ip: 00007f494ee0e7bb efl: 0000000000000246 cgf: 002b000000000033 erf: 0000000000000000 trp: 0000000000000000 msk: 0000000000000000 cr2: 0000000000000000 [end of stack trace]

Are you able to SSH into the NAS and run commands?

Sorry, I'm not that advanced. Of course I can get into the NAS menu masks and can probably login into the Secure Shell but I'm not good with Linux. Although, I think you are pointing to prior firmware where chrome was working. I'm intrigued.

Trying to add Hulu back into channels DVR and getting “Context Cancelled”

1 Like

@meitis are you able to run commands for @tmm1?

Not yet. I'll try tomorrow.

I am able to SSH into the MyCloud using Putty.

Run these and paste the output here:

which ldd

ldd --version

As I wrote Eric today, I am unable to load the commands you sent. Just a noob. With SSH open, I tried to paste the commands into the utilities system config mask, no go.

Another user was quick to suggest using the Putty app. However, I can't find another PR,4100 GUI option that allows me insert command code.

If there is anything else you can think of to help resolve the Chrome issue, please let me know.


google is your friend :wink:


It's not Google, but you a friend. Thank you for the guidance regarding Putty. I did get in to SSH to test the commands I was sent.

I had the same issue on my Pr2100, (ERROR was CONTEXT CANCELLED) so I went looking to roll back my PR2100 to Firmware 5.26.300 and “IT WORKED”.

I also turned of the auto update of the FIRMWARE until a fix is found.

Firmware Links from WD

Hope this help anyone with a WD MyCloud

1 Like

I also wanted to roll back my PR2100 firmware and disable auto updates but wasn't able to find any links to previous firmware on WD support site. Can you provide the link to where you found it? Once available did you simply install it using the option to "install manually". Thank you

I thought my firmware was already 5.26 but think it is 5.27 so link you provided should be what I was asking for. Question still then on steps you took to install. Thanks again.

Hooray! I too was able to manually rollback WD MyCloud PR4100 firmware to OS 5 5.26.300 firmware. Download your version at WD: My Cloud OS 5 Firmware Release Note 5.26.300 - Announcements - WD Community
My Chrome failure woes are gone for now; I'm able to update my source and play DVR TVE. Channels lives again. Be sure to switch Off the auto update feature. Let's hope there's a WD or Channels app firmware fix in the offing.
Thanks to all who reached out to solve this issue. Paul

1 Like

update the firmware on the last page of the firmware for your PR2100. manual firmware update, and make sure your auto update is of for now. GOOD LUCK

  1. Use the following WD link to the OS 5 5.26.300 firmware release at: (My Cloud OS 5 Firmware Release Note 5.26.300 - Announcements - WD Community)
  2. Download the PR2100 file to desktop on a PC or laptop.
  3. Use your laptop to login to your MyCloud using its IP address from your home network.
  4. From MyCloud home menu at top right, select the Settings tab.
  5. Deselect Auto-update, making it inactive.
  6. Select Firmware update from left column.
  7. Select Manual update / browse and upload the 5.26.300 file you saved on your desktop/laptop.
  8. Save.
  9. Your MyCloud should reboot, and hopefully the Channels app begins working again with Chrome failure error messages.