Weird freezing situation w/ Channels Apple TV app


I am getting a weird situation that has occurred recently with Channels on my Apple TV; it might be something that has an obvious solution that may be caused by my admitted, limited ability to grasp the tech/logic around how Channels works or should be properly set up, but all things were working perfectly fine til a couple of weeks ago or so.

Anyway, when I go to a channel in Channels, it take a few seconds to load up, which is fine (it has always done this), but I have been noticing lately that, if I switch around to other channels (mainly via On Now or the guide; I don't use the channel surfing feature that much to see if it does it there too), it seems to take just a bit longer to load up (like ever so slightly).

Eventually, it gets to a point where I go to a channel (any channel, antenna or my TVE ones - I have a Philo subscription if that matters any), I get a black screen with the progress bar which shows it is spinning, waiting to load and then it just stays like that til I exit out of the app. I then call up the app again and the app freezes and self exits. Then calling up the app the third time, I get the "Preparing your TV" message and everything goes back to normal, where normal means that it just starts the cycle again.

It happens when I move from channel to channel in the methods described above, but I also notice it when I am on a channel for a long time (i.e. greater than 5 or 10 mins) and want to move to another channel.

Like I said, it hasn't happened before and, oddly enough, only seems to happen on the Apple TV app(s); when I use my iPad, the Channels app seems to work perfectly fine.

Any ideas what I am obviously doing wrong? I am sure it is something I am missing...

Supplemental info:
Channels app v. 1.12.0438 (just updated today, but I was on the 1.10 build prior)
Apple TV 4k from before the new remote days, tvOS 15.2. Apple TV is connected via ethernet (no wifi)
(iPad is incidentally at 15.1 if that helps any)
I use a Synology DS 218+ for the Channels Server upgraded to 10GB RAM

Please let me know if you need anything else.. I suspect you might want the logs, and I am happy to supply them; but I am not 100% sure how to do that correctly (sorry).

Thanks for any help you can give me

P.S. I am looking through the logs and seeing there, every so often, the following message —

“TLS handshake error from [IP of my router]:[random 6 digits] : tls: client offered only unsupported versions: []”

Sometimes it’s just in the logs randomly, when idle (e.g., 5-6 times overnight); sometimes it’s after (or not too long after) doing a commercial detection or the next entry sometime after pruning.

Might that have anything to do with what’s going on?

Logs have been submitted as eb8d3d2b-1482-4f36-b958-aab2966f7709. Hope this helps

Submit from the app after it happens

Just happened again at 7:28pm Pacific time; logs have been submitted as b19d33a0-2dea-4d06-af6b-de00d24e6df7

Submitted from Settings in the Apple TV app as well

Any ideas? This is still happening and I’ve submitted logs from the app as requested…

Can you try deleting the Channels app (including betas) then reinstall


If you are referring to the app on the Apple TV, I have done that a few times and it hasn’t worked.

But I think you’re referring to the app on my Synology, which I haven’t done yet, but we’ll do so now.

I had also considered it; but was looking to see if you all thought it was something to try before doing. I’ll give an update when I can on this.

Hi again,

So I haven't had a real chance to sit down and truly test it out, but it appears that uninstalling and reinstalling the app, along with uninstalling and reinstalling the server program on my Synology may have fixed it. Channels are connecting when I switch to them in the limited testing I have done; they may take a bit of time to actually connect (like 5 seconds), but they are connecting...

Incidentally, what I have been going through sounds very similar to the question posed here, actually... I wonder if we were talking about the same thing...

Finally -- One thing I have noticed in the Server settings however that I never did before is that the Activity section at the top does not indicate when I am watching an OTA channel. Has this always been the case? Doesn't seem like it; when I watch a TVE channel, it tells me what channel I am watching under Activity in real time, but when I watch an OTA, the Activity says it just says "Idle".

That is the default. You need to enable "Tuner sharing" on the client-side in order for OTA streams to pass through the server.

Which would become a compelling feature if the server maintained a buffer (versus the client only), and then channel changes back to the original (say 30 secs?) didn't result in any loss of stream!

There are other compelling reasons to enable tuner sharing for all of your clients, predominantly being only a single tuner is used if a channel is requested by multiple clients and/or the DVR.

This way if someone wishes to watch something in one room of the house, and someone else in another room wants to watch the same channel, only a single tuner of your device is used. Without tuner sharing enabled, this would consume 2 distinct tuners. And if one of those watching the program wants to also record it to save it for later, and still continue to watch live? Well now the DVR server has to open its own connection and access a third distinct tuner (which may not be available, as the live viewing clients may have exhausted the device's tuners).

With tuner sharing enabled, only a single connection to the tuner is needed, and the DVR server happily sends it out to however many clients request it. And if a recording is requested, then it just saves an additional copy to disk, using the same connection.

(Edited for spelling/grammar.)

Good points.

I really should've said Which would become an even more compelling feature if...