What are these Errors?

I had my server drop abruptly at midnight (which it’s seemed to do before) so I tried to log in and check the logs but I couldn’t connect. I waited about 10 mins and tried again and it worked, but the logs didn’t seem to show anything wrong, but it did show literally hundreds of these duplicated for about two hours straight:

2020/01/02 22:40:30 [HLS] Pausing transcoder (out: 11m52.407444s, view: 6m51s)...
2020/01/02 22:40:31 [HLS] Resuming transcoder (out: 11m52.407444s, view: 6m51s)...

Then eventually this one:

2020/01/02 23:09:55 [HLS] Pausing transcoder (out: 36m59.746611s, view: 36m56s)...
2020/01/02 23:09:55 [ERR] os: process already finished
2020/01/02 23:09:57 [HLS] Resuming transcoder (out: 36m59.746611s, view: 36m57s)...
2020/01/02 23:09:57 [ERR] os: process already finished
2020/01/02 23:09:57 [HLS] Pausing transcoder (out: 36m59.746611s, view: 36m57s)...
2020/01/02 23:09:57 [ERR] os: process already finished
2020/01/02 23:09:58 [HLS] Resuming transcoder (out: 36m59.746611s, view: 36m58s)...

This is the only thing logged around midnight HI time when my server dumped:

2020/01/02 23:29:00 [IDX] Generating video index for job 1578043740-5
2020/01/03 00:00:36 [DVR] Pruning old recording Hawaii News Now at 1000 2019-12-30-2159.mpg
2020/01/03 00:00:36 [DVR] Pruning old recording NFL Live 2019-12-26-0829.mpg
2020/01/03 00:00:36 [DVR] Deleting /storage/A8E26A9EE26A710C/NVIDIA_SHIELD/TV/Hawaii News Now at 1000/Hawaii News Now at 1000 2019-12-30-2159.mpg
2020/01/03 00:00:39 [DVR] Deleting /storage/A8E26A9EE26A710C/NVIDIA_SHIELD/TV/NFL Live/NFL Live 2019-12-26-0829.mpg

Do you have Old Transcoder enabled in the Experimental settings?

Yes, I do.

What is preventing you from using the new transcoder?

I'm not certain about these log pausing and resuming error messages, but the behavior around restarting a transcoder process that has failed is better in the newer transcoder.

I had numerous documented issues here with getting stable remote streaming and this was one of the troubleshooting things I tried that seemed to help keep a smooth video playback. Are one the options (old or new) better when remote streaming and/or using a Shield as the DVR server?

I guess I can try using the new transcoder now to see what happens.

Speaking of transcoders, I saw there’s a new one for live streaming listed in the Experimental section. When I tried it last week or so it completely cut off my ability to do any remote streaming. The only way I got it back was to disable it again. Why would this be the case?

I just reviewed all of the issues you reported on the forum, and it appears they were all related to live streaming.

The Old Transcoder setting that you enabled was only related to playing back recorded content. The new recorded content transcoder has been active for a few months now with very few reported issues. Please try the new transcoder with your recorded content and see if you have a better experience.

To help rule out any issues that have been recently resolved, could you also update your DVR to the latest beta?

Regarding the Adaptive Streaming for Live TV feature this is a new feature that is currently under development. It requires the latest iOS, tvOS and Android betas and will not currently work with FireTV (because we do not have a current beta program for FireTV).

You can read more about it here:

If you update to the latest beta clients (assuming you are not using the FireTV) you should see a better remote experience with Adaptive Streaming for Live TV enabled.

If you do decide to test out the new experimental Live TV setting, please provide any feedback on the thread above.

1 Like

Awesome thanks for the info and clarifications. I am using AppleTVs as clients currently, but I do have FireTV Cubes at each TV as well, but haven’t used them in weeks. I’ll try the new transcoder, update to the latest beta and activate the live transcoder as well. I’ll report back any issues.

I am a little nervous to do this though, as for the first time I have had my DVR server up for 10 straight days without a streaming issue, live or recorded, except for the little glitch I reported here which was quickly recovered to a good state.......for now.

I understand. If the issues you reported the logs of in previous threads were the only ones you were having, I'm confident that enabling the Old Transcoder setting didn't have any impact on your issues.

For context, I am updating the main DVR server for my house for every beta release we do, so we see many issues that crop up immediately.

Depending on if I get much more feedback and bug reports from anyone, I expect that I'm a week or two away from making the Adaptive Streaming for Live TV enabled for everyone. It's been pretty stable in my testing and I've addressed all of the outstanding issues that people have had.

1 Like

Well I guess my apprehension was well warranted here. I updated and did all the suggestions you asked for and now I can’t access my DVR at all and since I can’t do that I can’t even see the logs to see what’s happened. :rage:

I tried connecting remotely via the web and also through the VPN to simulate being there at home which has worked every other time, but not this one. I tried rebooting the router remotely and that didn’t fix it. I logged into my HDHR tuners and they are booted and working fine with no errors whatsoever in their logs that I see.

I’m actually connecting it seems but ALL the fields are blank, from settings all the way through the log.

Anyone know how I reboot the DVR Server on my Shield remotely, or the entire Shield itself? I have a private OpenVPN setup between my two Asus Routers. I tried downloading an app for my Shield on my phone to control it but it needs a PIN to initially setup the connection. My daughter who’s normally there to help is still here for the Christmas holiday so she can’t help either.

I think it’s just time to throw in the towel and bite the bullet and just pay for TiVo and Spectrum TV. :slightly_frowning_face:

If you have a VPN tunnel, you can access the logs via http://x.x.x.x:8089/log

As stated above, I already tried that. All I get is the attached menu with the spinning circle no matter which menu option I select, including the log.


As I said already. I did.

You're using /admin/log which shows the spinner. Use /log instead

I already tried deleting the “admin” part as he suggested. No dice, but I’ll try again

Tried again and all it does is sit with a blank browser window and the loading bar at about 20% with no further movement.

The image attached is to show proof that I used the proper IP.

Can you see if loads for you?

Like I said, I think the DVR Server crashed on the Shield. That’s why I asked if anyone knows a way to reboot that and/or the entire Shield remotely? I tried two different iPhone apps to attempt to remotely control and connect to the Shield but neither gets me into it without some sort of authentication or setting that would have to be with someone there in front of it.

OK I’ll try that thanks.

OK that one got me in and I see all the text files. They’re way too long to post here though. I can copy and send to you somewhere?