Windows DVR BUG: Glitches during recording


#21

I’ve been trying to reproduce this problem today, but not having much luck. Initially I was seeing some glitches, but they went away when I switched my windows machine to record over ethernet and turned off the wifi adapter.

Looking at the Task Manager, I also noticed there was a process called “DiskTrace” that was starting up every now and then and using a bunch of CPU. Some googling showed it was because of the “intel driver update utility”, which I uninstalled from Add/Remove Programs.


#22

If you’re having issues, it might be worth checking the sequential write speed on your external drive.

  1. type “command prompt” in start menu
  2. right click on the best match
  3. run the command winsat disk -drive D -seq -write (replace D with whatever drive you’re using)

For example, I ran it on my C and D drives, and got 75MB/s and 28MB/s


#23

I just removed the Intel driver utility program ad I did have that on my machine. Thst would be great if that is causing issues. I did not have that on my earlier PC which was an AMD but it was a much slower machine which could have been causing issues on its own as that PC only scored about 1,500 on the benchmark test.


#24

I removed the Intel Driver Update. I checked my disk speeds and they are 148MB/s and 105MB/s. Maybe I am just doing to much with the server. I run Plex to serve movies to my devices and a few friends and Blue Iris for security cameras. My CPU and mem usage is usually less than 50%. Thinking about just getting a NUC and using just for the DVR.


#25

Try this:

  1. Upgrade your PRIME to the 20170406beta1 firmware

  2. Upgrade your DVR to v2017.04.08.0055 by opening PowerShell and copy/pasting this command:

Invoke-WebRequest -Method Put http://127.0.0.1:8089/updater/check/2017.04.08.0055


#26

With that latest DVR version, I was able to record three shows at the same time from my PRIME on windows and the disk rate never dropped below 6MB/s.

Let me know if you notice any glitching after the upgrades.


#27

Its done and I will let you know.


#28

I haven’t seen this problem. But I don’t think I have had three shows recording at once. Do you need to test? I have 5 total tuners I can try to use at once.


#29

I have seen glitches on my Mac Mini. I just watched the 2 hour premier of “The Son” without 1 glitch. Maybe has to do with the New firmware on my Prime. 04/06/2017 (I think that is the date). Also, on the latest DVR as of 4/8/2017.

And COMSKIP was perfect.


#30

Still issues for me. Saturday night live was only thing being recorded last night. HD prime latest beta firmware and beta DVR software, glitches in several portions of the show.


#31

Spoke to soon. A lot of glitches with Masters Golf. I was watching delayed a bit.


#32

I am starting to think there may be an impact from watching a show while still recording. I cant be 100% sure, but it seems my glitches could have aligned with when I started watching SNL and fast forward when I hit commercials. Is this a limitation of the DVR?


#33

When did this start happening for you in the Mac?


#34

Ok, did some testing and I did not have any problems. Recorded with 5 tuners. Two OTA and 3 cable (using HDHR Connect and Prime). Shared a OTA tuner to watch at same time. I had no video or audio problems. And I tested watching recordings while it was doing some commercial detection. Also tested watching a show while it is recording and had no problems with video or audio. The only thing my system does is Channels and Plex. Using a Q6600 quad core with 8 gigs RAM and a Nvidia GT 730 with passive cooling.


#35

Not sure I have never had a glitch. I am sure I have reported before. Mainly the problem is pretty limited. And I am pretty sure I had similar problems with the FIOS Equipment. But sometimes it does get a bit worse but have no idea why. Most of the time it is fine. I would say intermittent.


#36

Given that other windows users are not having any issues, it seems this might be an issue that’s specific to only some setups…

The specs posted so far are more than enough for Channels, and the disk speeds are plenty as well.

That leaves the network, so it’s worth double checking that you’re using gigabit on both ends. On windows, run this in the command prompt or powershell:

wmic NIC where “NetEnabled=‘true’” get “Name”,“Speed”

For example, I see:

C:\Users\tmm1>wmic NIC where "NetEnabled='true'" get "Name","Speed"
Name                                Speed
Realtek PCIe GBE Family Controller  1000000000

and then go to http://my.hdhomerun.com, click on your PRIME, click System Status, click System Log, and look for lines like this:

19700101-00:00:03 System: network link 1000f
19700101-00:00:04 System: ip address obtained: 10.0.1.4 / 255.255.255.0

If both ends show gigabit speeds, then consider swapping out the network cable that’s attached to the PRIME. We’ve heard several isolated reports that the ethernet cable that comes with the PRIME can cause issues.


#37

I’m going to try swapping 1 gig switch that the prime and DVR PC are connected to a long with Ethernet cables.


#38

I’ve put out another build for mac/windows which contains additional logging. Please upgrade to it, and next time you notice glitching check the logs for any messages.

Invoke-WebRequest -Method Put http://127.0.0.1:8089/updater/check/2017.04.10.2142


#39

I have gigabit on both ends with brad new shielded CAT6 cables. I upgraded to the newest DVR software but I haven’t had issues yet since upgrading to the beta FW on the primes. What exactly is the beta fixing?


#40

The beta PRIME firmware fixes a long-standing but very rare bug on the PRIME’s ethernet firmware which could cause the network connectivity to drop randomly. There are many threads on the SD forums about this issue, such as https://forum.silicondust.com/forum/viewtopic.php?f=113&t=33934

The 04.08 DVR increased the per-recording buffer from 16MB to 24MB. Video data from the HDHR is written into a buffer as quickly as possible, and then another thread writes from the buffer to the disk as quickly as possible.

The 04.10 DVR adds a “WARN” message to the logs whenever the buffer space runs out. Outside of PRIME firmware issues or ethernet cabling issues, this is one of the few places in the DVR that could be causing glitching. However, even 16MB is plenty of buffer (8 seconds minimum), so the only way it could be overflowing is if the disk wasn’t fast enough. The disk metrics I’ve seen so far are more than fast enough, so it’s unclear if this is the source of the problem or not. If the new log message shows up during recordings, then we will know for sure that the bug is in the DVR.