Windows DVR BUG: Glitches during recording


#41

I think you may be right. I just started a few recordings on my windows DVR, then started watching one of them and skipped ahead. When I got to the point in the video that was recording during my skipping, I saw some glitches.


#42

That is mostly when I see problems. I do this maybe 25%. I have less problems when watching after the show completes and COMSKIP completes.


#43

Interestingly if I try the same steps on Linux DVR (QNAP), no problems.

I also watch in-progress recordings on my main Mac Mini DVR all the time and have never seen this problem there either.


#44

Tried the same test on low-powered WDMyCloud 2TB, with three recordings at the same time, and still no problems.

So it appears to be something specific to windows version of the DVR.

Atleast I can sometimes reproduce now, so it should be easier for me to debug it.


#45

Alright, I think I figured out what’s going on here…

The problem only seems to trigger when you are watching an in-progress recording and skip multiple times or try to fast-forward/rewind. It has to do with how anti-virus software works on windows…

@Jay78412 and @Scottteller What antivirus do you have installed? I’m using the standard Windows Defender.

Now that I finally know what the problem is, I will try to implement a fix tomorrow morning.


#46

I am just using Windows defender installed from Windows 10.


#47

Okay here’s a workaround to try. Open the Windows Defender settings, and at the bottom add an exclusion for channels-dvr.exe:

Tomorrow I’ll work on a real fix that doesn’t require this workaround.


#48

I am also using Windows Defender for anti-virus. I have added this exclusion, and will see if the glitches go away. Thanks so much for continuing to root cause this issue!


#49

Here’s how to add the exclusion using PowerShell (right click Run as Administrator):

Set-MpPreference -ExclusionProcess “c:\ProgramData\ChannelsDVR\latest\*.exe”

You can also exclude your recordings folder:

Set-MpPreference -ExclusionPath “D:\DVR”

Note that running these commands will overwrite any existing exclusions.



#50

I use Avira. I just used it because it was free. I could just go to using Windows Defender or another antivirus.


#51

Is it possible that the antivirus is also causing the intermittent frame loss I have been seeing with ATV and not other programs ie:VLC? I’m still going to add the exemption.


#52

You should be able to add similar exceptions in Avira: https://answers.avira.com/en/question/can-i-exclude-files-or-processes-from-scanning--9188?sh=true


#53

Two shows were flawless last night before adding exceptions to Defender, but I was not home so did not watch until recording was completed. I have all exceptions added to Defender now, process for exe and Channels DVR folder, also using latest DVR software and latest TVOS Beta version. I have a few shows recording tonight, curious to see results.


#54

Same, anxiously awaiting to see if it finally fixes the problem. I hope so!


#55

Well I tried the exemption and watched that section of video I was having a problem with (frame loss) and only noticed it once on the current release. When I would rewind back it never happened again. On the ATV beta I never saw the frame loss. So I’m hoping it had something to do with Windows Defender. I exempted the .exe and folder for the DVR service.


#56

Perfect recordings!!! I wasn’t able to start watching any before they were done, but I don’t think that was the only culprit, but something that would cause issues in addition to other issues. More recordings on tap tonight… Will try to watch some while recording.


#57

Watching survivor, two glitches at points that do not align with my deliberate fast forward while it was recording. Exceptions still applied in Windows defender of course.


#58

Please upgrade to the pre-release v2017.04.13.0150 build, which has some performance improvements that should help with this bug.


#59

I was running the pre-release DVR last night. I started watching a recording about 30 minutes into the show. At 5 minutes was the first glitch. I had numerous clutches throughout the show. Didn’t see anything in the logs.


#60

My theory about the anti-virus was wrong.

I know what’s happening now and am working on a fix.