Windows not able to browse Pi DVR over Samba

New user so I might be missing something really easy. The settings page says access your recording through \DVR-SERVER\MEDIA\DVR. I'm on Windows 10 and can't seem to make this work! I replaced DVR-SERVER with IP Address and still no joy. Can you do this on a windows box?


Try 2 backslashes: \\DVR-SERVER\MEDIA\DVR\

(Or substitute DVR-SERVER with your server's IP address.)

Addendum: You can also try browsing through the Network top-level listing in Explorer. Also, make sure the computer you are browsing from has your local network set as a private network, rather than public, and that Network and Sharing is enabled. (I've never been able to figure out why Windows has certain settings as defaults, or why they change randomly.)

You want to view them in file manager type view in windows explorer?

I do have two back slashes and they are plugged into the same switch. Also tried ip agrees and samba is checked. Nothing seems to work. Sharing is enabled. This is first thing I can't browse on my network. Public or probate doesn't matter. I'm stumped. Can windows users browse?

Yes, I want to browse in file manager.

You have failed to provide the necessary information to continue troubleshooting. After multiple rereads of your posts, all I have been able to gather is that you have Windows 10, and want to browse your DVR files in Windows Explorer, and are unable to.

You haven't provided any information about your DVR server. What do you run it on? Where do you store your DVR files? Information about your network? Like I said, all I've been able to gather is that you have Windows 10 and are unable to pull up the files in Windows Explorer.

You're just going to have to slow down, and think about things more logically, to be able to provide us the info we need to continue to help.

Sorry, At first I wanted to know that it is possible to browse the files. I'm running on a Raspberry PI 4. I've got a SSD hooked up to it via USB. I'm on GBit hard wired network. Both computer and Raspberry PI are plugged directly into switch ports on the back of the switch. Anything else?


It is very much possible. You are running the channels rpi4 image or raspian, or something else?

This is for Raspian:,and%20see%20your%20shared%20drive.

If you're running the Channels image, the process may not be the same. In that case, a dev @tmm1 or someone with more linux / pi experience will probably have to help finish this up.

Windows also needs to be configured properly too but if you chose for it to be 'visible' to the network it shouldn't.

What OS on your RPi4, Channels image, Raspian, Ubuntu, something else?

I down loading the image from the channels site so I believe it's the rpi4 image. In the setting page it says to browse via: //dvr-server/media/dvr but that doesn't work. It also gives USB link. Neither are working. Obviously the raspberry pi must make the drive visible to the network. I assume I don't have to do anything to make that work?

If you are using the Channels Pi Image, all you have to do is enable the setting for Samba in the server web ui, and then go to that location on your network given that address listed. u literally can copy and paste that into an Explorer window.

If it does not work, then it is an issue with your Windows computer...which could be many.
Network device discovery and device sharing needs to be on and the network your connected to set as Private (not public).
it also could be blocked by any firewall/anti-virus software.

Trying the ping command from your windows machine to “DVR-server” and see if it successfully returns an ip and pings it. When using a name instead of ip you’re relying on name resolution so a good first step is to make sure that is working.

Try //

When I do // I get a 404 Not Found Error. I'm using the image I got from Channels. I have a SSD connected to my RaspberryPI and everything has been working great. I love Channels! It's very well done. In the settings Samba is checked. On my Win10 I turned off all firewalls, network discovery and file and print sharing is turned on. Both the PI and my Win10 are hardwired to the same switch.

\\DVR-SERVER\MEDIA\DVR\ from the settings page doesn't work, neither does \\\MEDIA\DVR. It's starting to drive my crazy!! Is it because the drive is connected to the PI and not my computer? That wouldn't make sense to me but I'm running out of ideas. I can ping just fine.

When I browse the network I see DVR-SERVER but if I click on it I get a Windows cannot access error. I've turned on NetBIOS and even turned on SMBv1. Nothing is working! Maybe the PI is the problem. Anything I can do to test that?

404 not found would appear if you're typing those urls into a browser.

You should put them into the start menu, or into the windows file explorer.

But if you're getting cannot access error via the network browser, it suggests something else is going on. Maybe the samba setup on the Pi is not compatible with your Windows for some reason. Can you screenshot that error you're seeing?

No, when you enter the address with forward slashes it pops open a browser to display the 404. I use file explorer with back slashes. Are you using Samba v1 or v2? From a file explorer I get:


So, looking on the server side. I can ping my computer. If I type smbstatus or "smbstatus -- shares" both come back with empty list.

I see that the recordings go to /media/DVR not /MEDIA/DVR.

I also don't see
wins support = yes
in the smb.conf. Not sure if it's needed but I usually have it.

Those commands are empty for me too, so I guess that part is normal.

Does systemctl status smb show it running?

Can you click Support > Troubleshooting > Submit Diagnostics from the DVR web UI and I'll see if there are any errors in your logs.

This error code is “access denied”, which implies a port blockage or authentication problem. With modern Windows you can easily test the port availability. Launch powershell and type “test-netconnection -port 445” and see if the port test succeeds.

I submitted the logs. The Samba service is running. All looks fine there. test-net-connection also looks fine? I'm really stumped. How about the smb.config not containing "wins support = yes"? It's write protected or I'd change it.

This proves that it is listening on the SMB port, so a firewall blockage is not the issue.