Won't play outside the LAN

I set up Channels DVR on a substantial Windows box (which happens to also host a Plex server). I seem to have the port 8089 open and connect OK to the server. I view the guide, select something, click Watch Now, and (web client) says:
Starting
Remux starting: 3s @ 6.67x (0.0fps)
then
Reconnecting
Remux starting 2s @ 1.82x (25.73fps)
then
Reconnecting ...
Remux starting: 2.29s @ 2.25x (35.96fps)
then
Reconnecting ...
Remux starting 2s @ 3x (26.31 fps)
then, nothing happens.
On the Apple TV client, similar - guide &c shows up nicely but when going to play, the spinner spins for a long time, then nothing. On the Android client, "Playback failed".
Source is 2 HD Homeruns, one a Connect Quattro and one a Flex 4K.
I'm far away from the local lan for a week or so, but I think port forwarding is set up right.
Where do I start troubleshooting?
Thanks.

Do you get the same behavior when trying to tune to a atsc 1.0 channel? Some server setups cannot transcode atsc 3.0 channels. What is the playback quality set to in the atv(under internet streaming)? Depending of bandwidth on each end try setting the playback to original quality. If bandwidth is limited you may need to lower quality and use non-atsc 3.0 channels

can you install HDHome run native app and view your sources? if you log into your router you should be able to see what the IP address of the HD home run. If you can view via the native app, then it's something to do with the channels DVR server/ router.

He is remote. Hdhr app doesn’t work when remote

well crap..
at least log into the settings and see if the channels service is showing an IP address associated with the HD Home run.

Yeah, it shows my 3 HDHRs correctly.

I found the log and browsed around. One potential issue - which for some reason Plex doesn't have - is that machine has a second Ethernet adaptor, a virtual one that enables a zero trust network created by Tailscale. I know from experience that for some reason the HDHRs won't send over that network. The log says the virtual adapter is the one it's telling the client to talk with. So I would like to try forcing it to use the real Ethernet adaptor, but I don't know of a setting in Channels to do that. I can't disable the virtual one from my present remote spot. Won't be home for a while. Not sure this is the issue anyway.
Anyone know a way to force Channels to use a particular network interface?

Please paste the log message you're referring to

Well upon further review the IP I see in the log is either the Tailscale IP of my client (100.xxx.xxx.94) or the external IP of the network I'm on remotely (when I disconnect from the Tailscale network). This is the message that prompted my post; from the status page under Remote DVR:
Configure your router to forward TCP port 8089 to 100.xx.xxx.15
That IP is the virtual (Tailscale) IP of my CDVR server. BTW all the status indicators on the status page are green.
I'd be happy to submit logs if that would help.
Thanks.

So am I SOL? Should I cancel my subscription?

I don’t use it myself but it looks like tailscale is a vpn.. so once you’re connected it’s like you’re “at home” so you would tell the Client you’re at home, not remote. If it doesn’t find the server automatically you may have to enter the server IP address. I’m not 100% sure on this, hopefully somebody else will correct anything I got wrong.

Connects fine for the guide and everything else, whether by Tailscale or not. But no video passes in either case. I see mention of Tailscale in other threads so it's not like Channels is incompatible at least in general.

Please submit diagnostics

logs id is eca91f63-6c29-4f4c-973d-2c9e26ce8806

Please try to play something from one of the apps, and once that fails, submit diagnostics from the app itself.

To do that, go to Settings -> Support -> Submit Diagnostic Logs from your device and let us know when it's been submitted so we can have a better idea of what was going on.

Tried streaming to Windows / Firefox, remotely, same result: no video ever played. Waited a couple mins. Log forwarded.

Could you change your Transcoder to Software from Hardware and see if that makes any difference? After you've tested, please submit diagnostics again for us to see if there's anything interesting in the logs.

3 posts were split to a new topic: Problem with DVR

Logs: a0c7d19a-26fd-4825-9fa0-99f0c6d82f06
I tried playing from Windows 10 Firefox remote, with software transcoding. Also tried from Android client (Galaxy Note 8) on wifi (cell is not good here). No video on Windows; Playback Failed on Android client.

If you make a recording of the channel and then try to play that, does that work?

Yes. Both Android and Windows (web) worked.