2.1.15 crashes on startup - FireStick 4K

@tmm1 - I'm having a similar issue but with 2.1.15. I literally can't open the app on my fire stick 4k - it just crashes and takes me back to the home screen (I can't see anything).

Here's my devices log from the /devices URL above - thoughts? https://pastebin.com/QjpnTCFH

Can you try deleting and reinstalling the app?

That did the trick... weird... never happened before. Thanks!

Did you turn off the "Help Improve Channels" setting by any chance? Looks like there might a bug in there.

Good question. I did actually... yes I turned off that setting. Other than that I haven't messed with anything else.

So uninstalling and reinstalling fixes the issue...until you power cycle the stick. Then it starts crashing again and you have to go through a uninstall and reinstall to get it working.

What about a Force Stop, followed by Clear Cache?

@racameron I'll give that a try later tonight.

@racameron Clear Cache does not work. I then tried Clear Data and that worked.