App Store Issue: Unable to download/update Channels tvOS (v2.1.23)


#184

Fancy Bits, whose bright idea was it to upload a version of Channels to the app store in advance of the roll out of the OS designed to support it?


#185

Just turned on ATV this morning. Channels works fine without prompting for update.


#186

I deleted the app before finding the forum.

I need the beta, please.


#187

I deleted the app before finding the forum.

I need the beta, please.


#188

Morning folks… I seriously can’t believe we’re in day three of this nonsense.

I guess Apple is pretty short handed given that it’s the weekend. I really hope this issue is resolved by tomorrow. We have confirmed that they made some sort of change on the App Store servers between Thursday and Friday which broke a bunch of apps, including ours. We pushed out 2.1.21 on Thursday which was perfectly fine. Then on Friday we tried to push out 2.1.22 and 2.1.23 and neither one worked. These builds were almost identical to the 2.1.21 (just a couple line bug fixes), so it’s nothing on our end that caused this issue. We also pushed out three builds last week (2.1.18, 2.1.19 and 2.1.20) none of which had any issue.

Anyway, I just sent out beta invites to everyone who asked for one overnight.


#189

I just tried downloading again from App Store and it’s working now

**EDIT: I just noticed my TvOS was at 10.2 after resetting


#190

That was fast. Beta downloads and works. :slight_smile:


#191

This seems confounding and misleading…
– Issues with downloading Channels tvOS have been going on for many weeks
– Many other tvOS apps are successfully updating

C’mon Channels, take responsibility and fix your problem quickly


#192

Unfortunately I also deleted app, and now require the beta app. Many thanks for an expedient reply.


#193

Could you please send me the beta version. I already have TestFlight installed; I have beta-tested other apps so I shouldn’t have any issues on that front.

I tried trouble-shooting before reading your post; in my ignorance, deleting the app to see if an entirely fresh install would work seemed like a good idea.


#194

What issues have you been seeing for weeks? No one else has reported any problems before Friday.


#195

“Channels – Live TV” could not be downloaded at this time
I don’t have precise timing, but feels like many weeks

To me it still seems like your problem… please fix it asap


#196

Thank you.
Beta seems to have restored all of channels capabilities.
May I ask what changes are being made to what seems like such a well coded program in the first place?
Are current bugs maybe the results of DVR integration?


#197

I need an invite to beta so that I can continue using it.


#198

Please invite for beta app.


#199

Please send beta, thank you


#200

I found a workaround solution to install Channels on the current release of TvOS. You will need Apple Configurator 2 available from the Mac App Store. Connect your Apple TV with the USB C cable and then install the app via this configurator - hit the ADD button at the top.


#201

Was able to install the latest version via Apple Configurator on TvOS 10.1.1 using a USB C cable.


#202

I could use a beta invite as well. Thanks.


#203

Good to know. We know the bug is in the 10.1 version of the App Store, so it makes sense that installing it differently works (via TestFlight or Configurator).