App troubles on new Fire Cube

I just went back to the Fire TV 4K Stick from the New Fire TV Cube because Channels DVR is our primary TV source and it is broken on the New Cube. The problem is that when you pick a program from the guide -- and it matters not whether it is HDHomeRun OTA or CableCard or TVE on the channel chosen -- the screen goes blank and it hangs. Sometimes if you try various guide choices one will eventually come up after a delay, and after that the other channels will work normally. The Fire TV Stick 4K worked perfectly before this experience with the Cube, and again works perfectly after, so it is something about the Cube. The Cube did do a software update when installed, there appears to be no further updates.

Can you submit diagnostics from the app after the issue occurs?

Is it completely hung in that you can't even hit back to go to the guide?

You could go back just fine, it would just sit there with a black screen until you did.
The Cube has been returned, so unless there is a log file on the server that would be helpful to you I am unable to do more troubleshooting.

I am running on a new FireTVCube and Channels DVR works great no problem at all... as a matter of fact I prefer the FireTVCube over my Shield as it controls all my entertainment equipment and cameras.

My Software version is 7.2.0.4 (PS7204/1045)

Home Version 6.1.8.0-720

I also have the latest Firmware on all my HDHomeRun devices.

That's great, but it doesn't negate the reality of my experience. I am not an inexperience newbee, rather a retired EE, and video technology pioneer, unlikely to make foolish mistakes. My problem is solved, by going back to the 4K stick, so whether you ignore the report or investigate is no skin off my nose.

Without the diagnostics from the device there's not much we can do. Thanks for reporting this though. If someone else runs into a similar issue they'll see this and we can get to the bottom of whatever is going on.

Several other users have reported using the new Cube without issue, so there may be something that broke in the latest firmware..

1 Like