Can not add Storage location on Synology

Synology DMS 7:

Channels installed on volume 1, I would like to add additional storage location that is located on a different volume. When i click the plus to add a storage location It does not give me the option to change volumes to choose a different storage location.

I know channels can "see" the other volume because at the bottom where I add custom content I can choose from different volumes, it is just the storage area that will not let me choose storage located on a different volume.

The new DSM 7.0 package no longer runs as root user.
You need to set directory permission for it using System Internal Username channels.

More info in this thread Warning - Synology DSM7

Would be nice if they noted that here

Yeah - i have the channels app permissions correct. Like i said in my original post, i can see the different volumes when choosing “custom content” at the bottom - it’s only when i am trying to add a second DVR storage location that I can now browse off of the original volume

Maybe it won't allow it to access /volume2

I setup mine like this

/volume1/shared_folder (system internal user channels has read access)
/volume1/shared_folder/ChannelsDVR (system internal user channels has read/write access)

I see what you're talking about.
Adding an additional storage path shows this


Adding an Import directory shows this

Yes - exactly correct. Thanks for those two images - that shows it perfectly.
I am trying to setup my main channels install and storage to be on a 1TB SSD for fast access/loading of new content and content i watch regularly and not having to have spinners running constantly (we watch and then immediately delete most shows) Then the few shows that i keep long term i wanted to move to my regular storage of standard hard drives.

Until the devs fix it, you can add it the old fashioned way, using a curl command on your Synology.

1 Like

I just tried and it gave me an error of "access is denied".

I am currently connected via VPN so I do not know if that is why it says that (though I can browse smb fine) or if it is a true access issue. I will try again when I get home later today. This feature though is already part of the GUI, so the fact that I can not see my other volumes when I click the plus makes me wonder if there is a Channels coding limitation allowing you access to only the current volume because keeping in mind based on your images and my experience we can confirm channels CAN see the other volumes when you try and add custom content - so it is not a general NAS permissions issue, its a specific to the Channels "storage path" issue.

any insight @maddox?

You have some extra stuff before curl.exe causing the command to fail.

I am sending the curl from windows CMD to synology if that makes any difference. I will try the different variations in that other thread.

I got it via powershell!

$url = "http://MYIP:8089/dvr"
$payload = '{"ExtraPaths":"/volume1/Media/ChannelsTV/"}'
Invoke-RestMethod -Method Patch -Body $payload -uri $url

Is there a similar command that can be used to change the default DVR path?

Just stop the DVR, manually move everything to the new folder, change the folder location in settings and restart the DVR.

Mine was because I run the main DVR on a SSD but i move “older” media to regular spinning drives if it’s still on there after a week or two

Thanks! I tried that, but I'm only able to navigate to folders on volume1. I have a different volume, connected through eSata, that I wanted to use.

What is the path to that eSata volume?
Is it /satashare1 ?
If you're running on DSM 7.0 you most likely need to give the system internal user channels r/w access to it.

For more information, consult your Synology Help documentation
https://kb.synology.com/en-global/DSM/help/DSM/AdminCenter/system_externaldevice_devicelist?version=7

https://kb.synology.com/en-global/DSM/help/DSM/AdminCenter/file_share_privilege?version=7

https://kb.synology.com/en-global/DSM/help/FileStation/privilege?version=7

When I insert a USB thumb drive into my Synology it shows up as /volumeUSB1/usbshare.
In Synology File Station it appears as usbshare1.
I don't have any eSata drives connected to my Synology.
Channels DVR does let me pick it once I give system internal user channels r/w access to it.

I appreciate the help! The path to the eSata volume is /satashare (no numbers). I've read through the links and, from what I can, permission are correctly configured. I've included a screenshot of the permissions for the satashare folder.

Don't know what to tell you. Works on mine using a USB thumb drive.



Is it on a different volume? My original issue was the DVR folder was locked to any folder on my original volume. If this is the case, backup your install, then reinstall Channels onto the volume that has your data drive and restore backup.

Oddly you can see any volume in the media settings at the bottom - but the DVR itself is locked to the volume that channels itself is installed on.

He just needs to unckech the DVR checkbox on the Settings page
Screenshot 2021-08-08 at 14-33-34 Channels Settings

and choose the directory he wants.

Sata share should appear as an option with the next prerelease build

3 Likes

Looking forward to it! Thanks for the help and sorry for hijacking this thread.