Channels App on FireTV not displaying guide information or What's on now

I have a clean install of channels app on my firetv on an existing firestick. When I open the app it displays preparing TV. It finds my HDHOMERUN tuner and displays all the channels from a scan.

However no information displays in the guide or on what's on Tab. What I have tried.

  1. Removing channels app and reinstalling --- same result
  2. I have cleared the cached, and reset to default settings -- same result
  3. Running a tuner scan for the channels ---- Finds 712 channels.

Note I have other tv's with firestick's that are working well. I have hdhomerun app installed on the same firestick and its sees the guide information.

I am at a loss at what else I can do. Please note that I am not running the channels DVR.

Does it work in the official HDHR app on the same device?

Thanks for the quick response. To answer your question, yes the HDHomeRun app is loaded on the firestick and displays the guide information correctly.

Please click Settings > support > Submit diagnostics > guide in the app

What is your HDHR device ID

Give me two minutes. My HDhomerun device id is 132508FE. I just updated the firmware on my hdhomerun to 20220203.

Done diagnostics are turned on. Thank you.

@tmm1 Aman any feedback or information you saw from the logs?

I assume you’ve made sure the guide dropdown has been moved from favorites to all?

Yes. All tabs are empty including all. The numeric channels show up but there is not data in any of the tabs, all, HD, movies, etc...

@tmm1 amman. Bump as I have not seen a response yet back from you.

Please update to v4.2.0 from the Amazon App Store and submit diagnostics from that version.

Ok thank you for your response. I will try that in a few minutes.


Hi Amman @tmm1, I am already running v4.2.0 from the Amazon Store. I submitted diagnostics again tagged with guide problems.

Unfortunately your diagnostics are always coming through with empty logs. I'm not sure what's going on with your device but something seems messed up on it.

Hmm. What is your suggestion on how to resolve. Should I factory reset my firestick and do a clean install?

I factory reset the firestick and did a clean install. I have the same issue. I am going to disconnect from wireless and put on the same ethernet broadcast domain.

I have lost SOME of my guide on my pc and on my ios device and on my firestick. So, not device issues. Strangely, it was only the lower channel numbers. Those that also have the higher number (ATSC 3.0) do show in the guide along with all the misc OTA channels.

After repeated "fetch guide update" it finally came through.

how did you do the fetch guide update. I assume your referring to doing a network scan on the hdhomerun tuner?

On the Channels settting page.