Channels app speedtest with iOS app?


#1

Tried running a speed test between a PC and the Channels client (iPad with Channels App v2.2.6)

  1. Look up IP of Channels client (iPad has reserved ip of 192.168.1.92)
  2. Open the Channels app on the client
  3. On the PC, open http://192.168.1.92:57000/speedtest

It wont connect. I can ping the iPad from the PC.
The PC is not running the Channels DVR, but is attached to the same switch as the NAS that’s running Channels DVR.
There is no browser on my headless NAS, so using a Windows PC to run the test.


#2

This feature is only available on Apple TV. There is no API for the iOS app.

However since there’s a browser, you can run a speedtest in the other direction. Open Safari and load http://dvr:8089/speedtest


#3

Thanks!
That worked. 108 Mbit/s on 5GHz wifi using Safari on the iPad.


#4

(Gb) = Gigabit Ethernet adapter
– = CAT6 network cable
NAS is Channels DVR server

NAS(Gb)–(Gb)SWITCH(Gb)–(Gb)ROUTER(5GHzWiFi)–iPad

Was wondering why my iPad was so slow in the Channels DVR speedtest, so I ran the same Channels DVR speedtest from my Windows7 PC w/Gb ethernet connected to a Gb ethernet network switch connected to my NAS w/Gb ethernet.

NAS(Gb)–(Gb)SWITCH(Gb)–(Gb)PC

http://NASDVR:8089/speedtest using Firefox, Chrome or IE from the Win7 PC
108 Mbit/sec, Huh?

Verified everything has negotiated Gb speed.

Just wanted to add that I was only testing this tool, don’t have any issues right now.


#5

(Gb) = Gigabit Ethernet adapter
– = CAT6 network cable
NAS is Channels DVR server

Curious how accurate you think this speedtest is.

Same config as my previous post above.

Transferred a few (4 - 8 GB) video files from my NAS to my PC and NAS to my iPad.
Measured the transfer speed using the network monitor on both my PC and NAS.

I measured about 800 Mbit/s doing file transfers from my NAS to my PC.
Channels DVR speedtest showed 108 Mb/s.
NAS(Gb)–(Gb)SWITCH(Gb)–(Gb)PC

I measured about 400 Mbit/s doing file transfers from my NAS to my iPad.
Channels DVR speedtest showed 108 Mb/s.
NAS(Gb)–(Gb)SWITCH(Gb)–(Gb)ROUTER(5GHzWiFi)–iPad


#6

Is your PC wired or wireless?

Fantastic speed results…I can only attain ~150Mbits/s with an AC iPad 12.9” 2017 version connecting with Qnap 251A on wired, although my tests on AC wi-fi only (same iPad) via Sweet Spots registers in excess of 1000Mbps.

Edit: Add server to equation above.


#7

My network diagrams are a bit unconventional looking :slightly_frowning_face:
I updated my earlier posts to show it’s all Gigabit network, except router to iPadPro which is AC1900 5GHz wifi.


#8

I assume you mean placing your iPad in the best location to get the best wifi signal?
Or, is that the app Sweet Spots


#9

My iPad location is where I normally reside to use all apps, etc. Granted it is only 20’ from my wi-fi router.

Sweet Spots (free) is an iOS app I have used in the past to identify any dead/sub-optimal physical locations (thus allowing me to determine/add appropriate MoCA locations in my environment).


#10

Saw your post over here and am curious if your WIN10 PC and Qnap are both on the same network switch


and were you running the speedtest from Safari (or another browser) on your IPad Pro?


#11

Yes, to Safari…hard to break old habits and use Chrome…but at times…Chrome has proved more useful.

No, not on the same network switch. See discussion on other thread for exact details. For this purpose (using switch ids as A-C, as this designation is quicker than trying to relate to #1-3 used in previous posts), Qnap is on switch A (Moca 1), Win 10 on switch B (MoCA 1), and ATV4K on switch C (MoCA1).

Edit: add additional detail


#12

i see 400 mbit on the speed test thru my ipad and 5ghz network.


#13

First, want to say I’m not having issues, just wondering how accurate this tool is.

I get the same speed as you with a speed test (not Channels SpeedTest) going out to the Inet w/my iPad through my 5GHz router, but not with the Channels SpeedTest.

What are you testing from/to with the Channels SpeedTest?

Channels SpeedTest only shows 108 Mb/s from my Windows PC to my NAS running Channels DVR and they’re both Gb ethernet and wired directly through a Gig ethernet switch. I get 800+Mb/s transfer between them when measuring with other tools. I get 400+Mb/s transfer between my iPad and the NAS when going iPad->5GHz Router->GbSWITCH->NASRunningChannelsDVR using other tools to measure transfer speed.

I’m not sure what the Channels SpeedTest is measuring or how it works, but it doesn’t seem to reflect reality.


#14

The speedtester generates random data to measure bandwidth, and I think perhaps there’s a bottleneck on how fast it can generate random bytes so that’s limiting the speeds you’re seeing.

I’ll see if we can get rid of that to maximize throughput.


#15

Thanks. Let us know when ready to test.

Here are my current results when I launch it from the browser on my Win7 PC and pointing to my NAS to run the speedtest using http://dvr:8089/speedtest where PC and NAS are both connected to the same Gigabit switch.

First a benchmark transferring a multi gigabyte video file from NAS to PC
PC Task Manager display

Now the channels speedtest from same NAS to same PC
PC Task Manager display

NAS CPU monitor

NAS Network monitor


#16

I see, the CPU spike is because the DVR was trying to compress the data before sending it out.

Can you try updating using:

curl -XPUT http://x:8089/updater/check/2018.10.06.2149


#17

Much better!
CPU utilization ~5% User, ~30% System during tests.

From Win7 PC now
2149%20Speedtest


#18

Awesome. Thanks for noticing this bug and all the debugging screenshots!


#19

From iPadPro now.