Channels DVR Won't Launch on non-4K Firestick

I was having an issue with installing the 3.0 Beta on my non-4K Firesticks. It looks like Amazon now has the 3.0 stable release out and I was able to install it, but it won't load. I get the "Preparing your TV..." splash screen and then it returns back to the previous/home screen. I get the same behavior on both of the non-4K Firesticks I have. The two 4K Firesticks I have give me no issues, they load and work great.

I've tried a factory reset of the Firestick, but it made no difference. I've looked for any sort of a log to perhaps show me the culprit, but I guess there's no logging available to the user on a Firestick? I tired installing version 2.1.27, but it's not loading either - and it doesn't even get to the "Preparing your TV..." splash, just a spinning loading circle.

It's running Fire OS, which it says is up to date.

Any suggestion?

Are you able to load http://x:57000/log using the IP of your fire stick?

I am not.

How many recordings do you have? Are you using the imports features as well?

I currently only have 2 recordings. I am using the imports feature - although I haven't tried it out yet.

The older FireTV sticks are stuck on Fire OS 5.x, which is Android 7. Current FireTV 4K sticks (including the 3rd gen FireTV, the pendant style) are all on Fire OS 6.x, which is based on Android 9.

It might be time to update some hardware ...

You might be right. But, I was able to use version 2.1.27 of Channels DVR before I tried updating to 3.0. I would at least like to be able to use the older version until I do upgrade those Firesticks...both of my non-4K are in seldom used rooms, so I hate to buy new ones that only get used every once in a while.

How many imports?

Can you click Support > Submit Diagnostics from the dvr web UI?

I have a lot of imports...8127*

Diagnostic log sent: deb9a84e-441b-4a76-b34d-5317e9d50e9f

*If the amount of imports is the problem, I can live without having all of my media imported as I still haven't completely stopped using Plex.

Yes I think that's the issue. I'm looking into fixes.

That was the issue. I removed my imports and it now loads just fine. Like I said, I can live without the import feature. But, the ability to integrate TVE with OTA broadcast with a DVR is the must-have for me.

Thank you for your prompt response to the matter!

Thanks for confirming. I will let you know when a new beta is ready to try with a possible fix.

Can you please try the new beta build v9.7.2240

It now launches with the new update. Although, it does take a bit longer than it did without the imports.

1 Like