Channels Plus Away From Home Broken In Fire TV

I am using the latest version on the fire tv app store Channels 3.0.0 and it works fine when I am home and I can use on my phone and web browser anywhere. When I click on the Channels Plus, and select Away From Home it crashes the app everytime. I have an Amazon Firestick 4k and have tried clearing cache, clearing data and reinstalling. The port is open and I have verified it. Is this an app issue?


There may be a bug. If you click At Home it works?

I'm not at home currently. But it asks me to enter the ip address. I tried manually entering my home ip and it fails and included :8089 at the end as well and doesn't work. Only have seen this issue when away from my home ip. So yes I believe it is a bug in the fire tv 3.0.0 Channel Plus linking function.

Okay I see the same behavior here. I will work on a fix

Thank you so much! I thought I was losing my mind.

I uploaded a new beta with a fix. So if you need it urgently, you can click Install Channels DVR Beta in the app and then connect remotely using the beta.

Having the same issue. How do you install the Beta on a FireTV stick?

In the app:

Settings > Support > Install Channels DVR Beta

Welcome to the community!

There isn't an option in the Fire TV app under Support for Install Channels DVR Beta.

It has

About Channels
Submit Diagnostics
Help Improve Channels

It's in the Channels DVR app. Is that the app you're using? What version number is shown in the app?

1 Like

Ok so I was using the Channels app in the Amazon Store and not the channels DVR app. I downloaded the Channels DVR App version 3.0,0 and was able to update to the Channels DVR Beta and connect to my server and all is well.

But, I did find another error now. If you load the DVR Beta app it stays on the Welcome to Channels DVR app. If you load the Channels DVR Version 3.0.0 all works fine but if you delete the Channels DVR beta it no longer works. So now we are stuck with two icons on two different versions.

I hope I have explained this in a way you understand. But it works! Just need to figure out how to remove one of these and have it still work, thanks!

In the beta app, does it show a Help button at the top right? Can you click that and click Submit Diagnostics?

1 Like

Will do right now.

I submitted as other and it says Diagnostics Uploaded

Okay I see the issue. You need to go into the Settings > Apps of the FireTV and click into each app then click Stop. Both of them running at the same time is causing the problem. After stopping, launch the beta and remote connect and it should work correctly.

1 Like

I did hit stop on both and upon click remote connect in the DVR beta app it just exits the app again the same as what it did originally.

Ah it exits away, I missed that part. I thought it was just getting stuck. Can you submit diagnostics again and select Crash

1 Like

Sure will do right now. Sorry

Submitted under crash as requested.

1 Like

Thank you! I'm uploading a new beta now with a fix for the crash. It will take about 5-10 min to finish.

1 Like