Chrome dbus issue with Chromium 119 on TrueNAS Core (FreeBSD)

Server was working without issue until this Pre-Release.

I have reinstalled chromium pkg twice now and restarted the server with no change.
The currently installed chromium worked before this Pre-Release and showed no errors in troubleshooting.
Diagnostics have been submitted

Same thing for me. This is what i get when i try and update chrome through the UI

I'm not getting the error with a Synology package install and Channels DVR v2023.11.09.2207

# ls -l /volume1/@appstore/ChannelsDVR/channels-dvr/data/chromedp-chroot/lib/x86_64-linux-gnu/libc.*
lrwxrwxrwx 1 channels channels 12 Nov  4 10:58 /volume1/@appstore/ChannelsDVR/channels-dvr/data/chromedp-chroot/lib/x86_64-linux-gnu/ ->

# ls -l /volume1/@appstore/ChannelsDVR/channels-dvr/data/chromedp-chroot/lib/x86_64-linux-gnu/libc-*
-rwxr-xr-x 1 channels channels 1901536 Nov  4 10:58 /volume1/@appstore/ChannelsDVR/channels-dvr/data/chromedp-chroot/lib/x86_64-linux-gnu/

# /volume1/@appstore/ChannelsDVR/channels-dvr/data/chromedp-chroot/usr/bin/ldd --version
ldd (Debian GLIBC 2.31-13+deb11u6) 2.31
Copyright (C) 2020 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
Written by Roland McGrath and Ulrich Drepper.

I’ll check it out shortly. Thanks for reporting this.

OK so this worked for me. I am on Ubuntu Server so maybe you can find an equivalent procedure on FreeBSD

1 Like

I believe I know the fix so if you can hold off on an alternate solution I’ll be able to validate that my fix works.

I think we maybe talking about two different errors here but I'm holding.

Please try the latest pre-release to fix the dbus error.

@eric should i uninstall what i just did to fix and let Channels handle the install via the troubleshooting fix chrome process or just roll with what i have now?

Here is what I just got.

@TerryD Could you re-run troubleshooting, re-update Chrome and try it again? If you could submit diagnostics again after that that would be appreciated.

@slampman If you're interested, we can dig into what's going on with your setup. I would need diagnostics, and maybe we should start a new thread specifically about it.

Still failing, reinstalled chromium pkg re-ran troubleshooting and submitted diagnostics.

@TerryD: Okay, sorry it's taken me a while to get up-to-speed on the specific setup you have, but to clarify: you are not using the "Click here to upgrade Chrome" button, but are instead installing Chromium yourself, correct?

In this case, I do not believe we've had any recent changes to impact the behavior of system installed Chrome/Chromium.

Are you sure you haven't upgraded the version of chromium on your system recently? What version are you running?

No recent update of Chromium and version being run.

I click here to upgrade Chrome and get a popup window, which appears to me to be saying I need to manually update.
When I click the OK button that popup goes away and there is no indication of any further activity.
The most recent TVE recordings were done Nov. 7th at 7:00 PM.without issue.

Thank you for that detail. I’m really perplexed how this would have started now, but I’m going to see what I can do to work around that error.

Can you try this pre-release build?

1 Like

Still no go sorry. Do you need diagnostics from this one?

Yes please.

submitted as 66213466-022c-4bb6-ad4b-49172856721c

Try this next one and then submit diagnostics again. Thanks!