Continuously Need to Reauthorize

I know I've been posting a lot the last few days, and I apologize!

I've been running Channels DVR successfully on my Mac Mini. The remote streamers are all Amazon Fire TV's. For whatever reason, when I switch apps on the remote Fire TV's, I have to reauthorize. For instance, I go watch Netflix, and go back to Channels, I need to reauthorize.

Logging into my Mac Mini (the server) and rebooting the server program in the tray fixes the issue.

Is there a setting I should change? Ports are manually forwarded, and UPnP is enabled, just to be safe. Any help is appreciated.

What version number is shown in the app?

Can you click Submit Diagnostics from Help at the top right when it fails to automatically auth

Once I get it to reproduce (and my family stops watching the news) I can!

It's version 2.1.23 from the Amazon Fire TV app store.

Hey Aman,

I uploaded the logs. Let me know if you need any identifying info!

Quick update: for another odd reason, when I do try to re-authorize, I get an error message regarding port 8089. I'll remote desktop into the Mac Mini and reboot the server program, and the port error disappears. Then, I am able to re-authorize.

This seems to be a two pronged issue.

Are you using Manual or Automatic port forwarding on your server? Sounds like this might be an issue with UPnP, which is finicky at best.

If it isn't already, set it to Manual, and put a manual port forward in your router instead of relying on UPnP/NAT-PMP.

It's auto, which I agree is probably the topology issue. I'm going to kill UPnP, since both Channels and my Plex server are manually forwarded via hard coded entries in the Fios router.

I'll give this a shot and report back.

Thanks for the tip!

So you've got a manual rule, and you're asking Channels to auto-negotiate a port forward, too?

This might be the source of your troubles.

Alright. Got this going, but now it seems to be a Channels issue. UPnP is disabled, and my Plex server (which is also manually forwarded) works fine from outside.

Channels is not open when I try from my Android, nor is a port scan at showing port 8089 to be open.

I can post some info if that helps @racameron @tmm1. Screenshots or otherwise.

Just so it's clear and explicit:

  • Channels DVR server has either a static IP or DHCP reservation
  • Router has a manual port forward rule for 8089/tcp to the Channels DVR server
  • Channels DVR server is set to use a manual port forward for remote access

Have you tried the old-standard of turn it off then turn it on again?

  • Power off your Channels DVR server
  • Reboot your router
  • After the router is fully booted, restart the Channels DVR server

@racameron thanks for the laugh! I appreciate the help. To your points:

  1. I have configured OS X to request its own static IP with a reservation ending in 155. That's what Plex's port is forwarded to, and works perfectly.
  2. Both UDP and TCP are set to forward port 8089 to that 155 address.
  3. Channels is set to manual.
  4. I've hit "Restart" from the OSX tray icon, as well as rebooted the Mac itself. I have also set the router to reboot.

Still no joy. What's the most frustrating is that Plex works, but Channels doesn't.

What about macOS's firewall? Have you ensured that Channels has access to the port?

While I've been away, I tried killing the Fios router's firewall and OS X permitting port access. I'm rebooting the Mac, the router and all the services to check.

@racameron, thanks for taking the time to help. I know this is an odd issue. Usually, I don't have network topology issues. As an aside, I actually chose to use the Fios router so I could get the 1 gig up and down. All wireless clients are run through an eero set up. I did the direct to the Fios to avoid these issues, so its kind of funny, in a way.

@tmm1 @racameron

FIXED! The Fios firewall blocked incoming port requests by default, EVEN WITH port forwarding. Had to add an exception there.

I am so grateful for the community here. Watching my NYC TV down in Jersey. No issues.

Thank you both!