DirecTV Stream Discovery Channels gone?

I'm not able to get the Discovery channels any more with my DirecTV Stream login. I've tried all of the troubleshooting and nothing has fixed it. Are they gone like Mtv, etc?

I have DirecTV satellite. I just checked the Discovery TVE channel in Channels and it's working fine with my DirecTV credentials.

Did you try these?

Thank you for the response. I wonder why DirecTV Stream isn’t working

Yes, I did go through all the troubleshooting on that link. Nothing got it back

OK, so you already submitted diagnostics then

Same issue here with Discovery channels with Directv Stream.

Check your log and it should tell you "no login form" but if you go to the Science Channel live, you can still log in with Directv Stream.

Hopefully it’ll come back in a few days.

Check the DNS on your Channels machine.
if DNS doesn't work right, channels won't validate.
Grab the latest pre-release.

It's not a DNS issue (wish it were). Channels is not finding the login form for Directv Stream when it tries to authorize. You can go (incognito) to any of the Discovery sites and login with your Directv Stream credentials and all channels will stream.

This is very similar to the Discovery channels issue in August 21 when Directv Stream was renamed from ATT TV.

Prereleases have not addressed the issue.

Once you login with DirecTV Stream at a Discovery site, does DirecTV Stream ask you any security questions or make you click anything before it goes back to the Discovery site to play the video?

No, once you select Directv Stream, it brings you to the log in screen. After logging in, there is no issue viewing any videos.

I have gone to the Science Channel, Discovery, TLC and all have been successful.

I have also logged in using Directv and it logged in okay. On my spare server, I added a Directv source (using my stream credentials) and have been able to view most of the Discovery channels sporadically. I haven’t had success when trying on my primary server.

Unfortunately, I don’t think it’s a channels issue. It's either Discovery or Directv Stream messing with something.

Now have them working on my primary server using Directv as a source.

Had to delete in my collection then re-add using the new source.

Are you saying you subscribe to DirecTV Stream, but you had to delete the source DirecTV Stream in Channels DVR

and then add DirecTV (not Stream) and it worked?

1 Like

I subscribe to Directv Stream.
I added Directv as a source using my Directv Stream credentials.
I x'd the Discovery Channels in my Directv Stream source.
I x'd all stations except Discovery Channels in the Directv source.
I removed all Discovery Channels in my primary channels collection.
I re-added the Discovery Channels to my primary channels collection using the Directv source.

I had to rescan the individual channels several times before they all worked. What might have helped is I rescanned individual channels while watching the Science Channel thru Channels.

Synology NAS
3rd Gen Cube

That's what I thought you meant.
So your DirectTV source works with the Discovery Channels, but your DirecTV Stream source does NOT. But you're using the same DirecTV Stream credentials for both sources.

That's helped me in the past using Xfinity.

The "no login form" error is what I get when I try to authorize using my Directv Stream source.

The reason I tried this is because I tried using my stream credentials after selecting Directv on the science channel live now feed and it worked. Directv Stream is listed as a provider on that site and works.

When using Directv as the provider on the site, it either logged in or gave an error that the Directv server was having issues and to try again later.

Your results may vary!!!

Not yet, but I will be soon. Was just checking here first to see if anyone else is having the same problem.

1 Like

Thank you for the suggestion. The DNS is good, so unfortunately that isn't the issue.

Here's an example from my log file (email address scrubbed) of what is happening on the discovery channels.

2024/02/03 17:43:50.222177 [TVE] action=version product=Chrome/121.0.6167.140 jsVersion= protocol=1.3 revision=@a5856993c61543d4acbee5f848f1750607e87ba0
2024/02/03 17:43:50.223214 [TVE] action=page_ready chromeVersion=121
2024/02/03 17:43:50.224312 [TVE] action=navigate url=
2024/02/03 17:43:50.226412 [TVE] action=request type=Document method=GET url=
2024/02/03 17:43:50.226412 [TVE] action=auth_domain
2024/02/03 17:43:50.226412 [TVE] action=scienceauth reason=login
2024/02/03 17:43:50.711237 [TVE] action=wait_for_page
2024/02/03 17:43:57.064196 [TVE] action=page_ready
2024/02/03 17:43:57.064301 [TVE] action=wait_for_page done=true reason=page_ready
2024/02/03 17:43:59.068692 [TVE] action=click_interstitial
2024/02/03 17:43:59.074497 [TVE] action=tvejs msg="scienceSelect: path=/login-affiliates"
2024/02/03 17:43:59.086011 [TVE] action=tvejs msg="scienceSelect: missing affiliate=DirecTV Stream"
2024/02/03 17:43:59.091168 [TVE] action=wait_for_interstitial timeout=12s
2024/02/03 17:44:00.093960 [TVE] action=tvejs msg="scienceSelect: path=/login-affiliates"
2024/02/03 17:44:00.098390 [TVE] action=tvejs msg="scienceSelect: missing affiliate=DirecTV Stream"
2024/02/03 17:44:01.115845 [TVE] action=tvejs msg="scienceSelect: path=/login-affiliates"
2024/02/03 17:44:01.119557 [TVE] action=tvejs msg="scienceSelect: missing affiliate=DirecTV Stream"
2024/02/03 17:44:02.121883 [TVE] action=tvejs msg="scienceSelect: path=/login-affiliates"
2024/02/03 17:44:02.125498 [TVE] action=tvejs msg="scienceSelect: missing affiliate=DirecTV Stream"
2024/02/03 17:44:03.131698 [TVE] action=tvejs msg="scienceSelect: path=/login-affiliates"
2024/02/03 17:44:03.138585 [TVE] action=tvejs msg="scienceSelect: missing affiliate=DirecTV Stream"
2024/02/03 17:44:04.151640 [TVE] action=tvejs msg="scienceSelect: path=/login-affiliates"
2024/02/03 17:44:04.154143 [TVE] action=tvejs msg="scienceSelect: missing affiliate=DirecTV Stream"
2024/02/03 17:44:05.159151 [TVE] action=tvejs msg="scienceSelect: path=/login-affiliates"
2024/02/03 17:44:05.165533 [TVE] action=tvejs msg="scienceSelect: missing affiliate=DirecTV Stream"
2024/02/03 17:44:06.174509 [TVE] action=tvejs msg="scienceSelect: path=/login-affiliates"
2024/02/03 17:44:06.181020 [TVE] action=tvejs msg="scienceSelect: missing affiliate=DirecTV Stream"
2024/02/03 17:44:07.184991 [TVE] action=tvejs msg="scienceSelect: path=/login-affiliates"
2024/02/03 17:44:07.193150 [TVE] action=tvejs msg="scienceSelect: missing affiliate=DirecTV Stream"
2024/02/03 17:44:08.198335 [TVE] action=tvejs msg="scienceSelect: path=/login-affiliates"
2024/02/03 17:44:08.203836 [TVE] action=tvejs msg="scienceSelect: missing affiliate=DirecTV Stream"
2024/02/03 17:44:09.219829 [TVE] action=tvejs msg="scienceSelect: path=/login-affiliates"
2024/02/03 17:44:09.227579 [TVE] action=tvejs msg="scienceSelect: missing affiliate=DirecTV Stream"
2024/02/03 17:44:10.244517 [TVE] action=tvejs msg="scienceSelect: path=/login-affiliates"
2024/02/03 17:44:10.250578 [TVE] action=tvejs msg="scienceSelect: missing affiliate=DirecTV Stream"
2024/02/03 17:44:11.100292 [TVE] action=wait_for_interstitial err=timeout
2024/02/03 17:44:11.100292 [TVE] action=wait_for_auth timeout=30s
2024/02/03 17:44:11.100292 [TVE] action=fill_form [email protected]
2024/02/03 17:44:11.108307 [TVE] action=fill_form state=done err=&runtime.ExceptionDetails{ExceptionID:1, Text:"Uncaught (in promise)", LineNumber:0, ColumnNumber:0, ScriptID:"", URL:"", StackTrace:(*runtime.StackTrace)(nil), Exception:(*runtime.RemoteObject)(0xc000c0dcb0), ExecutionContextID:0, ExceptionMetaData:easyjson.RawMessage(nil)}
2024/02/03 17:44:11.108307 [TVE] action=screenshot
2024/02/03 17:44:11.249880 [TVE] action=screenshot size=54642
2024/02/03 17:44:11.250384 [TVE] action=capture_html
2024/02/03 17:44:11.264157 [TVE] action=tvejs msg="scienceSelect: path=/login-affiliates"
2024/02/03 17:44:11.264157 [TVE] action=capture_html size=270783
2024/02/03 17:44:11.264812 [TVE] action=tvejs msg="scienceSelect: missing affiliate=DirecTV Stream"
2024/02/03 17:44:11.264812 [TVE] action=script_error err=no login form found
2024/02/03 17:44:11.449304 [TVE] Channel scan 52/173 DISCOVERY failed: no login form found

Have you tried using DirecTV instead of DirecTV Stream, like jagrim did?
Log in at science shows DirecTV Stream in the search, but no DirecTV Stream button

Yes, I know you can click DirecTV Stream in the search results, but what is Channels DVR selecting.

1 Like

Thanks! I just now tried DirecTV instead of Stream, and I did get the Discovery channels, but did not get most of the other channels I should be getting. I just tried to add Stream in addition to DirecTV and just got this.