DVR Pre-Release Build: Web Player Re-design (v2017.05.03.2306)

New build with fixes to Chromecast and iPhone portrait-mode styles: v2017.05.04.1746

curl -XPUT http://x.x.x.x:8089/updater/check/2017.05.04.1746

This is now available to everyone in v2017.05.05.0112.

1 Like

This is great. The TVOS is awesome too. I can’t wait to see the iOS version. :stuck_out_tongue_winking_eye:

1 Like

I can see the icon for subtitles using the new web UI, but the options that show for all programs are wither “subtitles off” or “unknown” on shows that would normally show subtitles.

DVR: 2017.05.05.0112
Server: MacOS Sierra 10.12.4

Tried (same results) with: IE 11 on Windows 10, Firefox 53 on Windows 10, Edge on windows 10

All shows recorded via Cable on a Prime and all the channels are originally mpeg2. Tried both Software and Hardware transcoders.

My transcode is [email protected] and buffer does not go below 2x

These are just the additions to the web player I’ve been waiting for!! And it’s working great. As always, awesome job!

1 Like

Show up as “English” or “Off” for me. But Closed Captions button (subtitles) only show up when software transcoding is selected. No button to turn them on when on hardware transcoding.

My subtitle selection gives me three options - Off, Unknown, and Unknown. Also, when I select the last option, I get the correct subtitles but the lines are in the wrong order. For example, if a character speaks two lines such as “Wait! Hold on a minute,” the subtitles should up as “Hold on a minute” on the first line and “Wait!” on the second line. This is with the hardware transcoder. I haven’t tried the software.

I’ve been using the Chapter Picker with the newly added < & >. Ease of use is excellent and now I just breeze through the commercials. Can’t wait to try this out on next remote trip.

Thanks so much for this awesome addition.

1 Like

Yup. It now almost makes lacking a windows (or mac os) “fat” client no longer a real issue even for internal use… (for when on the porch using a laptop via wifi or just to have something playing on a second monitor)

Alright, it took me all day, but v2017.05.06.0013 is now available with fixes for closed captioning. Also includes some fixes to Chromecast support.

Looks good, but there’s a minor visual issue with the landscape view on the iPhone 7 (using Safari). The slash between the current time and total time is under the last digit of the current time. It’s a minor visual issue, but is always present no matter what recording I watch.

Can you email me a screenshot to [email protected]

The cc fix didn’t work for synology. It just shows ‘unknown’.

Does the button say CC or subtitles?

How about with software transcoding?

What browser?

It shows a CC button. It used to not appear at all when using hardware transcode. Now the hardware transcode shows the CC button, but the only options are off or unknown. The software transcode is too slow so I don’t use it, but I did test this before the most recent update and it used to work with software transcode. Now (after update) it is the same as the hardware option. A CC button, but without the correct option for English subtitles.

EDIT: using Safari. Also tested using Chrome: With Chrome there is no option at all when using hardware. Software transcode does work, though.

Don’t know when this started, but I was on my iPhone watching a recording, from the fly out window with the player is also the settings cog. I clicked delete and got the popup to delete but the screen didn’t take me back to the episode listing for the show, it stuck there. A refresh of the screen fixed it.

Confirmed that the Linux hardware transcoder does not copy closed captions. This is the same issue as on windows in No CC on hardware transcoding

I had enabled closed caption passthrough on the macOS hardware transcoder, but had to disable it again in v2017.05.07.1905 because of stalling bugs. I was able to gather more data on the bug so perhaps we’ll be able to fix it soon.

Fixed in v2017.05.12.0136