ESPN+ & FOX Sports with Custom Channels via EPlusTV

I've recently had all of my ESPN+ recordings fail in the past week, so I tried to refresh the docker by removing the container and adding it back again. But it never asked me to log in again, and it continues to not work.

Refreshing device token (ESPN+)
Refreshing device refresh token (ESPN+)
Refreshing BAM access token (ESPN+)
Refreshing device token (ESPN+)
Refreshing device refresh token (ESPN+)
Refreshing BAM access token (ESPN+)
Refreshing device token (ESPN+)
Refreshing device refresh token (ESPN+)
Refreshing BAM access token (ESPN+)
Refreshing device token (ESPN+)
Refreshing device refresh token (ESPN+)
Refreshing BAM access token (ESPN+)
Channel #7016 has been idle for more than 5 minutes. Removing playlist info.
Channel #7017 has been idle for more than 5 minutes. Removing playlist info.
Refreshing device token (ESPN+)
Refreshing device refresh token (ESPN+)
Refreshing BAM access token (ESPN+)
Refreshing device token (ESPN+)
Refreshing device refresh token (ESPN+)
Refreshing BAM access token (ESPN+)
Channel #7020 has an active event (New York Islanders vs. New Jersey Devils). Going to start the stream.
Refreshing device token (ESPN+)
Refreshing device refresh token (ESPN+)
Refreshing BAM access token (ESPN+)

The hockey game I'm trying to record appears in my recordings but never plays. I look up the video file and it's 0.0 bytes.

Can anyone suggest a fix?

In your docker volumes find a file called tokens.json and delete it. Recreate the container and use the logs to login again.

Thanks, any idea how to access this tokens.json file using Portainer or using a Synology?

Look under Volumes in Portainer and delete the one for this container.

First, a disclaimer: I'm a complete Docker novice.

I got the docker image up and running. So far, so good. Where I've hit a wall is the prompt in Docker to sign & activate ESPN. The only option is for an email password - no option to sign in with TV Provider. I don't subscribe to ESPN+. I access ESPN and Fox Sports through my tv provider. The GitHub instructions include an Environment Variable for ESPN "Set to false if you only want events that come from your TV provider".

I looked through Docker to see if I could locate where to make this change. I don't see it. But to be honest, I'm not even sure if I'm looking in the right area. My question is, where do I locate this variable (and possibly others) to make the change?

Can you show your container settings? Blur out any UN/PW

Also, Can you open the Logs as they might be waiting for a prompt.

I'll give that a go right after work

I'll try looking for those

1 Like

Things may have changed but typically you navigate to espn.com/activate and put in the code provided by the docker. It’s like 6 or 8 characters for espn and 4 characters for Fox. From there you select your provider.

Yes, I did see that. The only problem is it asked me to login with email/password. I don't have an account setup. I login using with my TV provider. I didn't see that option.

It tells you to go to the espn.com/activate and input the code. It recognizes whether it’s an ESPN acct or a provider account. Select your provider and it will bring you to your providers log in page. Log in.

You'll have to set ESPN_PLUS=false along with setting the ESPN channels you have through your provider to true

Just putting out feelers for NFL+ and NBA League Pass. If someone has those and doesn't mind sharing credentials with me I can try adding them (assuming they don't use DRM). I'd be curious about adding DAZN as well.

1 Like

Yes, thank you. I get that part. Apologies if I'm not explaining my issue correctly.

How/where do I find that setting (ESPN_PLUS=false) to make the change?

Yes. I see the espn.com/activate and the code. However when I input the code, my only option is to enter an ESPN account email and password. There's no option to login with TV provider - that I can find.

I might be wrong, but I'm guessing it's because I need to set (ESPN_PLUS=false)? Which is what I'm trying to figure out - where to do that.

This is slightly dated, but look at this:

The things with -e are the environmental variables that you have to put in to set what you want true or false.

Here's an example with almost your exact scenario:

Search this thread for docker run to get more examples if you need them.

1 Like

Where are you running your docker? Synology, windows, Mac, portainer, etc.

If you’re running on Synology, use the wizard and select Advanced settings and you can enter the environment variables. Portainer, if I remember also has an ENV (Environment Variables) spot.
Can’t help with Windows or Mac instalation.

Hi. I'm running it on a Windows 11 NUC. I'll look again to see if/where there's an advanced settings tab in docker. Thanks

1 Like

Hi. Thanks for the reply. So this must be done before I run the docker image in cmd, or can it this be done somewhere in Docker itself?