Fire TV Stick 4K Issue


#1

Hi All!
Been running the DVR setup using an NVIDIA Shield and it's been working well both in and out of the house with my Fire TV devices (Fire TV and Fire TV Stick 4K). However, out of the house my grandpa is using one of my Fire TV Stick 4K devices and tonight had the strangest issue that I could not resolve. When tuning to a channel the buffer bar came up at the bottom of the screen and would stay there like the app was frozen. If I paused for a minute or two and came back it would play a few seconds and audio would drop out then it would 'hang' again. Basically the kind of behavior you would see on a bad network connection. However, all his other streaming apps like DirecTV Now worked fine. Analiti WiFi Tester app shows at minimum 12Mbps download speeds on the Fire Stick, usually even higher on average so there is not a bandwidth restriction.

First I tried going down to the absolute lowest quality settings and that made no difference; the buffer/lockup behavior still happened after a few seconds when tuning to a channel. I cleared the app data and cache of the Channels DVR app but that made no difference. Rebooted the Fire TV Stick 4K which also made no difference. Tried disconnecting it and reactivating it with the DVR, again, no difference. In desperation I completely removed the app via uninstall and downloaded again then reactivated it with the DVR and still the same behavior would occur. This is truly bizarre since the Fire TV devices in my home are working fine and all other streaming apps are working fine on my grandpa's Fire TV.

Finally, I even tried connecting my home's Fire TV Stick 4K on my office TV to the hotspot on my iPhone to simulate the Fire Stick app connecting "out of home" in case there as a quirk with Fire TV app specific to the 4K but I could not re-create the issue. Just wondering if anyone else has seen this type of behavior and if there was a resolution I have not thought of yet?


#2

Did you try running the speedtest in the DVR section of the app? That will do an end-to-end test


#3

That gives me an error saying "this type of link can't be opened" with some reference to OAuth.


#4

Hmm strange. Maybe speedtest doesn't work remotely correctly.

Try doing a speedtest from another browser device via my.channelsdvr.net/speedtest

You can also try streaming in the browser web UI to see if that also stutters.


#5

Thanks, I will give that a try when I am at his house next. The only way I can run that test now is from an OrangePi Zero I have running at his house and it's network driver is garbage so my results there would not be all that accurate. I tried it there for kicks and it returned 7Mpbs so still high enough to where I would think even the lowest resolution streaming should still be able to work.


#6

What's the latency like?


#7

Will need to be onsite with my laptop for an accurate number but the OrangePI is showing ~250ms. Just tested on LTE on my iPhone while in my home and it's showing 8Mbps with ~200ms latency so maybe the OrangePi isn't too far off. Yet, the iPhone streams 720p 4Mbps without a stutter.