FireTV 2017 manual tuner addition fails


#1

I have a FireTV (2017) and manual tuner addition fails. This wouldn’t be troubling, except it works on my AppleTV 4k using Channels app.

Both my FireTV and AppleTV are on the same Wifi network. The SiliconDust Prime tuner is on a different vlan/network from my devices.

I can add, watch, remove and re-add the tuner to my AppleTV Channels App and everything is fine. When I provide the same IP address of the tuner to the Channels app on the FireTV it immediately says it cannot connect.

Is this expected behavior? Most of the reason I purchased the Channels App for my Fire TV is that it’s worked so well for my AppleTV when using a tuner on a different vlan/network.

Any assistance would be appreciated.

Thank you.


#2

We just finished some improvements to the Android/FireTV HDHR discovery code that will be in the next release. We have a beta available through the Play store, but fore Amazon store you’ll have to wait until its officially released.


#3

Thanks for the info. Is there an estimated release of the update for FireTV?


#4

There was a release this morning. Can you see if the About tab says 2.0.11 and try it out again?

After entering the IP, go to the player tab and click Submit Diagnostics > Other


#5

Hi there - sorry for the later than hoped reply. I tried with the new version and it seems to be working correctly. Thanks! I didn’t do a submit-diagnostics. If you still need it, please let me know.