FireTV 4k sidebar menu

When I select the sidebar menu I can not select any of the options. On occasion pressing the “ok” button and the down button on the remote together moves the selected option but only between settings and on now. I’ve tried the iPhone remote app and the FireTV remote same problem. Both the FireTV 4k and 4k Max have the issue. I also have a first gen FireTV stick, remote works great with Channels. Help please


Restart the FireTV ?

I have repeatedly. Also I don't believe it is a server side configuration issue since I have an older FireTV stick that functions perfectly. I would think it is a client side issue specific to the FireTV 4K and 4K MAX sticks. On the server side I am using Channels DVR on a RPI 4 running Raspbian 10.10 (kernel: 5.10.52-v7l+)* on a M2 SATA SSD for OS and storage. I love Channels, thanks for your support.


Try clearing the cache and data in the app. Are you using PiP in any or all of the sticks? In the past I’ve had freezing issues like that due to PiP on my android based clients

Thanks for responding. I cleared the cache and data same problem no difference. I haven’t used PiP at all.


I’m not to familiar with kids mode but I think it disables some of those sidebar items. You could try toggling that setting on off. May be check server side kid settings on those two clients

Thank you for responding. Ok, I have checked all client settings, and they’re all the same. I checked the server settings and the only server over-ride setting for clients is commercial skipping. So to recap the gen 1 FireTV stick Channels App sidebar menu functions as expected. The FireTV 4k and 4k Max Channels app Sidebar menu options can not be selected using the remote that comes with the FireTV sticks.


As my saga comes to a close even though any support has long gone silent I decided to purchase another remote control. After all my research I decided on the Rii mini i8+ keyboard remote. It came highly recommended on a number of sites. What I soon discovered was a better understanding of the issue of feature. Yes, there is still no bolding of which option you’re on hitting either up or down on the selector ring but once you know what option of the side bar menu you’re on you can select say down one click and press the “ok” button in the middle and the option is selected and displayed. WTF!! So maybe it is an issue or maybe a feature!! Either way it works and that is all I need. :grinning:

Problem resolved

Do you have high contrast or other accessibility settings enabled on your android OS? That may explain what's going on