Glitch on AppleTV 16 using Search

Latest Betas (both server & client)
iOS 16
APPLETV 4K new & 4k and old AppleTV

@tmm1 First Search works.
Move out or look at an item.
Then attempt a Second Search. It will NOT allow you to enter a new search term.

The second attempt at Search will not move up to the top and allow access to enter a new Search term without exiting (force closing) the AppleTV client and restarting it.

I don't use the clients, so can't comment on the issue.
Appears nobody else is seeing it, or it's being discussed in another topic.
Makes you wonder sometimes if you're writing with invisible ink, or just on everyone's ignore list.
:smile:

Moved it to Apple TV Troubleshooting

2 Likes

Thanks, we are aware of this issue.

1 Like

Seen this too on the ATV.

FYI, if you scroll far enough down the search results and then immediately back up, the keyboard letters will appear again. Just FYI.

@tmm1 I have filed this separately, but not sure if related in any way:

This has been resolved in the latest TestFlight release.

1 Like

Updated to latest client. Search is still borked, same issue

(Now I can SEE the last search term when I couldn't previously. Simply can't get up there)

Can you explain your issue in better detail with clear steps on how to reproduce it?

The issue that was solved was that after an initial search, editing the query would not adjust the results. Only if you changed the result filter, would the query get new results. This was resolved with the latest update.

Please help clarify the issue you’re having.

3 Likes

First search works completely fine. You can even perform a second search as long as you DO NOT MOVE THE CURSOR down past the [TVShows][TV Movies][Movies] section

The on screen keyboard disappears permanently when you scroll down to inspect the actual movie titles.

You can no longer cursor UP past the [TVShows][TV Movies][Movies] section. The on screen keyboard to never reappears so you can no longer search.

Force closing the app and reopening it only allows you to repeat this process.

1 Like

Thank you. We are looking into this. I can make it happen, but only sometimes. If I'm on the left edge of the screen and scroll up quickly with momentum swipe, I can make it to the search bar most of the time.

This may be a bug we have to report to Apple

2 Likes

I have noticed this behavior, but in Hulu rather than Channels. I believe this is a tvOS bug.

1 Like

I recently purchased the channels dvr for my Apple TV.
Everything seems to work fine except the search function.
I can type a search and find programs however the Apple TV remote won’t let me access the keyboard search function.
The original search is stuck and won’t clear.
I also don’t have a pop up keyboard on my phone when a keyboard input is needed on channels due.
Any help would be appreciated.

1 Like

@tmm1 I went back into time a bit (pre-iOS 16) installed channels version 2002( 9.11.1748) where I KNEW search functioned properly.

Retried search with that version and it displayed the same faulty search issue. It did not work where I personally knew that it had worked in iOS 15.

Therefore it IS AN iOS 16 bug.

Hope this helps

1 Like

Thank you

I’m seeing this issue as well - once I scroll down to the search results, the on-screen keyboard disappears and will not reappear (nor does dictation work) if I scroll back up. This happens on Channels and Nebula since the tvOS 16 upgrade, and did not happen on tvOS 15.

1 Like

This is an Apple bug, and not something Channels can fix.

If this isn’t a case of Channels doing something that’s incompatible with tvOS 16, could the Channels team open a ticket with Apple regarding this? Though I guess there is a chance this is already a known issue on their end - if so, would hope there’s a fix in tvOS 16.1…

I've been out for a few weeks (hurricane issues) but I just became aware that SEARCH is re-enabled! Yea!

It seems tvOS 16.1 (released today) fixes the issue of search not letting you enter another keyword after scrolling down.

1 Like

Perhaps, but I'm still running tvOS 16.0 and the SEARCH is working
-- very odd to say the least so something else is in play.

I'll upgrade it to 16.1 later tonight

AppleTV 4K New with tvOS 16.0 (as well as all the channel's current updated betas) - SEARCH is working

SEARCH is NOT working with 16.1 on the older AppleTV 4K
SEARCH is NOT working with 16.1 on the original AppleTV 4

So it i no longer believe it to be an apple os issue

(Since 16.0 its working on the ATV4K new, I'll wait to upgrade that until this weirdness goes away)