Has the MPEG2 "Fixed" firmware been released yet?


#1

Since switching all my TV's across to Channels and Fire 4K stick's I have been eagerly awaiting the firmware fix to rectify the hardware deinterlacing rather than using software which causes stuttering and frame drops on most UK channels.

As channels has previous communicated directly with Amazon regarding this issue I was just wondering if we know if we are any closer to the fix? I believe an original date of mid to end of Q2 was discussed.

Will be great to get this finally sorted and enjoy some programs which are very difficult to enjoy currently

Thanks


#2

Not yet. They're saying end of June


#3

Thanks. Fingers crossed it doesn't get pushed back or anything. It'll make my life a lot easier not being nagged by the Mrs!


#4

Did this just get fixed in the last 24 hours or so? I was just watching a program tonight through Plex on a 4K stick, and noticed it longer had horrible deinterlacing issues when the camera would pan around the scene! It was a very stark and noticeable improvement! I know Plex is not really a topic of discussion here, but that is always how I knew there was a problem with the 4K stick firmware. Incidentally, I have never had a problem with deinterlacing inside of Channels itself, as I have it set to software deinterlacing.

For reference, the source material that suddenly started playing better for me was a 1080i NBC broadcast originally recorded in WMC, and then copied over to a new Synology NAS when the old WMC machine was shut down. Since there was no way to bring these recordings into Channels, I loaded up Plex, and then noticed the 1080i issue.

My software version on my 4K stick is showing as 6.2.6.4. I didn’t find any release notes about this version online, but admittedly didn’t dig too deep either.

If others can confirm, it appears fixed for me!

Edit: It must be a pretty new update, Amazon’s own website doesn’t have the firmware listed, as of this post:


#5

I just checked on 2 of my 4k sticks one was on 6.2.6.3 and wouldn't update further the other was on 6.2.6.4 so i tried swapping the decoding across to hardware but after 5 minutes the picture had frozen but the sound continuing so i don't think the issue has been resolved.

I've switched back to software and all seems back to normal bar the frame rate issue


#6

Gaaaa, that stinks, I was hoping this would all be related. Bummer. :frowning:


#7

Yeah i know how you feel. In the UK quite a lot of TV is streamed in mpeg 2 it seems so this effects us a lot. Every TV in my house uses channels so I'm desperate for the issue ri get resolved


#8

I assume there's still no news from Amazon on this one? I have been checking daily but haven't seen an update come through, with automatic updates its often easy to miss when an update has happened though!


#9

I just tried ringing Amazon and all they could say is they are aware of the issue but were unable to give me any dates for a fix. They said it has been escalated several times


#10

There are some reports that the fix is available: https://github.com/amzn/exoplayer-amazon-port/issues/81#issuecomment-504453810


#11

Still no luck for me unfortunately but I've got 5 4k fire sticks running at the moment so I'll try updating and restarting each one as often as i can to see if it forces an update


#12

Not fixed here waiting on 6.2.6.4 stuck at 6.2.6.3 ... hopefully will receive update soon.


#13

Mine are on 6.2.6.4 bar 1 but the issue still persists. Reading the github post is sounds like he recieved 6.2.6.4 but still had the issue too. Then another system component which didn't actually change the version from 6.2.6.4 has fixed the issue. That's how i read it anyway


#14

Still appears broken in channels at least. That's after a normal update, then a 'system components' update followed by multiple reboots. Will try again tomorrow!


#15

Just now my Bedroom TV has been upgraded to 1996 instead of 1995 which so far after 5 minutes on ITV HD has not crashed using hardware decoder. There has been no frame skips and awful viewing experience so I believe the rumours are true and the fix really is on way!


#16

Think I spoke too soon, in crashed in the adverts! I will keep testing but still think 6.2.6.4 NS6264/1996 may have the issues


#17

@tmm1 is it possible to see if the crashes are exactly the same as they were before the latest 6.2.6.4 update?

People seem to be having differing success depending on what app they are using for playback, which suggests something has changed.

Regards


#18

I have had 6.2.6.4 1995 on some devices for just over a week, which was exactly the same as the last 6 months.

The one that updated to 6.2.6.4 1996 this morning played with hardware beautifully for 15 minutes but crashed on the adverts and required a restart, since they I am struggling to get it to do anything, but for the first initial play it worked perfectly decoding via hardware without any frame drops that I could notice on ITV HD.

To be completely honest I don't think any of the builds have actually fixed the issue yet though I think my playback was a bit of fluke this morning


#19

They've closed the issue, so this must've been the 'fix'. Any difference in the behaviour @tmm1?


#20

I believe the issue should not have been closed personally. I have seen no evidence from a "channels" point of view anyway that the issue is any better than before. I have different sticks on different builds from 1995 to 1996 and the issue still remains within channels.

I believe the thread was closed with a view to re-opening another one with the specific MPEG content that wont play as the thread went off the rails slightly with some people saying tis fixed and others saying its not.

@tmm1 I am also very interested in if any of these updates mean good news to get channels decoding via hardware?

Thanks