HDHR DUAL - Tuner not available error

Thanks for the prompt fix guys. I had the same issue and now the new version fixed that.

However now with today’s second update I get “tuner not available”, which has never happened before. I rescanned all my channels and it found them all, and it even offered to apply a firmware patch for me (which seemed to work). But I can’t tune any channel from either the AppleTV or iPad app.

I double checked that i can still tune channels using EyeTV on my Mac and it worked fine.

Note that this is on one of the older HDHomeRuns, dunno if that would matter (?)

EDIT: it goes without saying that I power cycled the HDHomeRun but that didn’t help.

Can you try turning off the “tuner sharing” option on the Settings tab to see if that makes any difference.

Wow! Thanks for the super fast response!

That fixed it. Is that setting new? I don’t remember seeing it. What’s it do?

On your DVR’s web UI, in the HDHR section, try clicking the dropdown and doing Scan Network.

Then turn on Tuner Sharing again and see if it works.

Nope, didn’t work even after doing the network scan. Had to turn sharing back off.

Can you the Log tab of the DVR to see what it says?

These are the two most recent entries, the others are from much earlier today.

2017/09/17 21:09:01 [SYS] Created database snapshot: backup-20170917.210853
2017/09/17 21:09:01 [SYS] Removing old backup backup-20170724.143622

So nothing of interest in there. Tried scanning the network and toggling it back on/off to see if a log entry would get generated.

Tuner Sharing basically tells the app to stream via the DVR, so that multiple apps can watch the same channel using just one tuner on your HDHR.

Can you make sure the DVR is still able to stream from your DUAL? Make a recording of something that’s playing right now. See if any errors show up in the Log when the recording starts.

It worked and I still have tuner sharing off. Could that be because it’s using both tuners instead of sharing one?

2017/09/18 08:47:35 [DVR] Starting job 1505728620-ch65.1 Breakfast Television on ch=[65.1]
2017/09/18 08:47:35 [TNR] Opened connection to 10358C62 for ch65.1
2017/09/18 08:47:43 [DVR] Recording for job 1505728620-ch65.1 from 10358C62 ch65.1 into “TV/Breakfast Television/Breakfast Television 2017-09-17 2017-09-18-0847.mpg” for 13m24.926802052s
2017/09/18 08:47:43 [WRN] Buffer for 10358C62 ch65.1 is more than 50% full (clients=1, len=16777684)

I too have one HDHR and am having the same problem. I have 2-ATV’s and an iPhone. I can only watch when sharing is turned off. And what I notice is I can only watch or record one stream even though I have 2 tuners in the HDHR.

Right now I am recording a show, and it will not allow me to watch/record a second stream. “Tuner Not Available”

Both lights are on on the HDHR.

Latest firmware on the HDHR and newest OS’s on my Apple devices…

If I have tuner sharing on and try to access the HDHR (which is idle), the first tuner light will blink for a bit then I get an error “Tuner Not Available”

Same problem for me. Just like the previous poster: If Tuner Sharing is turned on (and all 4 of my tuners are idle) I see the light BLINK and I get the TUNER NOT AVAILABLE error. If I disable tuner sharing everything is then OK.

I have a HDHomeRun EXTEND and an HDHomeRun DUAL. Both are on the latest firmware, latest DVR Server software, etc. Doing a network scan does not fix the issue either – only way I can make it work is by disabling Tuner Sharing on all frontends (iPhone and AppleTV’s).

This only just suddenly started happening recently.

Further research shows that if I change the under priority to put the EXTEND before the DUAL, it works. When I use up both tuners on the EXTEND and try a 3rd stream from another device I get TUNER NOT AVAILABLE again. It looks like the DVR is not properly working with the HDHR DUAL, only the extend. Thoughts @tmm1?

Any errors shown in the DVR Log? Is the DVR able to record from the DUAL?

Seems like something has changed in the DUAL’s behavior with the latest firmware update.

Nothing in the logs. Scanning for new tuners does not even show anything in the logs.

I changed priority so the DUAL was priority #1 in the DVR, and tried recording some shows. I can see the lights go on upon recording and can confirm that the DVR indeed seems to be utilizing the DUAL properly – just not when other frontends are set to go through the DVR. Strange. Anything else I should try or get information on?

I can watch or record from the HdHR but only one stream at a time with sharing turned off.

Absolutely nothing in the logs …

Interesting, I can use 2 streams if I use the DVR server which is on my Linux server. I can watch a stream from the server and record another program at same time…or watch on the server and watch on ATV or iPhone.

Tuner sharing still must be off however…

Guess I’ll have to break down and get myself a CONNECT…:slight_smile:

Finally got a chance to dust off my DUAL and take a look. I see the same issue- is a bug in the app that I will fix for the next beta.


New beta is available on TestFlight

Using the new IOS beta, I can turn tuner sharing on and do 2 streams.

If I have ATV running a stream, and I try using the new IOS beta on my iPhone - “Tuner Not Available”

Is there a ATV beta update? If so I guess I have to sign up.

Thank you for all your work on this!

When I use the IOS beta I can view 2 streams off the HDHR.

When I use the ATV beta I can view 2 streams off the HDHR.

But if I use IOS beta and the ATV beta at same time I get tuner not available.

I will test more tomorrow.