Latest Update not working 3.2.14 (Legacy tuners showing black screen on channel change)


#1

Hi my Apple TV dowloaded the latest update and the app won't open now. Every time I press to go into the app it just quits. the latest update showing is 3.2.14. released on April 23. Thank You


#2

Can you try to uninstall and reinstall?


#3

My ATV4 (Model A1625, 32GB) also picked up Channels V3.2.14 this morning.

I am able to watch all OTA stations but some (apparently SD) do not tune properly (get spinning wheel and then a blank screen). Tuning a different station and then trying the original station seems to work. Sometimes I have to switch channels a few times (back and forth) for tuning to work.

I also notice more picture breakup (happens intermittently) on some stations than with previous app version.

The stations having tuning/breakup trouble appear to have good signal strengths and symbol quality.

I use a legacy SD tuner (HDHR-US) using FW 20170930.

Hope this can be investigated and resolved.

Unless app unistall & reinstall is also required to fix this issue.

Thanks!


#4

Oh, forgot to mention. my ATV is using tvOS 12.2.1 (16L250).


#5

@SolarWind Does the HDHR app on iOS or the InstaTV app on tvOS work? There were no changes to the streaming code in this release, so it sounds more like a signal or network issue.


#6

I installed new version last night without any problems. But I did not watch SD. I also have ATV beta I can test on later today when home if still issues.


#7

Hi I checked my updates for Apple TV and it had an update available. The update fixed the issue thank you for the great customer support! quick response. awesome product!


#8

Thanks for the quick reply and sorry for my delayed response.

I think you are right with your suspicions.

I just tried the same SD stations again that were having issues tuning earlier today and right now they work immediately, as they always have. So, the tuning problem I reported is not occurring at present.

As to the infrequent picture breakup: it didn't happen a lot earlier today and, after a couple of minutes watching right now, it seems to not be happening (things are fine now).

Most importantly, given that there were not changes to the streaming code in this release, I do believe something strange was going on at my location earlier today.

I suspect the OTA signal more than the LAN/WLAN signal. Depending on the weather in my area, sometimes aircraft flight patterns are modified which can cause brief OTA reception disruptions (~1 second or so where signal strength fluctuates significantly as an aircraft transits reception path from OTA tower to my antenna). I'm assuming that if I just happened to tune/retune during such a moment, there would be the issue I mentioned earlier. The only other thing I can think of is that the OTA stations are messing with their encoded picture resolutions or encodings, esp. for the SD channels. I live in a large metro area where some stations use unusual SD pixel resolutions. It is amazing how many streams they push through one 6 Mhz ATSC OTA channel. (One LPTV station was doing 9 [IIRC] SD streams for a while! Their PQ was bad on most channels.) Also, a while back, one station seemed to have an encoding problem, as multiple receiving devices/apps had issues consistently decoding the picture properly until (suddenly) the problem went away.

So, my apologizes if I chimed in too quickly upon experiencing the issues. I appreciate the good quality of the Channels app which is why I was so surprised earlier today to have the tuning problem. (To date, I have never had a "tuning" issue with Channels which is why I reacted (apparently too) quickly to report it, having noticed a new app had been installed overnight.)

As to my LAN/WLAN: I will keep monitoring it too. Since my SD tuner streams via UDP (IIRC), you are right that problems in the home network will cause picture breakups. I have been careful in my network setup to optimize throughput and seldom see picture breakups due to home network packet loss.

I will keep monitoring the situation. If the problem(s) recur, I will investigate more before posting again. If needed, I'll fetch the base InstaTV app for tvOS and compare. (I don't have an iOS device to try the HDHR app on.)

Thanks for a great app and your quick assistance and sorry for (apparently) chiming in too quickly.


#9

Hi again.

A few minutes ago, I experienced the same symptom I reported earlier (trying to tune from one channel to another just shows a black screen with timeline on bottom and spinning "circle").

For example, I am on PSIP channel A.1 (in HD: physical channel A).

  1. I try to tune a new PSIP channel B.2 (in SD; Physical channel B). The above symptom occurs.
  2. I then try to tune a new PSIP channel B.3 (in SD; Physical channel B). This tunes immediately.
  3. I then immediately return to PSIP channel B.2 (in SD; Physical channel B). Channel now tunes.

I notice a similar issue (occasionally) when switching from an SD channel to an HD channel on a different physical channel.

A few observations:

  • I had never experienced this issue on previous version(s) of app
  • I do switch between channels quickly. (i.e. don't watch the newly tuned channel long).

My suspicions at the moment:

  • Perhaps some interaction between tuning and buffering of stream (before playback) is happening?
  • Perhaps there is some HD to SD or SD to HD switching that is involved in creating the problem?
  • Perhaps the fact that I am using a legacy HDHR tuner plays a role?
  • The signal strength of the physical channel is unlikely to be fluctuating much between my tuning attempts. (The signal on the physical channels is generally quite good and not usually affected by environmental factors, especially in the small intervals I am experiencing these issue.)

I even restarted my ATV a couple of times and was able to reproduce the above issue after each reboot.

This is not a huge issue (I can try to retune until the PSIP channel I want actually "locks-in") but it does create an annoyance factor.

Does anyone else experience this?

I sent in 2 player log reports.

Thanks!


#10

I want to revise my channel notation so that it is clearer (and avoid the overloaded use of A & B).

The updated example is:
I am on PSIP channel A.1 (in HD: physical channel X).
1.I try to tune a new PSIP channel B.2 (in SD; Physical channel Y). The above symptom occurs.
2.I then try to tune a new PSIP channel B.3 (in SD; Physical channel Y). This tunes immediately.
3.I then immediately return to PSIP channel B.2 (in SD; Physical channel Y). Channel now tunes.

Thanks.

Update:
I've done more testing and have an update.

It seems the issue I am experiencing may be related to scaling SD4:3 content to full screen.

I normally have the Playback Setting "Stretch Video to Fit" set to ON.

With this new app version, when this is ON and I try to switch from an HD(i.e.16:9) channel on 1 physical channel to an SD4:3 channel on a different physical channel, the problem occurs.

If I turn the switch OFF, the problem does not appear to occur.

Also, when I watch an SD4:3 channel with the switch ON and try to tune an HD channel, the problem seems to occur. Turning the switch OFF again appears to prevent the problem.

Interestingly, it seems that when the problem occurs (e.g. tuned to an HD channel & switching to SD4:3 on a different physical channel) the issue may fix itself by tuning from the "hung" SD4:3 channel to an SD16:9 channel on the same physical channel.

I have been running with the Player "Stretch Video to Fit" setting set to ON for a very long time with NO issue (until now).

Don't know if the OTA stations involved have changed their picture size (eg. from 704x480:SD4:3 or 720x480:SD4:3 or 640x480:SD4:3 to 528x480SD4:3) or if the scaling feature in Channels app itself needs some TLC...

More if I can debug more.

Update2:

I checked the picture resolution for the channels I tuned and experienced the issue I reported above.

Those particular channels are being transmitted as follows:
PSIP 66.3: 640x480:SD4:3
PSIP 9.3: 720x480:SD4:3.

As FYI, one physical channel in my area carries multiple virtual channels (e.g. PSIP 38.6) at 528x480:SD4:3 .

Most SD channels I watch in my area run various SD resolutions but are using 16:9 aspect ratio.

I only occasionally watch these particular 4:3 aspect ratio channels (which would require full screen scaling by Channels app). But, I do often briefly tune them to check the program on them...

Thanks!

Update3:
After Update2, I left my Channels App Setting for "Stretch Video to Fit" set to OFF.

Interestingly, I now see (most of the time) the tuning problem reported above when switching stations as follows:

  • 720p -> 1080i
  • 1080i -> 720p
  • SD-WS (WideScreen) -> SD-Std
  • HD (not sure if it was 720p or 1080i) -> SD-WS.

The following station transitions appear OK (assuming I tested enough and starting state is consistent):

  • 720p -> 720p
  • 1080i -> 1080i
  • SD-WS -> SD-WS
  • SD-WS -> HD
  • SD -> SD (but I didn't write it down; hope I recalled it correctly).
    The above transitions seem to generally imply that channel transitions in which aspect ratio and (in case of HD content, resolution) does not change work OK.

I tried creating a full tuning permutation success/fail table but I don't trust my results yet (they are inconsistent). I'm assuming they may be inconsistent because the state of the app after a failed tuning transition may depend on the attempted transition.

It appears, though, as if a new station tuning request resulting in a change in Aspect Ratio (Std or WS) and/or HD picture resolution (when compared to currently tuned station) may be involved in creating the issue I am observing.

Anyone else see this?

If my observations and documentation are accurate, I think I may be better off turning the "Stretch" setting back "ON" because I have fewer issues that way. (I tend to transition between HD and SD-WS stations more often than between those and SD-4:3 content).

Thanks.

Update4:

After previous update, I went and downloaded the ATV InstaTVPro app (as previously requested). Installed it. Scanned for channels (successfully).

I tried tuning various combinations/sequences of channels on InstaTVPro: No issues. Everything works fine.

Went back to Channels app with Stretch setting OFF:

  • Some channels/sequences work; most of the time I STILL see the above reported issue(s).

Thanks,
Helmut


split this topic #11

3 posts were split to a new topic: DVB tuning issues on latest release


#12

@olderi What kind of HDHR do you have?


#13

Hi again.

One other observation: the software routine (in the "Channels" Setting menu) that scans for OTA PSIP channels and classifies them as HD and SD has, to my recollection, never worked correctly on my legacy HDHR-US tuner.

For example, currently, out of 17 HD PSIP channels, it only lists 1 as being HD. It (incorrectly) lists all the other ones as SD.

This scanned channel classification has behaved this way for a very long time.

Could this classification be affecting the proper tuning/playback of the stations in this new app version?

Thanks!


#14

That scanning does not come from Channels. That is handled by the tuner itself.

HDHR tuners need an initial channel scan to find the channels. In doing this, it also tries to connect to the streams so it can determine the resolution, audio channels, etc. (Additionally, newer tuners run a background channel scan on a semi-regular basis.)

While the information provided in Channels' interface is nice, it'd be better if we could modify the information to correct it instead of relying on HDHR's inadequate scanning.


#15

The legacy tuner models don't provide hd/sd data in the lineup. We try to guess which ones are HD based on the callsigns, but that's not very reliable.

I suspect there's another bug specific to the legacy tuners which is causing the tuning issues you're having. Can you click Submit Diagnostics on the bottom of the Settings tab and post your HDHR device id.


#16

Thanks for your reply.

I privately sent you my HDHR device ID plus a new log report from around 0334pm Central Time. (I sent 2 other log reports back on April 27 around 755am Central Time.)

I noticed the posts from user olderi have been moved to a different (DVR-related) thread. I think that poster is correct about the randomness of the issue. It does appear to not be as systematic as I first suspected. In fact, I too am observing an increasingly random nature of the tuning/playback error I reported (and violation of some of the earlier reported "patterns".)

Also, I am currently wondering if the issue could be due to the playback engine not properly storing the video to be played back. I only mention this because if I wait a while with the tuning "spinning circle" and then try to retune, I often (always?) get a prompt telling me I am behind the timeline (although nothing has played) and asking if I want to abandon the playback...

Thanks for looking into this. This fairly common occurrence requiring multiple tuning attempts is beginning to get on my nerves...

I am going to look into getting a newer HDHR tuner.

Thanks!


#17

A newer tuner definitely wouldn't have these issues.

I'm going to have to dig my legacy tuner out of the closet and run some tests.


#18

We have narrowed down the issue and will be releasing a new version with a fix.


#19

That is good news. Thanks for looking into the issue; I appreciate it.

I will try out the fix once it is released. Can you share any information about the cause of the issue?

As indicated earlier, I have purchased an additional SD tuner, an HDHR EXTEND [HDTC-2US]. I will add it to my home network once it arrives.

Thanks again.


#20

It appears to be some sort of race condition related to the udp connections used by the legacy tuners. We are not sure exactly what changed to cause it but have added a workaround fix to the next release.