Lost numerical entry w/Harmony

I have been using a Harmony remote on my system for years. I have always been able to enter channel numbers directly. Suddenly I have lost this, pressing number keys does nothing. All other functions work.

I have removed and re added all my devices, reset the Hub but still no numerical entry. Any ideas?

As of version 10.29.327 numerical entry of channel numbers no longer works while in the guide when using a Harmony remote under Bluetooth control.The last version it works is 10.27.1604

Numerical works while actively watching a show, but has no effect if on the guide.

Current release version works correctly.

No one else sees this behavior? I can’t find any fix and noticed the bug started with the new caching update for the guide.

Just as a data point, I am running the latest TestFlight (11.6.2052) on two AppleTV 4K’s, and am not experiencing this issue as you’ve described it.

One AppleTV is controlled by a Harmony 650 (infrared only) and the other is controlled by a Harmony Companion (set up as a Bluetooth keyboard.) I am able to manually enter channel commands with both of them, as I have been able to since the start, and it works to change the channel I am watching in Channels.

I haven’t changed any of the configuration, haven’t removed or re-added any part of it, and it all still works.

I have never been able to manually enter channel numbers when in the guide, though. I tried it a long time ago, and it didn’t work then, and I didn’t know that it had ever started working, so I’ve never missed it. I’ve only changed channels this way whilst watching live TV.

That said, I did read elsewhere that there is a newer entry for AppleTVs in Harmony’s database, called “Harmony Pro BT Apple TV 5.” And with this newer entry, there are now true REW and FF buttons. (No more press and hold to get REW and FF. The left and right direction buttons still work as before, so pressing them will skip back and forward, respectively.)

I’m still using the older entry, and it works fine for my needs, so I won’t be changing anything soon. But I mention it in case that newer entry, or some other one, is what’s caused your issue.

What specific settings did you choose when configuring the Harmony to control the AppleTV?

I am using a Harmony hub in Bluetooth mode, not IR. Harmony Pro Apple TV 4 preset. Up until the beta version I mentioned, I am able to directly go to any channel in the guide. Enter a number and the guide zooms to that position. When watching tv I can also direct enter any channel number.

But now I can only go direct when watching. Numbers in the guide do nothing. But the current stable release still works as before, so for now I have locked down my updates so the stable won’t get overwritten.

Me too. And I never knew that manual channel entry worked in the guide too, even if temporarily.

I’m glad you mentioned it, hopefully this feature’s disappearance is just a bug and it will return one day soon.

Also seeing the exact same behavior using my Sofabaton remote. Numerical entry no longer works in the guide since version 10.29.327. Still works on the stable. So it’s not a Harmony thing.

Thanks for reporting this. The fix is out in the latest Testflight.

1 Like

Still not working. Sorry.

Please confirm you are on the latest TestFlight beta and submit diagnostics.

With the latest TestFlight (11.8.426) I can confirm that manual channel entry in the guide (to jump to that channel's row) is working for me, on the living room AppleTV 4K with a Harmony Companion remote (set up as a Bluetooth keyboard.)

It's not however working on the bedroom AppleTV with a Harmony 650 remote. I'm not sure if it's supposed to, as this remote only uses Infrared. But manual channel entry still works when watching live TV and it works when I use these "favorite channel shortcuts," via the 650's screen and the corresponding right and left buttons.

Can you see if it works in 10.27.1604?

I just tried, and yes, it works there, when manually entering the channel number buttons in the guide. Then I updated back to 11.8.426 and it still works. I'm not sure why it didn't work before!

I will however note that neither version works with my favorite channel macros though, pictured above. Perhaps they're transmitted too quickly? When I do try those, in the guide, only the final "enter" key works, which tunes into whatever channel happens to be highlighted in the grid. It's not a big deal to me though as I'd never remember each channel's number anyway in order to manually enter them. That's part of the reason I set up this remote with favorite channel shortcuts in the first place.

My guess is there isn’t enough delay between the numbers. Is there a way to change the delay?

On 11.8.839. Diagnostics submitted just now

I tried Harmony and Sofabaton on two ATVs and both would not work in the guide. Submitted diagnostics for the 2nd ATV

@mtnbkr60 What channel were you trying to get to? Does it work when you try on TestFlight build 10.27.1604?

Update: I've found the issue with broadcast TV channel numbers and the update will be coming out shortly.

Any channel number entry does not work, off air or TVE.

Everything works on 10.27.1604

The latest Testflight has fixed number entry for broadcast channels:

2 Likes

All fixed! Thank you. We now return to your regularly scheduled program.