Movie quits prematurely

Watching the movie "An Affair To Remember" (remotely/away from home) and it's down to the last 2 minutes and it just quits.
I can't get the remote to move past the 112min mark whatsoever.

If I play the movie through on my laptop it plays just fine all the way through the credits.

Is there a setting on the Fire TV that I need to adjust?? The WAF is at an all time low!

That’s odd. I wouldn’t think there is a setting that would help with that. What quality do you have the client set to for remote viewing on the fire stick?

8 Mbps - though everything else plays just fine.

Is the movie mkv or mpg?


Get this...I set the streaming quality down to 300Kbps, and the movie was able to play passed the 112min mark to the end .. The quality absolutely sucked, obviously, but it did play.
I then proceeded to put the quality back to 8Mbps, when I noticed that there was one more option for "original" -which I wasn't aware of.
So I put I set it to that quality and again, the movie DID play to the end of the movie. I don't know - maybe getting channels to play to the end @ 300Kbps "kickstarted" it to recognize the rest of the file?

Based upon the image you posted, have you tried the "Regenerate Video Index" option?

I had another movie - "The Incredible Mr. Limpet" with the same action.
I tried the Regenerate this time, but it didn't help. The only solution seems to be to drop the streaming quality. We dropped it to 3Mbps, the quality drop wasn't noticeable but at least it played through to the end.

Please upgrade your DVR to prerelease v2021.06.30.0218 and let us know if this issue is fixed.

I can do that... only it's hit or miss on which movies it will occur on. Once I get a movie to play by dropping the streaming quality, it behaves itself when I put it back to 'original' quality.

Okay submit diagnostics if it happens again

Please upgrade to v2021.07.01.0009