On Now becomes unnavigable after rearranging a tile

I'm trying to help a friend with a new AppleTV client install. After a rearrange on the icons, and pressing the using the Back button to exit the rearrange, The On Now screen is no longer navigable. Its unpredictable to get out of the top menubar into the icons and once in the icon field, it appears to be stuck on the last icon rerarranged. Deleting and and reinstalling the app makes the On Now navigable with the default icons until one is rearranged.

What did we do wrong?

I think I responded to your report this morning via email. Could you reply there and follow the instructions?


Hi Jon,
Thanks for the quick response. There were two problems. now one remains.

I was helping Paul Halverson for whom I setup a Channels DVR Server long ago. He sent you the logs and your response he received this afternoon proved correct. I ran smartctl on his drive and it was failing. He purchased a replacement and I'm in the process of migrating his server to it. Thanks for that.

Paul switched to an AppleTV DVR client thinking that might have been the source of his disk problem, which of course it is not. He showed me the problem after reordering an icon in his Now On screen. He also showed that his FireTV client has no similar problem. I couldn't work around it on his AppleTV, so I created the thread. I've never used the Now On screen on my AppleTV client but when I returned home, I tried it and mine gets stuck, too.

Any suggestions what to try?
Dave Poole

Hi Jon, I cannot find an email beyond a request to send you a video of the problem. Can you resend? thanks!

That's the only response I sent, the request for a video to see the problem.

If you can't find that email again, just shoot us a video to [email protected]