Playback Failed on NVIDIA Shield v9

I did not say anything other than give you the link to go read for your self the existing threads on the issues you are having.

The form software loads a preview of posts, you need to click the link to read the full thread, not just read the preview.

Also, you are not giving that useful info and very vague in your first post, you did not say that you had done all of that already.

If you read through the already exiting thread on the issue, you will see others having the same issues. Post there if you still have issues unless other wise told by mods to start a new thread.

This comment was uncalled for and was what got my dander up. It smacked of technical elitism. As if only the technical savvy should presume to use the Shield.

You asked "What is an APK?" if you do not know what that is...then you come across as not tech savvy to understand detailed explanation given as how to proceed.
Hence why googling some questions is your friend.


Frankly, get over it. An attitude like that, not many will want to try and help you.
If you can't be bothered to read posts already there on the topic, again, not much we can do for you.

TLDR: the Shield is pretty much boned right now, broken by Nvidia OS update. Can not be fixed by anyone but Nvidia and who know when that will happen. EVERYONE is having major issues, not just Channels DVR users. Do what the dev recommend, move your server to another supported device/platform is the only way to get back up and running reliably.

Whatever!! You make too many assumptions about me. I did read all the posts and saw no answers to my problem that's why I opened a new topic. The only point you might be right about is that maybe I should have posted all this to the main thread.

There also is the Channels DVR Discord server, Help channel, if a "live" chat is more your style of working through issues.

But it is not as active as here.

This sounds similar to what others are experiencing on 9.0

The system locks up and requires a reboot. Seems like adopted storage becomes disconnected.

We can't fix it because it's at the OS level and affecting all apps.

Maybe try this?

You can also upgrade to the hotfix which might help: NVIDIA SHIELD TV Software Upgrade 9.0+ HotFix Image

But honestly it seems like it's broken until nvidia fixes it.

If you have access to a USB keyboard to plug in the Shield and another system to run adb/fastboot via USB, it took me about 15 min to reflash back to the 8.2.3 release on my Shield TV Pro. (You do need to sign up as an Nvidia developer to get access to the image).

Of course you will be setting up afterwards just like a factory reset. Reapply Google updates and reinstall apps.

@tmm1 Thanks for the information.

Depending on how long NVIDIA takes to fix the issues, I might consider @john9527 suggestion.

Do we know if NVIDIA is in fact working on the problem.

Dude, there has been serious issues with Nvidia's software releases on the Shield since it first came out. I know, since i bought the 2019 model when it first came out. I and many others have posted about issues many times on their forms. Send in bug reports....all ignored.

They do NOT care about fixing issues, and only say a fix will come soon if they even acknowledge an issue exists. 8 months, users waited for them to "fix" the removal of Bluetooth Audio codecs and other issues. And the update did not even fix it. Took another 6 months or so. You can see it on their forums.

The Shield so rarely gets updates, its a joke.

At this point, my 2 Shields still work fine as Clients devices for Channels DVR and my Pi as the server, and so far, have no issues, but that is the only thing they are used for now, and only app that is installed, i removed all others. I myslef, for my use, moved to Apple TV 4K some time ago. Much better experience.

I would suggest, as all the others and devs here state, since it can not be fixed, move to some other platform for your server. And, if the Shield it self is now pretty much unusable as a device, go get a Google Chromecast with google TV or Walmarts cheap Android Tv streamer thingy, to use in the mean time, as you wait long time for Nvidia to get their s*** together.

1 Like

I checked my usb settings and they were set to "Always On" and I continue to get random shutdowns.

Thanks good to know.

I thought I would try using adb/fastboot to reflash the Shield back to 8.2.3.
I encountered a problem when the "adb devices" command failed to show the Shield on my Windows 10 PC. I downloaded the driver provided by the link in the instructions and tried updating the driver in "Device Manager" as suggested, but the driver update failed. Any suggestions?

Did you adb connect first, and grant access on the shield?

No. I did not see that in the instructions. I did connect it physically via USB cable.
Just tried: adb connect
Got message:
cannot connect to No connection could be made because the target machine actively refused it. (10061)

I used a notebook running Linux Mint to do the downgrade....the instructions worked just as written. But they assume you already know how to enable USB debugging.

When connecting via USB it should be automatically detected (no 'adb connect' required), but did you enable 'Developer Mode' on the shield first (go into the Device preferences, About, and then down at the bottom highlight the 'Build' line and press enter 7 times). Then open developer options and set USB Debug mode. Then reboot with the USB connected (must be the Shield USB port furthest from the HDMI port) and you should get a prompt on the shield to allow the connection.

The other Shield USB port should be connected to a USB keyboard, as you need to interact with the Bootloader menu on the Shield.

Thanks for the reply @john9527.
I did everything you suggested. However the PC does not see the Shield when I enter: adb devices.

So, when I enter the command: fastboot oem unlock
the response is < waiting for any device>

This implies that fastboot does not see the Shield either, so it waits.

Maybe the problem is that I'm using the android sdk I installed a while back from Google.

I tried installing the SDK from NVIDIA put the link given did not respond.

I'm assuming you got the Allow connection prompt on the Shield?

Then on the PC you did
adb reboot bootloader

Do you see the bootloader menu on the Shield? You need the Shield HDMI connected and use separate displays for the Shield and the system you are running adb on.

Then the
fastboot oem unlock

wil give the 'waiting' message, waiting for you to navigate the bootloader output on the Shield to 'Confirm'

At least that's how it went for me.....

I can understand your frustrations, but Nvidia is working on the problem. I got the second patch last night, so please don't be so quick to condem them. I am sure that they are overwhelmed because of this. Now, having said that, I agree that they should have done a much better job of testing it before they released it. Please try to remember that none of us are perfect...we all make mistakes daily. As far as trying to run the server on my Shield, I will wait until the final fix is released as it is running fine on my PC as long as I don't use commercial detection.