Pluto for Channels

For some reason, I have tried restarting the docker container but the EPG data isn’t there on channels?

What is logged on the DVR web ui log when it tries to log the Pluto xml?

For Docker on Windows do I use the " WSL 2 backend " or the " Hyper-V backend and Windows containers " backend?

WSL2 - the other is a windows container pipeline which has little development


Mine has lost all XML/Guide data. Server is running fine.

Mine has been working fine since I setup the scheduled tasks to keep it on track.

What does your Pluto for Channels Docker Container log show?

I am having the same issue I think. Synology docker. The log says mv: can’t rename ‘playlist.m3u” : No such file or directory
Same for the epg. This worked at some time in the past, so I or the system changed something. I checked permissions, etc. I also tried setting up tasks to stop and start as root. It still errors.

1 Like

The only time I've seen that error was when my Internet connection was down while Pluto for Channels was trying to grab an update.
If you click on the EPG link on your Pluto for Channels web page
Screenshot 2021-07-31 at 11-31-45 Pluto for Channels
and look at the XML guide data you can tell how "fresh" it is.
Mine last fetched about 30 minutes ago and the first guide entry shows
programme start="20210731101500 -0700" (10:15am this morning)

   <channel id="watchfree-movie-binge">
      <display-name>WatchFree Movie Binge</display-name>
      <desc>Your go-to channel for top free movies. New movies added monthly, from edge-of-your-seat action, date night rom-coms, to laugh-out-loud comedies. Binge them all before they’re gone.</desc>
      <icon src=""/>
   <programme start="20210731101500 -0700" stop="20210731120000 -0700" channel="watchfree-movie-binge">

I do get the Pluto for channels page but clicking on playlist or epg goes to 404 not found…. Internet is fine, and I resurrected a qnap and it gets the details fine, but not sustainable, qnap is crappy. I have 2 synology, the 2 bay is working but not for Pluto as described. had a syn 918+ die on me yesterday, but got another one coming.

Sounds like an issue with your Pluto for Channels container.
Are you running the latest container v1.2.1?
Maybe @maddox has a suggestion.

I just recreated first downloading specifying 1.2.1 then create container, same result. Maybe it is a setting relevant to the configuration of the synology. I realize this is beyond regular requests, just hoping someone knows something…

I'm running it on my Synology DS1513+ no problems.
I didn't specify a tag, so am running 'latest'.

docker run -d --restart unless-stopped --name pluto-for-channels -p 8080:80  --env TZ=America/Los_Angeles jonmaddox/pluto-for-channels

Not sure what the difference between tag '1.2.1' and 'latest' are

Perhaps you can see the problem by looking at the container log.
You can export the log from Synology Docker and save it to a CSV (comma separated) text file.
It's structured in reverse chronological order (latest entries first).
Screenshot 2021-07-31 at 12-58-06 DS1513PLUS - Synology DiskStation

2021-07-31 20:06:47 stdout - - [31/Jul/2021:20:06:47 +0000] "GET /epg.xml HTTP/1.1" 404 555 "" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/91.0.4472.166 Safari/537.36" "-"
2021-07-31 20:06:47 stdout 2021/07/31 20:06:47 [error] 13#13: *2 open() "/usr/share/nginx/html/epg.xml" failed (2: No such file or directory), client:, server: localhost, request: "GET /epg.xml HTTP/1.1", host: "", referrer: ""
2021-07-31 20:06:44 stdout - - [31/Jul/2021:20:06:44 +0000] "GET / HTTP/1.1" 200 910 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/91.0.4472.166 Safari/537.36" "-"
2021-07-31 20:05:58 stdout Last ran: Sat Jul 31 20:05:58 UTC 2021
2021-07-31 20:05:58 stdout mv: can't rename '*epg.xml': No such file or directory
2021-07-31 20:05:58 stdout mv: can't rename '*playlist.m3u': No such file or directory
2021-07-31 20:05:58 stdout
2021-07-31 20:05:48 stdout e[90m at processTicksAndRejections (internal/process/task_queues.js:80:21)e[39m
2021-07-31 20:05:48 stdout e[90m at emitErrorNT (internal/streams/destroy.js:84:8)e[39m
2021-07-31 20:05:48 stdout e[90m at Socket.emit (events.js:210:5)e[39m
2021-07-31 20:05:48 stdout e[90m at Socket.socketErrorListener (_http_client.js:407:9)e[39m
2021-07-31 20:05:48 stdout e[90m at ClientRequest.emit (events.js:210:5)e[39m
2021-07-31 20:05:48 stdout at Request.onRequestError (/usr/src/app/node_modules/e[4mrequeste[24m/request.js:877:8)
2021-07-31 20:05:48 stdout e[90m at Request.emit (events.js:210:5)e[39m
2021-07-31 20:05:48 stdout at self.callback (/usr/src/app/node_modules/e[4mrequeste[24m/request.js:185:22)
2021-07-31 20:05:48 stdout at Request._callback (/usr/src/app/index.js:120:26)
2021-07-31 20:05:48 stdout at JSON.parse ()
2021-07-31 20:05:48 stdout SyntaxError: Unexpected token u in JSON at position 0
2021-07-31 20:05:48 stdout
2021-07-31 20:05:48 stdout ^
2021-07-31 20:05:48 stdout undefined
2021-07-31 20:05:48 stdout undefined:1
2021-07-31 20:05:43 stdout
2021-07-31 20:05:43 stdout
2021-07-31 20:05:43 stdout
2021-07-31 20:05:43 stdout
2021-07-31 20:05:43 stdout [INFO] Grabbing EPG...

I don't know @maddox code used in the container, so can't comment on the errors.
What version DSM and Docker are you running?
I'm on DSM 7.0-41890 and Docker 20.10.3-1233

Im on DSM 6.2.4-25556 Docker 20.10.3-0554

That should work. I was running the same versions before I updated to DSM 7.0.

Thank you so much for trying to help.
I have been digging into settings and my Impact Firewall settings were blocking the docker app. I managed to add rules to allow it to work and keep the firewall on. It now works again! I have been mercilessly pinged on my qnap and are very carefull so need to keep it on...


Wow, this is great. I read almost everything here for quite a while and... got everything working within a couple hours. So my question is...

Channels Server is on a very old iMac that can't run Docker. My Mac mini is running it - it stays on all the time anyway, so no worries. I was able to point Channels to the files being served up on the Mini no problem!

The question is - now that I have the image running, can I close out the terminal and just keep Docker running? I believe that's the case.

The other question is... when this machine restarts, will I then need to run that same command line or will Docker restart and run it until it actually is instructed to end?

Version 1.2.2 is up:

  • Mogrifies movie genres to conform to major top level genres in Channels

This helps fix Pluto movie genres so they conform to those expected in Channels so that they show up in the new On Later browsing.