Pluto Guide info not updating

Hello! I added Pluto channels (without docker) using the instructions here:

The guide does not always updated. I tried increasing the frequency but I still have to update it manually. Any help would be appreciated.

Use a different solution like docker or

Thank you for the fast reply. I haven't gone down the Docker rabbit hole yet but I need to figure it out.

Updates fine for me. I use the nocords links. Set to refresh every 1hr. It is a short guide data though, only 12hrs

Docker method is pretty easy, but the method is even easier. Just set up Custom Channels and paste URLs into two fields, no software to install. Kudos to @HankLloydRight!

I checked the guide in a browser and it worked fine. It looks like the issue was that the Apple TV app does not update unless I completely close it out. I don't know if there is a setting I'm missing for the clients.

Correct. If you don't close the app, it remains in the background but in a suspended state. If you open it from a suspended state, the guide data is not updated/blank. That is normal. At least, that is the way it has always been in my experience.

Guide fetching from the server is expensive (time wise) and is highly optimized. If you reopen the app after a long time has gone by, it will update. But not after a few short seconds or minutes.

Any time you add channels to your lineups with new sources, it’s good to just force quit and start from scratch.

I appreciate it. It was going into the next day without updating. I see why Apple does it that way but I wish it was an option to always fully close it instead of suspending. Easy enough for me but I try to make it family proof.

Fortunately, adding new Channels to your lineup isn’t something that happens very often. So it’s not too bad.

I'm not worried about adding channels, just getting the guide to keep updating. It's updated today so I'll see how it goes. The only thing I changed was to have it update every hour instead of every 3.

You’ll have zero problems with the client keeping the guide updated. You don’t need to force quit the app for this.

The issue we told you to force quit the app for was because new channels were added, which is technically only fetched when the app first starts up.

1 Like

I asked about it because the guide on the Apple TV's was not updating. The Pluto channels were added and the guide was initially populated but it would not update when needed. This was over the course of a few days. Sometimes rebooting the Apple TV worked or redownloading the guide but would shortly go back to just generic data. I'm probably missing something so I don't mean to be obtuse. Either way it's still working right now so hopefully it's all set now. I really like having the extra channels added without having to leave the app.

My similar issues always turned out to be the box the server was running on was running a VPN, never a client issue here albeit likely different hardware (Win10 server w/ PIA VPN, Shield Pro client).

Thanks for the reminder though, have been meaning to test whether this situation changed if I changed from WireGuard to OpenVPN, doing that now.

[edit] That didn't take long.

2023/05/01 11:09:25.086649 [ERR] Unexpected m3u response for Pluto: 403 Forbidden

The Pluto data at blocks PIA users, for good reason, probably. I hear they have lots of abusers, very unusable anymore. Got a multi-year deal so cheap several years ago yet here I am not even using it anymore.

I am having the same the of problem. My original post here:

seemed to have fixed the problem when I applied the Pre-release at that time. Since I have been autoupdated to the most recent stable and the Pluto TV guide data and Virtual Channels guide data seems to be broken again.
For the Pluto TV guide, it just shows generic categories for the guide data. My Virtual channels shows data but it's incorrect. If I force close Channels on the ATV and reopen, all shows fine again....for a day or so then the process repeats.
Let me know if I can provide any more info.


Interesting. Thank you. I don't have a VPN installed on the server box but I have had them cause some funky issues on my phone.

Ahh... I missed that post. Thank you very much. I was feeling pretty dumb. That is the exact issue though. I just checked and there is no guide data again. I submitted the logs.

Well, this is interesting. I can't recall the last time I had Pluto guide issues, but it started today. I'm getting partial listings, some channels there’s nothing and others are good. The logs are good too.

I think this is a glitch on Pluto's end, I went to the Pluto website and any show I click on in the live grid seems to either never start or takes a minute or more.

I suspect this is something that will be a PITA in different ways for most and tomorrow it will be back to normal.

1 Like

You didn't really miss anything. It's seems like it was fixed in that pre release but then maybe was broken again with a newer update? Not really sure.

It seems to be impacting Virtual Channels too. @jkr4m3r, you are using an Apple TV right? This is where the issue seems to be.

1 Like