Remote Scrubbing not working

I found problem with scrubbing when remote and using a firestick 4k, if you try to scrub past the buffer, it will jump back and forth and eventually stop moving forward making it impossible to get to where you want to go. For example, trying to scrub 60 minutes into a sports game from the beginning is next to impossible. As long as you wait for the buffer short burst back or front work great. I don't remember it always being like that as I've slowly replaced all my clients with apple TVs which don't have the issue at all.

I love the software and don't want to sound like I'm complaining, I just thought I would bring it to the attention of the developers. The firestick travels a lot better than apple tv which is how I found the problem in the first place.


Thanks for raising this. I’ll see if I can reproduce the issue in my Fire TV Stick.

Would you be able to make a short video so I can make sure I’m doing the same thing when I test?

Hi Eric,

No problem. I made a video and put it on YouTube here:

I also submitted diagnostics for the video player right after making the video at around 10:46 PM PST.

This is very helpful and not at all what it should be doing. We got the diagnostics and will look into what's going on here.

We’ve released a new Android beta that should fix this issue:

Let me know how it works for you.

1 Like

I downloaded installed the beta from the support page of the current channels app and I can't play anything from the beta. I get playback failed (-17). I just submitted diagnostics for the video player again. 5:07 pm PST.

The beta version 4.3.1-v305241937.

Thank you for working on this.

Edit: I now see the date in the beta version

I now cannot play LIVETV getting the same error.

Looking into the diagnostics.

Ok I am using release level. Let us know when you have a new beta.

Next update fixes the error. Sorry about that.

It’s not quite fixed and this is what’s it’s doing now:

I submitted diagnostics right after the video, 5/24/22 9:37 PM PST

Very odd. I’ll look into that one next.

I tried my Tivo 4k streamer, the release app has the same problem as the fire tv 4k, the beta works perfectly.

1 Like

So one of your devices works properly on the beta and one of them doesn’t?

I've been able to reproduce this issue. The fix for this doesn't look obvious, so we're going to have to dig into it further.

My Firestick 4K and Tivo 4K have the same issue as my OP on the release app. The beta fixes the issue on the Tivo 4K, but not on the Firestick 4K which has issue on my second video post 11.

My Apple TV’s don’t have the issue at all.

Could you try it again on your TiVo 4K and see if you can cause the problem? I'm very confused how this could be device-specific.

As another point of reference, the beta version scrubbing works very good for me on my FireTV 4k Max. Although, when automatic commercial skip is on, it does sometimes jump through the commercial gaps and sometimes will jump into them. I do like it that way, gives a method to view skipped parts if desired.

Ok, gave it another shot. For home streaming the Firestick 4K beta app works perfectly. If I route it through "away from home" remote connection that is when the Firestick 4K exhibits behavior like my second video.

I think the TIVO 4k and Firestick 4k have the same behavior, its the remote part that causes the weird issue.

Update: I’ve been able to reproduce this issue on the Apple TV so it gives us a better idea of what part of the code base the issue is coming from.

Thanks again for this report!