Stereo Pair (Echos) causing glitches

When I use a stereo pair of echos connected to the fire TV 4k, it causes glitching, stuttering, and out of sync audio. Anyone else have their fire tv setup with a stereo pair? Would using the fire TV cube be better? It's like the fire TV 4k stick isn't powerful enough to stream the audio to the echos and play content on Channels DVR at the same time. When I turn on "gaming mode" for the audio, it routes the audio to the TV's speakers instead and everything works fine. Anyone have a solution?

I have a similar setup but I have 2 Echo Studios Paired ... but I use the new FireTV Cube and have no problems. I think the FireTVCube is more powerful than the FireTV 4K. I guess I will try to pair one of my FireTV 4K and see if it works for me.

No Problem with the FireTV 4K and the Echo Stereo speakers ... everything plays fine no audio sync issues or stuttering ... From what I read on Amazon the FireTV 4k should have no problem... Is your WFI busy as that is what is used to send sound from the FireTV 4K to the Stereo Pair. I use AC Wireless.

WiFi is okay. I figured out a solution though. I turned decoding from software to hardware and that fixed all my issues. If anyone else has the same issue, give that a try. Thanks for the replies!

Great ... mine was set for Hardware.

So I thought I fixed the issue with the stuttering/out of sync video and audio by switching to hardware decoding, but the issues persisted. I bought the new Fire TV Cube, and so far, it seems to have fixed my issues. I tried Plex on the fire stick 4k and live tv/dvr, and it seemed to do a little better job keeping everything glitch free. I'm guessing the Fire Stick 4k is just a bit underpowered to stream video and also output the audio to the stereo pair at the same time. The new fire tv cube has a little bit better specs and I'm guessing that's why I'm not seeing problems anymore. If anyone else has come across this issue with a 4k stick, please let me know. Maybe we can narrow down the cause.

Funny I had to give up using my New FireTV Cube because it is dropping frames in the Channels DVR APP while paired with my Echo Studios ... I switched to the FireStick 4K and all my problems have gone away.

I'm seeing the same issues now with my fire tv cube. It worked perfectly for one day, and then took a dump on me. There's got to be a memory issue or something if it's working properly on a fresh system. When you switched to the fire stick 4k, was it a fresh install? Is it still working for you?

It is still working ... but I prefer the cube. I just do not understand why Channels DVR is the only one having Problems on the Cube.

The Android APP is the stepchild so do not expect this to be looked at any time soon.