Tuner Not Available Error on tvOS

I am trying to watch any TVE channels from the tvOS and I get an error, "Tuner Not Available". I am able to watch TVE via, WebUI or iOS device just not tvOS device. I tried force quit app and restart. I have tried restart of the whole AppleTV and still get the error.

I tried with turner sharing on and off. Safe results.

Any Ideas?

I have submitted Diagnostic Logs.

What does the dvr log say?

nothing in the dvr log. That's why I submitted the Diagnostic log from AppleTV. I was hoping there was some info in there.

Please email us the DVR log. It will give us more details.

Logs just emailed.

1 Like

Looks like I'm seeing a lot of these errors that indicate you are having issues with your DNS:

lookup turnerlive.akamaized.net: no such host

Also, I've noticed you have some OTA channels that are not coming through very clearly:

2020/03/13 17:00:30.063713 [SNR] Statistics for "TV/Diff'rent Strokes/Diff'rent Strokes S05E02 1982-10-09 In the Swim 2020-03-13-1630.mpg": ss=99%,0%-100% snq=99%,0%-100% seq=99%,7%-100% bps=2247570,46624-7196640 pps=216,5-684

If seq= is ever less than 100% it means you're having issues with the recording.

But wouldn’t that be a problem with all of my clients then. Web UI and iPhones all play TVE no issues. But both of my AppleTVs have problems.

They different stroke recordings seem ok. I just sampled a few minutes of a few recordings.

I can try rebooting my router and see if that fixes the issues.

Can you try clicking Connect to DVR > At Home and enter the IP of your DVR server

Tried that and I get an error saying DVR not found at that up address. I check from safari and another computer in the house and can get to that IP and web ui.

I also tried remote and it authenticates, but gets the same error Tuner not available.

Sent diagnostics as well again

Can you look in your Apple TV settings and verify that its IP address is on the same subnet as your DVR server? It might also be a good test to see if you can connect to the Apple TV from a computer to see if you can view the client logs. I think the URL is http://xxx.xxx.xxx.xxx:57000/log. Replace the Xs with the IP address of the Apple TV. Channels must also be visible on the Apple TV screen.

Yes both AppleTV’s on same subnet as DVR server. 192.168.7

All other iOS clients on same subnet but have access to TVE streams no problem.

Was not able to connect to appletv from computer using url above.

Can you enable http logging on the DVR server and see what appears when the tv tries to tune a channel.

When I try to tune with appletv I get this.

[GIN] 2020/03/14 - 14:14:27 | 200 | 16.640632611s |   192.168.7.227 | GET      /devices/TVE-ATTOTT/channels/6050/stream.mpg?codec=copy
[GIN] 2020/03/14 - 14:14:46 | 403 |      27.924µs |    73.54.202.57 | GET      /devices/TVE-ATTOTT/channels/6050/stream.mpg?codec=copy

When I tune with iPhone I get this

2020/03/14 14:16:42.712840 [TNR] Opened connection to TVE-ATTOTT for ch6050 MSNBC
2020/03/14 14:16:48.620417 [TNR] Closed connection to TVE-ATTOTT for ch6050 MSNBC
[GIN] 2020/03/14 - 14:16:48 | 200 |  6.430337977s |   192.168.7.227 | GET      /devices/TVE-ATTOTT/channels/6050/stream.mpg?codec=copy

Looks like a routing issue on your network. The DVR is not seeing the 192.x address as the source, and thus rejects the request because its not from a local network.

While I have not tested this theory yet. But I think it might be related to secure HomeKit router.

The DVR, iPad and iPhone clients do not have issues with TVE channels. It is just my two AppleTV’s which are home hubs and therefor they have restrictions on access to the internet. This might explain why only these two devices behave differently.

I have not tried this because of the nasty warning message about removing and re-adding HomeKit devices across the whole house.

Unfortunately, I cannot see the access settings for these AppleTV’s for some reason. The choices are:

Restricted - only local network access
Auto - determines which connection it lets out
Unrestricted- free reign.

One of my AppleTV’s worked for a few hours without me doing anything. This is all very strange.

Is anyone else running Secure HomeKit router and want to chime in?

The latest tvOS beta should fix this issue:

https://community.getchannels.com/t/channels-4-0-beta/22082/172

Please let me know if it makes a difference.

It appears to have fixed the problem. I tested on both AppleTVs this morning.

One AppleTV was working with both the prod and beta versions of the app.

The other AppleTV was not working with the prod version. But the beta version seems to work just fine. I will keep testing today and follow up with results. Thanks for your efforts. And let me know if you need any diagnostics.

1 Like

I have submitted diagnostics for both prod and beta versions. It is now happening with iPhones and iPads.

I changed the server to disable WiFi and just use Ethernet. I restarted the channels server process (not server reboot) after that change.

Are you running a VPN on your iOS devices?

There is something very very odd going on with your network. Both your iPhone and DVR are on the same private network, but the IP that the DVR is seeing you come from is a public IP. This shouldn't be possible for a situation where you are all on the same local network, so something in getting between the devices and making your phone reach the DVR via a public internet address.

No. I have eero mesh network. No special VPNs running on network.