TVE chrome issue

Separate question: I've tried adding YouTube TV but get this error:

chrome failed to start: [0708/] NaCl helper process running without a sandbox! Most likely you need to configure your SUID sandbox correctly

This is what the logs show:

2020/07/08 12:55:11.690795 [TVE] Auth starting for YouTubeTV as [my email address]
2020/07/08 12:55:11.690934 [TVE] action=auth mvpd=YouTubeTV requestor=nbcentertainment
2020/07/08 12:55:11.710280 [TVE] action=xvfb
2020/07/08 12:55:12.148944 [TVE] Auth failed for YouTubeTV: chrome failed to start:
[0708/] NaCl helper process running without a sandbox!
Most likely you need to configure your SUID sandbox correctly

Any help would be appreciated!

Please click Support > Submit Diagnostics at the top right.

What kind of machine is this that you're running the DVR on? What OS?

6ff3d1d1-599e-4e7d-a281-3b7be215429d (There's a lot of failed stuff with Spectrum in there too but that was resolved)

Machine details:


Linux Ubuntu
18.04 (kernel: 4.15.0-109-generic)


4 cores / Intel(R) Core(TM) i5-2467M CPU @ 1.60GHz

load averages: 0.05 0.21 0.46


7.58 GB
76.0% free

Have you run apt-get install chromium-browser?

I'll try that now, I just have regular Chrome installed.

I don't get that same error but the auth fails. Weirdly enough it ends up loading the Spectrum login saying I've attempted to log in too many times. I tried removing the Spectrum TVE entry and got the same thing. I've tried both the main account which I disabled 2FA and a separate family account without 2FA. Here's the logs for when I tried with the secondary account without Spectrum TVE set up in Channels:

2020/07/08 14:27:19.852316 [TVE] Auth starting for YouTubeTV as [email]
2020/07/08 14:27:19.852469 [TVE] action=auth mvpd=YouTubeTV requestor=nbcentertainment
2020/07/08 14:27:19.875157 [TVE] action=xvfb
2020/07/08 14:27:20.415506 [TVE] action=mock
2020/07/08 14:27:20.416217 [TVE] action=navigate url=
2020/07/08 14:27:20.419110 [TVE] action=request type=Document method=GET url=
2020/07/08 14:27:20.571438 [TVE] action=wait_for_page
2020/07/08 14:27:20.627330 [TVE] action=request type=Document method=POST url=
2020/07/08 14:27:20.627364 [TVE] action=auth_domain
2020/07/08 14:27:20.817937 [TVE] action=request type=Document method=GET url=
2020/07/08 14:27:20.952959 [TVE] action=request type=Document method=GET url=
2020/07/08 14:27:21.024889 [TVE] action=request type=Document method=GET url=
2020/07/08 14:27:21.135493 [TVE] action=request type=Document method=GET url=
2020/07/08 14:27:50.571790 [TVE] action=wait_for_page err=timeout
2020/07/08 14:27:50.571896 [TVE] action=fill_form u=[email]
2020/07/08 14:27:50.572348 [TVE] action=screenshot
2020/07/08 14:27:50.572399 [TVE] action=screenshot_err err=context canceled
2020/07/08 14:27:50.572415 [TVE] action=capture_html
2020/07/08 14:27:50.572441 [TVE] action=capture_html_err err=context canceled
2020/07/08 14:27:50.576572 [TVE] Auth failed for YouTubeTV: context canceled

Interesting. Can you submit diagnostics again?

deda1906-0d83-40ce-9d5a-09dfe75d5ded Submitted

Huh this is very strange. You're trying to login into YTTV and somehow the Spectrum page comes up?

Are you using some type of smart DNS or VPN or something weird on your network?

The Channels server is also a Pi-hole server. I can try it with using another DNS like or

Same result without using the Pi-Hole as DNS. Tried restarting the server and that didn't change anything.

Is there a way to just start the server from scratch? Basically delete and start brand new.

I found the follow commands to try and delete from scratch:

rm -rf channels-dvr

And then reinstalled using the normal instructions. It looks like it was a fresh install as I had to re-login set my recording folder. When trying to auth YouTube TV I still get the context canceled error but now there is no screenshot image it's just the broken image logo.

The logs are c25a4079-0e3b-49ea-affe-239cd0c88ad7 and all I've done is set it up and try to auth YTTV with both my main account and a family sharing account.

Edit: Something else I noticed was in the YouTube TV thread @tmm1 you said:

TIP: For best results, before adding your YouTube TV account to Channels DVR, first visit and login there to authorize TVE access.

However if I go to that url the page is broken. In the logs I still see
[TVE] action=auth mvpd=YouTubeTV requestor=nbcentertainment

So is it possible something with that is causing the issue?

Try this:

Still the same error. I was able to get to and sign in with YTTV credentials and can stream directly from that site.

Same error meaning.. context cancelled?

Yeah context canceled with a broken image logo for the screenshot.

Ok, so I have isolated it something on the Linux box because I just tried installing it on Windows and it's working to auth with YTTV. I will double check all the networking configs because I have a feeling that is where the problem is.

context cancelled means you didn't follow the instructions I linked correctly.

Here's what I did:

  1. Clicked and held update which downloaded and installed version 2020.07.09.0054
  2. I then clicked add source and TV Everywhere
  3. Entered my credentials and clicked and held the sign in button which eventually disappears as it switches to the spinning green icon

Is there something I'm missing?

That does sound right. I guess you're right and something funky is going on with the network config, because I have no other way to explain why you were getting a spectrum page before on the youtube website.