TVE on ARM-based NAS

I'm getting this same error. And yes they are installed into the Applications folder.

I just tried from a windows 10 computer and get a similar error "exec: "Google-chrome": executable file not found in $PATH"

Chrome has to be installed where your DVR is running. In your case your DVR is running on a Synology with an ARM processor. That setup is not supported for the TVE feature. You would need to move the DVR to a Synology with Intel processor, or to a PC/Mac.

So will it eventually be supported? Cause I’m not buying a new synology array. If not, just take the option away. Seems like a bug you need to fix while it’s in Beta.

The requirements for the beta are listed on What is TV Everywhere?. Its possible we may add support for more platforms as the beta progresses.

Please add my support to add the Seagate NAS platform to the beta

If you're interested in ARM support, please copy/paste the OS/CPU section from the top of your DVR web UI.

Thanks. I've uploaded an experimental build which may work on your ARM NAS. I tested on my Synology DS216j and it worked, but there are a lot of different types of ARM processors so it may not work everywhere.

To try it out, click-and-hold the Check For Update button. After it upgrades to v2019.08.01.0157, try adding the TVE source again.

I tried to check for update, but it says I am up to date at version 2019.07.31.0021

It started to work, but then generated this error.
image


You have to click and hold the button.

Is there any DSM firmware update available for your Synology?

yes. I'll go apply it and the try again.

Up to date. Starts and then errors out.
image
image

DSM and Channels version info:

image

Do you know how to enable SSH access and ssh into the NAS to run some test commands?

not on this particular NAS. I'll try to look it up later. What are the commands you want run?

Run these commands, then copy/paste all the output back to me:

cd /volume1/@appstore/ChannelsDVR/channels-dvr/data/
sudo ./chromedp-shell --headless --repl --disable-gpu --no-sandbox

mine was on volume3. Here is the output.

image

1 Like