TVE on ARM-based NAS

I'm looking into some possible improvements to support TVE on more ARM devices. If you are interested in testing out the latest pre-release, please let me know.

1 Like

I don't want to hijack the thread, but I have a Netgear readynas 102 that I'm willing to experiment with if that's a model that could possibly work. @tmm1

I’m sorry, I’ve upgraded my NAS and the new one has an Intel CPU.

@bshop2 No problem. The upgraded NAS with Intel CPU will perform better than any ARM-based NAS.

@swope1221 If you'd like to try, click-and-hold on the Check for Updates button on the DVR web UI and then try adding a TVE source.

Hi @tmm1 . I tried as you said and here's what I got. Locast was no problem, however TV Everywhere has an issue. I'll attach a couple of screenshots so you can see if any of it is a help to you (or me).
Screen Shot 2020-06-22 at 7.40.51 PM

Thanks for testing @swope1221. Can you try this:

  • click-and-hold on Check for Updates to upgrade again
  • after the upgrade, click Add Source > TV Everywhere
  • fill out the form but don't hit enter
  • click-and-hold on the Save button

Will this work for Verizon credentials? I have 2 fios cable at another home but am trying to use login in a second home. Keep getting an error message. Also I do not see a save button. I am using a WD Mycloud home as my DVR.

Hey @tmm1. I did as you said, except I didn't see a save button, but I'm assuming the sign in is the same thing. I did click and hold but it eventually went to verifying. At the end I got a similar error to before but now it says 4, not 11. I'll attach screenshots.Screen Shot 2020-06-22 at 8.40.07 PM Screen Shot 2020-06-22 at 8.41.07 PM

Sorry I meant the Sign In button. Please try again with v2020.06.23.0001

Hi @tmm1. It's hard to see in the one screenshot, but that's the version I'm on.

Hi again @tmm1. Just for your troubleshooting purposes, I have tried rebooting my NAS, uninstalling and reinstalling channels and then updating to v2020.06.23.0001 before trying your suggestions but still get the same error message. Tag me if/when you need me to try anything else. Thanks for your continued efforts on this.

I just installed this on my ReadyNAS that has 4 cores / ARMv7 Processor rev 4 (v7l)
Version 2020.06.25.0029
When I try to add Philo I click confirm on the email. The DVR changes to verifying logon and then says "no login form found"

Could you click Support > Submit Diagnostics

Logs have been submitted as f9a2f296-bef4-4d32-9a56-1777105bd50b

Interesting, thanks. Could you SSH and run this command:

cat /etc/resolv.conf

And paste the output shown here?

Hi @tmm1. I updated to version 2020.06.27.0310 today and now I get this error message on my Readynas. It went from an error message previously posted in this thread and shared in a pm with you to now back to saying TVE is not supported on NAS with ARM CPU.

We had to roll back to the previous code because of issue and will be revisiting this next week.

Unfortunately it seems if you were seeing "signal 4" then the CPU is too old and we won't be able to make it work. There is a feature called NEON which is available on all newer ARM processors and that's required to be able to make this work.

Thanks for the reply. I wanted to know where it stood and before I decided to make another investment. Much appreciated.

~# cat /etc/resolv.conf
Generated by Connection Manager

I just updated my Synology 214 NAS to the latest Channels software (2020.08.06.1811) and get this error when I try and add my cable login to TVE:

chrome failed to start: ./chromedp-shell: line 4: /volume1/@appstore/ChannelsDVR/channels-dvr/data/chromedp-chroot/proot: cannot execute binary file: Exec format error ./chromedp-shell: line 4: /volume1/@appstore/ChannelsDVR/channels-dvr/data/chromedp-chroot/proot: Success

Any ideas?