Updated to DSM 7 and Channels for DSM 7 Beta Movies do not import

I have updated my Synology 1515+ to DSM 7 and updated the Channels Package. My local Movies are not importing and generating the following error.

2021/12/12 16:07:31.823941 [ERR] Scanner error walking /volume1/Movies: open /volume1/Movies: permission denied

I tried copying all the special permissions from the Channels DVR Folder.

You help is greatly appreciated.

If you installed the new package, you must grant permissions to the internal channels user created by the new package.

image

I am assuming you mean the to "Edit Shared Folder Movies" access under "Advanced Share Permissions" for the specific "Movies" folder created outside of the DVR folder where Channels saves its recordings.
That did not work I still got the same error. Also looked under the Users for the NAS "Users and Groups" there was not an internal user settings to enable.

2021/12/12 17:04:26.023876 [ERR] Scanner error walking /volume1/Movies: open /volume1/Movies: permission denied

Thank you for the suggestion and your time looking into this.

you could delete channels and reinstall. For me this fixed issues I was having. DSM 6 was using root and 7 is a user. I had issues when I upgraded also. I just deleted and reinstalled and then added the permissions above for my local content and all works as expected. Hope this helps.

I think there is some confusions here maybe? Volume1/Movies doesn’t sound like the Channels DVR folder where it does all of its stuff, the default naming format is different. That looks like a folder you’re trying to import movies from? If so I would expect granting the “channels” users read/write to it (and all sub folders/files) should work. Did you do a fresh install of the DSM 7 package or did you upgrade over the DSM 6 package?

Can you share some screenshots of the settings page that shows both the DVR storage path and the imports paths you have configured?

Hello everyone and thank you for the help. Volume1/Movies is the folder i am trying to import movies from. I also upgraded over the DSM 6 package. Here is the setting I missed and how to get to it in three steps.

Then I edited the SYSTEM INTERNAL USERS.

image

Here is the setting that enabled Channels to see my Movies folder.

image

Thank you all very much for the help!

4 Likes

Deleted post...