Very low bandwidth

Unusual problem cropped up watching a recording of The Simpsons on Sunday. It LOOKED like the show was being viewed with a 1 or 2 Mbps bandwidth. Lots of micro-blocking around the lines. Even a very low transmission rate is fine for animated shows since they utilize very simple graphics, but this was pretty bad.

I was about to fire off a tersely-worded message to the station when I thought, "hey, I could check my backup recording that used WMC!" Sure enough, the picture was almost pristine. Very close to the picture you'd get streamed straight from the FOX app. Sharp lines, solid colors, just a tiny amount of micro-blocking you had to squint to see.

Last week the picture looked fine. The one major change I made this week was to revert from the latest Fire TV Cube back to the Fire TV Max due to a bug in the Cube. The picture also looks fine on my phone and my other TV - a 48" TV in bedroom that uses a Fire TV 4K.

I re-installed ChannelsDVR.

Anyone else experiencing this? It's less apparent on non-animation, but it's there.

1 Like

I'm watching The Simpsons on a 120" Hisense TV using a Fire TV stick 4K Max. This TV also has Google Play built into it, so I thought I'd try that with the ChannelsDVR app for that platform.

It worked just fine. Maybe only slightly less sharp than the result I got using WMC. But perfectly acceptable.

So it's looking like something in the latest update for the Fire TV stick 4K Max is doing something fishy. It currently has the highest firmware number of all the Fire TVs - even higher than the newer Cube.

I suppose I'll spend another hour rebuilding the Fire TV back from factory settings.

After restoring the Fire TV stick 4K Max to factory defaults, no improvement was noticed. That stick is using the very latest firmware

I went back to using the latest Cube which is on and the picture was just fine. It's a little buggy, but at least the picture is good.

So in my uneducated opinion, ChannelsDVR isn't wholly compatible with the Fire TV stick 4K Max using the firmware.

I have no problem with any of my FireTV devices including the max sounds like you have a network problem are you using Wireless. ?

Try speed test from your FireTV to the DVR and post results.

Change Settings > Playback > Advanced > Video Driver to Software

This type of problem is very common with FireTV devices whenever they update the hardware firmware

I also use the FireTV Max devices all with the current software version and I haven't seen any problems with any of my recordings. I don't have any Simpson's recordings though. I have been only using the Hardware video driver in the Channels client software.

1 Like

I use Hardware on all My FireTV devices also.

The ChannelsDVR shows 200 Mbps.

Do this: update to the very latest firmware (, record an animated show, watch.

Worked fine before upgrading to Fire TV stick 4K Max
Works fine using newest Cube.
Works fine using older Fire TV stick 4K.
Works fine using WMC.
Works fine using Google TV.
Appears to work fine watching on phone locally (although the tiny screen might make it impossible to see defects.)

EDIT: Works fine on Chromebook

It's not related to animation, has to do with your specific mpeg2 broadcast. Switching to software will fix it

It worked! Switching to software seems to have fixed it.

where is this at? on the fire stick? or the channels settings?

Channels app on fire stick