WDMyCloud Single Drive


You have to keep one of them off of bonjour. That way only one server is advertising itself at a time.


That is what I did for the quick test. Of course that disables our main DVR that my wife uses. So this limits my testing to when we do not need it (for playback on Apple TV) which should not be a real problem for limited testing.

This is not a big deal to me but you may want to consider a “settings option” to pick which DVR to use.


Here’s how to install on single-drive WDMyCloud. Only works on gen2 models (check if the firmware is version 2; gen1 models use firmware version 4 and do not support apps).

Open the WD my cloud interface in your browser. Click on the Shares tab. Create a new share called “DVR”.

Click on the Home tab. Then, in the URL bar, delete what’s there and type this:


(If you try to copy/paste, the browser will delete the javascript: part, so make sure you type that back in.)

Now click on the Apps tab again. You will see a new section appear on the top left called “App Store”, with a link underneath that says “Install an app manually”. You will see an agreement pop-up, but the Accept button doesn’t work.

Delete what’s in the browser bar, and type this (remember to re-type the javascript: if you copy/paste):

javascript:APPS_EULA=1; check_app_eula()

Now hit the Cancel button, and then click on “Install an app manually” again. A file upload will pop-up letting you upload the DVR app to the NAS.

Download this file and upload it to your NAS:


Once installed, you can click the Configure button then login to the DVR. On the left click on shares and then select the new DVR share from the list and click Save. Your DVR recordings directory should be set to /shares/DVR

Now enter your zipcode to set up your HDHomeRun’s guide data.

Once the initial setup is complete, a new “Commercial Detection” option will appear on the Settings tab near the bottom. TURN IT OFF. This model is not powerful enough to run commercial detection and it will cause your NAS to become unusable.

You should be up and running now. Note that the NAS is too slow to transcode, so DO NOT use the “Watch Now” feature from the web admin.

Cheapest NAS Option
Setting up Channels DVR

When I complete the first step (clear the URL bar and type the javascript command) I’m presented with a webpage with the number 1 displayed in the top left corner and that is all… I hit the back button and am returned to the homepage, I then go to Apps and there is no new section titled “Apps Store”. I’m running firmware version 2.30.165 on my WD MyCloud 4TB single bay NAS.


What browser are you using? Please take a screenshot and email to [email protected]


I’ve tried with both Firefox and IE11, not Chrome yet. Screen shot sent along.


And… as I was typing that I then tried Chrome… bingo! Stupid Firefox and IE11!


Good to know it only works in Chrome. Thanks!


I have tried in chrome but I cannot get this to work. It appears they may have redesigned the mycloud user panel. I do not see anywhere that it allows for a website address to be typed into as suggested.


It’s not in the interface. You type it into chrome where the URL shows up.

These instructions are for MyCloud, and do not work on MyCloud Home.


just got a channels dvr subscription and trying to set it up on my WD my cloud. Followed the instructions and got as far as the agreement pop up. At that point had to leave when I got back tried to reinstall again and never could get the( app store) to reappear on the app’s tab again. I’ve tried several times with no luck. Any idea’s?


Are you using Chrome?

Do you have a mac or a pc? I might have another way to install from the Terminal.


Thanks for the quick response. I have a PC and I was using chrome


The other method would only work on Mac/Linux.

If you got the Apps tab to show up before, I’m not sure why it would not work anymore. Did you refresh the browser and try the steps from scratch?


yes, I managed to get to the agreement but when I hit cancel and install an app manually again, there’s no file upload. Just to make sure that second entry into the url EULA=1;check or EULA=1; check? No space after semi colon


Shouldn’t matter if there’s a space or not. You can also do them separately:


Can you snap a screenshot and email to [email protected]


I found another way to install packages over ssh. Do you know how to ssh to the NAS? You will need to enable ssh in the settings and then use an app like putty.

wget -O /tmp/channels_dvr.bin https://channels-dvr.s3.amazonaws.com/wd/WDMyCloud_ChannelsDVR_1.0.5.bin
upload_apkg -d -s 1 -p /tmp/channels_dvr.bin

  1. Go to the NAS webpage
    This is usually available at http://wdmycloud/ or http://wdmycloud.local/. If you know the IP address of your My Cloud you can also enter that in your browser’s address bar. Log in once you arrive at the page.

  2. Enable SSH support
    Go to the Settings page, Network, and set SSH to ON.

Security: Some NAS products use a default username and password for SSH. The NAS should be on a home network firewalled by a home router.

  1. SSH into the NAS box
    Open a terminal window and type “ssh [email protected]” or “ssh [email protected]”, e.g. “ssh [email protected]
    Log in with the same password you use to access the web interface.


I added the channels premium TV option and now I keep getting “Sorry, your channels DVR computer is not powerful enough to compress video for remote viewing” message. Any ideas on how to fix that? I’ve tried restarting the whole kit without any success. It worked for a while until the guide updated the premium channels information.

HDhomerun Extend is on version 2018.09.19.0236 and the Channels App is on Channels 3.2.6


Are you streaming remotely? Either click logout from remote DVR or set the quality to original


I’m not streaming remotely, on the local network on the Apple TV channels App