Windows DVR BUG: Glitches during recording


#61

I can test it once you have something for me to try.


#62

The bug I found only happens on the Windows DVR, only when recording from a PRIME, and only when also trying to watch something from an ATV4 connected over Ethernet.

If you meet the above criteria, please post the name of your network adapter being used on your windows machine here. I’m using a “Realtek PCIe GBE Family Controller”


AppleTV Stutters BAD with recordings, Computer Plays Fine
#63

Also check what the device setting for FlowControl is set to on your adapter’s advanced settings. For me, the default was “Rx & Tx Enabled”.

In adapter properties, click Configure, then on the Advanced tab, then click Flow Control. Check the value on the right.


Dvr recordings towards the end are choppy
DVR recording jumbled when watching in progress
Recordings breaking up
ATV hangs on specific recording
#64

I use the Prime and ATV4s are connect over Ethernet. I connect using the following adaptor.

Intel® Ethernet Connection I217-LM

I checked the flow control and it is set to Rx & Tx Enabled


#65

My system has an Nvidia nForce Networking Controller. Flow control is disabled.


#66

Changing Flow Control to “Disabled” seems to fix the issue.

I am trying to narrow down the problem further, so it can be fixed in the PRIME firmware. I also have an idea for a workaround I can add to the DVR for this case.

The problem appears to be that ethernet flow-control kicks in because everything on the network is gigE, but Apple only put 100mbps port on the ATV4. Somehow this is affecting the DVR<->HDHR communication, even though its the ATV<->DVR connection that is limited to 100mbps.


#67

I also have the Realtek PCIe GBE Family Controller and is enabled. I connect Ethernet from router to atv4 but wireless to router from windows 7 pc and have been experiencing the same issues as above. I just thought it was my wireless connection.


#68

I have an Intel 82579LM and has an Intel driver where I have to pick advanced tab, then pick Performance Options, then pick properties again to have the ability to change setting for flow control. I have disabled it for now to see what happens.


#69

I have these same glitches using a hdhomerun connect with cable attached for local channels. Would these potential solutions also work for the connect?


#70

I use CONNECT and experience the issue. This is not limited to PRIME.


#71

I know some of you are having issues with the CONNECT. So far in my testing, the steps I am using to reproduce glitches on PRIME recordings do not seem to affect the EXTEND or CONNECT. This could mean the CONNECT bug is a different one, or that it’s just not happening on my setup because of the switch I’m using.

Could you folks provide more details on your setup? Is your ATV4 wired in? What kind of switch/router are things plugged into?

It’s definitely worth trying to disable Flow Control as well to see if it makes any difference.


#72

ATV is wired to a Verizon fios gateway router. Just disabled flow control. We will see if that works


#73

I haven’t noticed a glitch, but I will post my setup since it is Windows 10. I have a Prime and Connect both connected to a 1gig switch. The computer is wired to same switch. From the same switch I have a MOCA 2.0 adapter to get the internet to my other locations. The ATV’s I have are both wired. The ATV’s are then plugged into a 1gig switch. So: 3 1gig switches and 3 MOCA 2.0 adapters.


#74

Any difference with tonight’s recordings after disabling Flow Control?


#75

Fingers crossed!!! So far so good!!! No glitches observed since turning off flow control.


#76

Recorded 24 last night and no glitches. Started watching a few minutes in. Last week I started watching about 30 minutes in and there was a glitch around that time. Looks good so far


#77

@Phillip, @Jay78412, @GaryS any luck with the Flow Control change?


#78

I haven’t recorded much lately. But last nights recording flawless. I have a few more to watch and will let you know.


#79

I’ve been investigating this issue some more, and it turns out it has nothing to do with the HDHR or our DVR. Here’s a good article which explains what is going on: https://www.smallnetbuilder.com/lanwan/lanwan-features/30212-when-flow-control-is-not-a-good-thing


#80

Two items that are barely mentioned in the article as well:

  • Update your NIC drivers. Some NICs have the capability to control flow control but the older drivers did not expose the flow control interface. Many times the drivers from the MB/PC manufacturers are crippled or are not the latest. Best to get the drivers from the NIC chipset makers.

  • Not all unmanaged switches are equal. Some for example only have a single path bridge between the 100mb and the gigabit backplanes; essentially causing all traffic crossing the bridge to have to “wait”/pause.