YouTube TV: Cable provider authentication failed

Have you tried the non-docker Channels? I've been using Channels installed from the Synology Package Center without issue. I have YouTubeTV.

I run Channels DVR on a RPi. Have used YouTube TV via TVE for over a year and slowly had issues with one channel after another not working. A few days ago I stupidly deleted the source and tried to reload it. It won't load saying my browser is not secure. Contacted Channels help and eventually was told it is a YouTube TV issue that they could do nothong about. I am able to log into individual apps (Fox Sports, ESPN, CNN, etc), so it's not a user/password issue.

I do have another TVE account through Optimum that works fine (but not a lot of channel content). I also have an OTA antenna setup with a HomerunHD, so I get all the basic channels.

Bottom line is not to waste your time trying to get YouTube TV via TVE, at least on a Raspberry Pi, if it's not working for you.

1 Like

That is what I am using now on my Synology NAS. Stopped working a few weeks ago with that error about Cable provider authentication failure. I was going to try the docker version of Channels but just never got time to mess with the setup. Whole thing seems hit or miss as some stated they are fine on the Synology NAS using the Channels app.

I run non-docker Channels on Linux. I have been losing a few channels (NFL, FS1) lately which I can't reauthenicate ("browser or app may not be secure"). I tried different versions of Chrome/Chromium with no change.

I tried running the docker version on the same computer and I added YouTubeTV and all channels authenticated. So I guess I will be migrating to the docker version. What's the best way to do that?

But I still can't watch or record the NFL network. I get this error:

2023/09/03 04:09:41.584427 [DVR] Error running job 1693714161-ch6192 NFL Football: Failed to download segment 14: Get "skd://3784bf0b7307ebaf9363ec0fded91744": unsupported protocol scheme "skd"

I'm on the latest pre-release.

I got my current setup migrated to Docker now. NFL Network still getting that error.

Did you submit diagnostics for that?
Using Xfinity I can auth and stream at the nfl live site, but Channels errors out on channel 6192 with no stream available. [HLS] Couldn't generate stream playlist for ch6192-dANY-ip172.18.0.1: Stream stopped
Getting an unsupported encryption method error when trying to record. Created a topic and submitted diags here NFL Network Stream not found & unsupported encryption method

Any solution to this, I've disabled 2FA

You might want to state what "this" is.
Are you unable to add YTTV to Channels, or are specific channels failing to auth or stream, or ...

I am unable to add YTTV as a source for my DVR on RbPi

1 Like

Having the same issue here as well, unlinked my YTTV account and getting the dreaded "This browser or app may not be secure" message. I've connected to channels web interface using https, don't have ANY 2FA on my google account, and just updated to the latest pre-release version of channels. Anything that we can do? Willing to try anything at this point.

Probably won’t work but this is what I’d try; change your password with ytttv then use your cell phone data for a hotspot and attach your server, reboot the server, scan tve with updated password, switch back to home internet.

1 Like

I just signed up for YouTube TV and had zero issues adding it as a source. I have the server installed on a Mac Mini 2 and set it up on my iPhone. I have 2FA turned on and when I plugged in my credentials the first time it failed. I did it again and opened the YouTube app on my iPhone to authenticate the sign in as soon as I put my credentials into Channels again. It allowed me to approve the sign in within the YouTube app and started scanning my channels.

I hope this helps!

Great that it works on the Mac. I think it is fine on a Windows install as well. Appears issues we are seeing are specifically related to using the native app (non-docker) on a Raspberry Pi or Synology NAS. Even that is pretty random it seems as others reported no issues at all. I know a few with the issue have submitted logs and emails to support but looks like it was YTTV that changed the type of browser that can be used to authenticate to their service now. Those lucky enough to have set it up a few months ago are probably still okay until they attempt to reauthenticate or like I did, pause YTTV for a couple months over the summer then restart the service when football season kicked in.

It seems to be an issue with some linux-based installations, like RPi or Synology. I started having the same issues on my server running Arch Linux. I could authorize TVE channels manually using Chrome, but it would not work through Channels. I switched to the docker version of Channels, which fixed the issues. The docker version is also running on linux though (Alpine Linux), so why does that work and others don't?

Maybe the version of headless chrome being used. Was in my case with the Synology package install using an older version (v97) vs. running it in a docker container (v109). Constant issues authing Discovery Network channels until I migrated to the docker container.

I currently have a RbPI with the DVR installed, I can’t get YTTV to work. How can I change my Pi from the image install to a docker install? I’m using an external drive attached to it as well.

My Synology installation of Channels with YoutubeTV TVE credentials has been uneventful and flawless. That is with a DS220+ with DSM 7.2-64561. No VPN. No special chrome install. Not using docker (for ChannelsDVR). 2FA is off. Spectrum as internet provider. Of course dynamic IP, though I have manually assigned the Spectrum DNS server addresses for good measure. Using the Synology firewall using basic recommended settings found at Synology: How to Correctly Set Up Firewall on DSM 7 – Marius Hosting. I went in to moving from Spectrum Cable to Philo to YoutubeTV expecting a nightmare. But it has been great for several months with Youtube.


Add me to the list of not working YoutubeTV on Mac Apple Silicon M2
I got screen displayed that google wants to confirm I am logged in on this device even when I confirmed in another browser that yes this is trusted device.

download the latest pre-release and see if the attempted fix for this issue works.

No, it still not work