Beta: HDR playback on Apple TV 4K

In the latest TestFlight build v7.3.203 from the Channels for Apple TV 4.0 Beta, we have added a new setting:

Settings > Playback > Advanced > Video Driver: Experimental

With this enabled (and Match Content > Match Range: Yes set on your Apple TV settings), imported movies in 4K UHD HDR10 will switch the TV into HDR mode and will play back with full HDR colors.

Share your experiences with the experimental video driver below.

1 Like

Just tried to playback a UHD movie, HDR kicked in as expected and picture quality is great. One observation though, when I paused the movie then using the scrubber jumped forward to approx the 1/4 mark of the movie, then click play, the movie would not play from that point. In fact it just seems to hang at the point I paused. When scrubbing forward in smaller stages it seems ok, say 5 minutes at a time. Tried with a couple of different movies and get the same result. Maybe data not caching in fast enough. My Apple TV is connected via an Ethernet cable directly into my network hub.

I tried that and had the same pause. It eventually started once but the other time it just sat there.

In addition to this issue, I’m experiencing a glitch when playing back non UHD content towards the top of the screen. It happens when playing back OTA or an imported movie. If I switch the experimental video player off the glitch is gone. It’s a flicking of the screen image that occurs every 10 seconds or so. I just downloaded the latest beta release 7.3.1621 and observed this playback issue, not sure if it happened on the prior release as I literally updated the beta twice in the space of 30 minutes or so. Also, with the experimental video player on, some OTA channels now have large black borders down the left and right hand side of the screen, less than 4:3 aspect ratio. With experimental video player off these channels play full screen.

The glitching you're describing should be fixed in 7.3.1815. Let me know if you see it after updating to that version.

For the aspect ratio problem, a photo would be helpful.

Hi, yes looks like you guys have resolved the glitching in the latest build. I have attached some photos that depict the aspect ratio problem. I can confirm that this only occurs with SD channels. HD channels all playback full screen. You can see that with some channels The image is not even 4:3 aspect, and the image is not scaled correctly. With the standard video player enabled all of these channels playback full screen and look fine. image image
Sorry about the photos being upside down.

1 Like

lol! You gotta watch it, I thought your issue was that it was rendering upside down!


I’ve noticed a few issues with the experimental video driver enabled while watching live tv. The screen appears to have tearing issues pretty regularly while viewing live tv. It continues to play just fine with the exception of the banding/tearing issue. As soon as I turn the experimental video off, the live station plays fine. Not sure if it matters but I use a cable card with a HDHomerun tuner for Channels DVR.

Things I’ve tried:

  • turning off match content (Apple TV)
  • turning off match range (Apple TV)
  • changing resolution to 4K HDR, 4K SDR
  • changing all settings and rebooting Apple TV
  • Updated Channels server and full reboot of both PC and Apple TV

Is anyone else experience this issue?


Thanks. I was able to reproduce this on some channels and have some ideas on how it fix it.

1 Like

Please try 7.4.2029

Hi, just downloaded 7.4.2029, switched to the experimental video driver. Unfortunately SD channels are still presenting the black bars with incorrect aspect ratio. Included another photo for you.

Could you click Support > Submit Diagnostics immediately after playing that channel.

Ok just submitted diagnostics

Does it happen if you make a recording and then play that?

Please try 7.5.153

Hi, this build has fixed the issue. Many thanks.

Sorry, a bit premature with my reply. SD channels are now rendering at full screen using the experimental video driver, however, the image is not stable, it’s tearing and juddering which doesn’t happen using the standard driver. I have just submitted diagnostics after playing back some live OTA content.

Thanks! Please try the latest beta 7.6.150 which should fix the picture issues.

1 Like

Yep, looks like you’ve fixed the issues.

1 Like